Solution to Reverb G2 Audio Drop Out!

After many months I have finally found the solution to the audio and screen drop out issue with my Reverb G2, I am talking about the constant volume icon popping up with a freeze of the sim which occurs in all games.

The problem is that the motherboard RealTek HD Audio device is competing with the Reverb G2, so it starts switching between the two. Go to your BIOS and disable the onboard audio device (typically called HD audio device or similar in Integrated Peripherals on an AMD motherboard. You only need this if you are using the 3.5mm jack ports on the back of the motherboard, otherwise disable it. If you are using the 3.5mm connections then you will need to use your audio 3.5mm out on your monitor instead which gets its source from DP/HDMI. Any USB headphones will be fine as they have their own device drivers separate to the motherboard one.

The issues came back! The real solution was to get the new cable from HP.


Are you aware of the recent G2 firmware update?

“Resolves a potential issue where displays may flicker or go black when playing certain titles at high volume levels.”

Yes I was fully up to date on all firmware/drivers/software on the entire stack. X570 AGESA as well. Nothing solved that issue except this disabling of the motherboard audio device. My issue was happening at any volume level.

I have the same problem and tried to disable onboard audio aswell, but it didn’t work for me.
I also deactivated other audio peripherals in the device manager (Nvidia driver through hdmi, Oculus audio driver for my Quest 1, Virtual Desktop audio driver).
I have the latest Reverb G2 firmware which gives me even more audio drop outs, and not only in MFS, I now have them in War Thunder too, but in WT only audio drops, no black screen.
I ended up ordering a powered USB 3.0 hub, I hope it will do it for me, as I read that it had solved many issues for some users. I should receive it today or tomorrow, I’ll keep you updated!

PS: my mobo is a Gigabyte B450 DS3H, I think it might be the culprit.
Other specs: Ryzen 5600X, 32Gb, RTX 3080, Reverb G2

For the time being please deactivate pci express 4 in the bios (force pci express 3 linked to gpu and ssd m2 if you have one). Then connect the g2 to the fastest usb 3 available (usually the one next to usb c port on the mb). The connection should be more stable. I tested it successfully on my rig.

I was about to give your tip a try, just to find out that my bios only proposes from auto to Gen3.
I have the latest bios (F61a), in a previous version (F42h) it was mentionned to take Gen4 in charge, but I read on a forum that Gigabyte was due to disable Gen4 on B450 mobos, because of reliability issues.
The B450 DS3H is quite old, I feel lucky enough that it got updated for the latest Ryzen Gen. It even received the resizable bar support, but it reboots when I activate it ^^’.
Hopefully the powered hub will do the trick, otherwise I’ll be good for a motherboard update.

If you opt for a new mobo then maybe stick with b550 rather than x570 as the latter have a lot more pcie issues that aren’t fully resolved.

Sorry to hear that. I’m on b550 and I thought it was the same on b450. It did the trick for me.

Well… it looks like I’m out of luck. I received my USB 3.0 powered hub, when I try to connect the G2 through the hub, I get the 7-14 error I didn’t have while being directly connected to the motherboard (only one of the 4 rear USB 3.0 ports works though!).
I plugged back the G2 to the only USB port of my motherboard it accepts.
I unistalled it to see if ever I could then install it through the hub… nah, 7-14 error again…
Unfortunatelly, my RTX 3080 doesn’t have a type C port.
I wish I could roll back to a former G2 firmware, I had less frequent issues!

Turns out we can roll back to firmware v.14 (latest being v.15), I’ll let you know if it’s any better

It sounds like you are still solving the issue I first had which is getting a stable port working, even with a stable port I got the audio conflict which was separate and solved by the HD audio device.

I just had a couple flights, I feel that I had less drop outs with firmware v.14.
Than, I tested your solution again but the other way around: I disabled the sound of the headset!
I had 10 minutes of uninterrupted flight and then again… 2 short black outs.
Maybe I’ll try again fidlling with audio drivers, but I think I’ll wait further updates before investing in a new motherboard, too many people seem to have problems of any kind!

There seems to be too many variables, with a side of random, to accurately diagnose these.

I had mine pretty much eliminated previously, by downgrading to pci-e gen 3, and plugging into a specific usb-a plug using the usb c-to-a adapter.

Then i received a new cable, and a usb hub from HP, and thought I’d try with latest of everything (G2 firmware, x570 firmware, latest nvidia driver, WMR portal, etc.). I enabled pci-e 4 again, and found the black outs did not occur. I was happy - until the next flight where they started again, really badly. Then tried a few different settings, including going back to pci-e 3, hub/no hub etc.

It’s mainly under control now, but still worse than before. Basically results are not dependable, and just when you think you got it worked out, next flight is different :slightly_frowning_face:

I guess I’ll go back to just flying, living with the occasional blackout, and hope HP/Asus/MS get their **** together soon…

1 Like

Well I lose all aircraft and environmental sounds when I switch to VR but I still get the annoying music and system warning “bing” sounds when a warning pops up but and other than that complete silence.

I have never had VR issues in any other game on steam or non steam like DCS or Xplane 11.5 or P3d v5.

Since this is one of the top search results in google for this issue I just wanted to possibly help others in the same situation by describing my experience.

Disabling the Realtek audio in the BIOS worked - ONCE. But the issue quickly came back and persisted.

Here’s my permanent solution: I bought and installed a powered PCI-E Fresco Logic USB 3.0 Expansion card and connected the Reverb G2 via that. This solved every single issue I had with the Reverb G2, and everything has been rock solid since.


For my case, with the latest Asus X570 bios and Nvidia drivers, i can run PCI-e without audio drop out and/or blue screen, and everything smooth.

Hi guys, I wanted to give a little update on my situation, it might help other that have the same issue.
Just like bj00rn, I bought a PCI-E expansion card that solved everything!
Unfortunatelly I had a micro ATX case, so I had to get a bigger one to fit the additionnal card, and as I also have a micro ATX motherboard and a big RTX3080, I had to buy a PCI-E X1 90° cable as the graphics card is hiding the additionnal PCI-E slots.

To sum it up:

  • USB powered hub: tried, didn’t work
  • PCI-E extension card: works like a charm!

The card I bought: SupaHub PCI-E USB 3.0 expansion card (4 ports).
(It has an internal SATA power supply that I didn’t have to connect, it seems that the PCI-E port gives enough juice.)

1 Like

So, as I’ve had my G2 for less than 24 hours, get no sound when playing MSFS, and more than half the time my controllers are unseen/don’t come on, should I buy this now or are there other options?

5JUL Ryzen Master, Afterburner
UserBenchmarks: Game 104%, Desk 104%, Work 98%
CPU: AMD Ryzen 5 5600X - 100.3%
GPU: Nvidia RTX 2060 - 99.9%
SSD: Intel 660p NVMe PCIe M.2 512GB - 174.2%
SSD: Adata SU760 512GB - 114.6%
RAM: G.SKILL F4 DDR4 3600 C16 2x8GB - 97.8%

For those with AMD connectivity issues, including sound drop off or blue screen you need the Omnicept cable. I just got mine today and after 6 months and 6 different headset it finally works in every usb port. My previous G2 had the audio switching sources then the blue screen before finally giving up complete.

The cable is from HPs more expensive headset and is available to all G2 owners under the warranty. Just call them up (can be harder than you think!) And ask for the rev 2 cable. If they don’t know what you are talking about mention there is an engineering authority regarding this and they need to refer to it.

It can be explained better in the link below but I can confirm it is a solution. Please note this is the official hp support forum and the posts has been closed as solved. Same with a few more if you want to look.

1 Like

I just got my G2 yesterday. Can I assume I have the Rev 2 cable or is there a way to check it? Unbelievable! I just checked the link and I clearly have the older cable!!! Thanks for the information.