Solution to Reverb G2 Audio Drop Out!

Since this is one of the top search results in google for this issue I just wanted to possibly help others in the same situation by describing my experience.

Disabling the Realtek audio in the BIOS worked - ONCE. But the issue quickly came back and persisted.

Here’s my permanent solution: I bought and installed a powered PCI-E Fresco Logic USB 3.0 Expansion card and connected the Reverb G2 via that. This solved every single issue I had with the Reverb G2, and everything has been rock solid since.

2 Likes

For my case, with the latest Asus X570 bios and Nvidia drivers, i can run PCI-e without audio drop out and/or blue screen, and everything smooth.

Hi guys, I wanted to give a little update on my situation, it might help other that have the same issue.
Just like bj00rn, I bought a PCI-E expansion card that solved everything!
Unfortunatelly I had a micro ATX case, so I had to get a bigger one to fit the additionnal card, and as I also have a micro ATX motherboard and a big RTX3080, I had to buy a PCI-E X1 90° cable as the graphics card is hiding the additionnal PCI-E slots.

To sum it up:

  • USB powered hub: tried, didn’t work
  • PCI-E extension card: works like a charm!

The card I bought: SupaHub PCI-E USB 3.0 expansion card (4 ports).
(It has an internal SATA power supply that I didn’t have to connect, it seems that the PCI-E port gives enough juice.)

1 Like

So, as I’ve had my G2 for less than 24 hours, get no sound when playing MSFS, and more than half the time my controllers are unseen/don’t come on, should I buy this now or are there other options?

5JUL Ryzen Master, Afterburner
UserBenchmarks: Game 104%, Desk 104%, Work 98%
CPU: AMD Ryzen 5 5600X - 100.3%
GPU: Nvidia RTX 2060 - 99.9%
SSD: Intel 660p NVMe PCIe M.2 512GB - 174.2%
SSD: Adata SU760 512GB - 114.6%
RAM: G.SKILL F4 DDR4 3600 C16 2x8GB - 97.8%
MBD: Gigabyte GA-B550 AORUS ELITE

For those with AMD connectivity issues, including sound drop off or blue screen you need the Omnicept cable. I just got mine today and after 6 months and 6 different headset it finally works in every usb port. My previous G2 had the audio switching sources then the blue screen before finally giving up complete.

The cable is from HPs more expensive headset and is available to all G2 owners under the warranty. Just call them up (can be harder than you think!) And ask for the rev 2 cable. If they don’t know what you are talking about mention there is an engineering authority regarding this and they need to refer to it.

It can be explained better in the link below but I can confirm it is a solution. Please note this is the official hp support forum and the posts has been closed as solved. Same with a few more if you want to look.

1 Like

I just got my G2 yesterday. Can I assume I have the Rev 2 cable or is there a way to check it? Unbelievable! I just checked the link and I clearly have the older cable!!! Thanks for the information.

As you probably saw in the link the easiest way to check is that the rev 2 cable has a small on/off button on the psu.

Yes, and that the psu was considerably larger in the newer version. With a couple more hours of flying, I’m flying along happy(!) and suddenly the screen goes black and I’m back in the house on the hill with a bang. Is that the result of the the usb port failing to power the hmd? That is, will the new cable likely solve that problem? And thanks for the post and help.

Anyone catch chatter on the interwebs of where you can buy a new headset and reliably get a rev2 cable? It’s probably too new to say, and I’m guessing all of these online retailers that have it on sale for $400 are trying to get rid of old stock.

For me I would get a blue screen them the headset would be off. The connectivity issues affect the power or lack of from the usb so the fact your headset remains on would make me think it is likely another issue.

Anyone that receives a rev 1 can call HP support and demand a rev 2. I’ve started a thread called Reverb g2 Amd usb connectivity solved and that has a link to a Reddit post dedicated to this issue that goes into a lot of detail about getting a rev 2.

I just got a new Reverb G2 today.

When I first plugged it in, it seemed to be fine. I definitely got a v1 cable, though, despite it being new and ordered just last week. But I did order it one day before the “everyone gets a v2 cable” deal. I bought direct from HP, so I thought it was odd that I didn’t get one.

After setting it up and getting into MSFS2020, I started getting audio issues and lockups.

I probably could benefit from a v2 cable.

However, I did solve my problem. My mobo has a USB setting that allows me to add an extra 0.1, 0.2, or 0.3 volts to the USB3 ports. Turning it up to 0.3 volts (the first one I tried) allowed me to fly around with zero issues.

I don’t want to burn out my headset by overloading my USB voltage, so I will probably contact HP support and ask for a v2 cable.

At the very least, I’ll be able to fly while I wait for the v2 cable.

Just wanted to add that this is a significant upgrade over the Oculus Rift CV1 I used to use. What a difference! I’m very much GPU limited now (RTX2060XCUltra), so lots of room to grow.

Which motherboard is this?

Personally, I had me too audio drop outs but it seems to be resolved once I turned off my main audio output source. I have a pair of Logitech G560 speakers and when are on I get drop outs in VR, if I keep them off , VR works fine and never got drop outs anymore!

I have an Aorus X470 Ultra Gaming board. I believe it uses a Gigabyte bios, but I don’t know much more than that.

I got my new cable from HP and it seems to work well in DCS now, haven’t tried MSFS yet. I’m in the UK and was told by a very rude HP employee who kept arguing and interrupting me that a new revision cable wasn’t needed and that he would escalate to a level 2 engineer, he also said they were out of stock in any case and that I would be waiting a long time to receive one. Funny thing is I got a dispatch notification later that evening and it arrived from Europe next day!

If your audio cuts out/screen goes blank then contact HP and don’t accept anything other than a revision 2 cable.

I note that even with the new cable I can’t use a USB-C port directly on my X570, only using a dongle works.

Strange that it doesn’t work in the usb type C although I have to admit it I only use the type A with supplied adaptor as its easier to get to and I need to disconnect ever night as I have a cable chewing cat. (Protective sheath needed for that problem but also adds a bit of rigidity to the cable).

I have an Alienware Ryzen R10 and the only usb port that ever worked was the front top type A. All others either did nothing or gave one of the WMR errors. Then after 3-5 weeks it would stop with the front one probably due to a bit of wear on the cable pushed it over the threshold of working or not.

With the rev 2 cable I can use any of the types As with the HP supplied adaptor. I will try the type C later. But so far absolutely none of the previous issues, sound loss, blue screen or WMR errors. Also think the cable is slightly more flexible than the old one.

In the last month or so I started to have audio dropouts, and MSFS really doesn’t like it… will sometimes crash when it switches back and at best a very long stutter.

Anyway I finally called up HP yesterday and after a few basic questions about being up to date with drivers and bios the support agent just asked where I wanted the cable to be sent. Was easy and he was polite so perhaps you jut got unlucky (or I got lucky!). It’s on backorder but hopefully they are pumping them out at a decent rate!

You are the first person I’ve heard of with any issue at all with the new cable, odd that you can’t use the USB-C port on the mobo… on my x570 the mobo USB-C works even with the v1 cable (other than the recent audio drop outs but was fine for a long time before that). Are you up to date with a bios compiled on AGESA 1.2.0.3 B as that included AMD’s “final” fix for USB connectivity?

Have you come across anyone else with the same problem with the new cable? You definitely got the new revision with a larger brick right? (Part number is: M52188-001 Part description is: SPS-CA ACTIVE 6M BLACK /W SWITCH).

Yes I have the larger brick version. I will check the USB-C on the front of the case to see if that works, it was working before but with no audio. It could be due to having another device on the same bus on the back, I’ll try removing it. Yes I have 1.2.0.3b but the beta before the final bios by MSI for the tomahawk, again I’ll update it to the final release at some point but just sick of having to redo my PBO and ram oc. I think the AGESA is the same in the beta and final though.

Either way it isn’t a big issue, it’s working now with the converter dongle so that’s good enough for me.

Doubt there’ll be a material difference between the beta and the final version… I feel your pain, I got very bored of re-entering all my timings lol.

Oh well at least you have a working setup!

I just got shipment notification for the new cable, so wasn’t waiting more than few days on back order :metal:

1 Like

That’s great, I’m confident it will fix your issues!