(SOLVED) Fenix A320 EFB does not switch on

Hi. When I load a flight on MSFS and I go into the cockpit, the EFBs are switched off (completely black screen). I tried to click on the screen but the EFB doesn’t switch on.
Where am I wrong?

Kind Regards.

1 Like

Are you clicking on the power button on the EFB? (The little circle on left hand side middle of the screen) looks like an iPad button.

1 Like

Have you switched power on to the aircraft, from ground, batteries or the apu?

Do you have the Fenix App running in the background and started it before MSFS?

1 Like

You have to start the Fenix App, [the one with CPU/GPU choices, Simbrief Name etc] before you 1st start MSFS. [I leave the Fenix App minimized]
Thereafter you may not need to start the Fenix App before MSFS. Have to test that today.
Took me 4 hours to find that out last night via another forum.

Hi. I tried but it doesn’t work.

Hi and thank you. The Fenix app is opened in background but it doesn’t work.

From Fenix Support, overnight.

Also, try using a different A320 livery & different Depart airport.
Good luck.

Hi, please close the sim and restart. Seems that very often the EFB is not initialized on the first run after installing the A320

Hi. I tried with different liveries and I did a full un installation and reinstalled the Software, but this is not a solution.

Same problem. Everything works well except EFB.

1 Like

So weird. It works when I open the EFB in the browser , but still black in the game.

Have you got the EFB to ‘light up’ & there is a key pad.
If so the code is 0000
Or left mouse click & hold on the finger tip image.
If EFB dead try left click & hold on the "Power Button, LHS of EFB.
It can be very frustrating.
You tried the Start the Fenix App & minimize it before you started MSFS??
PS: Do you have avionics lit up, but not EFB, or are Avionics dead too?

1 Like

Hi. The EFB is completely dark: it doesn’t ask a code. I tried to hold with left mouse button click on the circular home button, without success.
I don’t see any power button.
The Fenix app is open in background.
I tried to uninstall and reinstall the aircraft and the liveries and I also tried to change livery.
But the EFB is still dead.


I didn’t know anything about the Fenix and I was able to open the EFB easily. The Fenix app opened by itself in my case. Maybe something on your PC is blocking it.

Ok, some messages above I had posted a tip I read about and that does not work. In fact I have now installed the Airbus and have myself run into the exact same problem. Weird. Tried different liveries, reloaded the airplane, run the Fenix authentificator before or after starting Fs, run it as admin… all to no avail. EFB remains dead. Hope we get this solved quickly…

Hi. My PC is OK and does not block anything. It works smoothly with other aircraft, including PMDG and FBW, without any issue.

I see you have Avionics so its a Fenix link to MSFS issue, I think
I had the "dead Aircraft’ first load this morning, so I shut everything down then restart PC
Start Login/Start Fenix App as Administrator
Minimize Fenix App when logged into Fenix App.
Start MSFS as Administrator.
Load the A320 with the Fenix livery. Pick a Departure airport, forget about a flight plan.
Hit ‘Fly’
When the aircraft loads check you have Avionics, then see what state the EFB is in.
Mine came up ok doing the above, but I had the pass code grid, I held left mouse pointer on the finger image & EFB opened up to the main Icons.
If you have Avionics but a dead EFB, try holding left mouse pointer on the button on left hand side of EFB.

PS - If none of that works, try deleting the A320 Neo via your MSFS Products section. I did that last night, might make a difference, might not.

PPS - Long shot - in the Fenix App, set 'Render Displays On", to a GPU. (& Save) If you have multi monitors, choose the one MSFS appears on. I suspect the issue is to do with the EFB being able to appear on a PC, or say, a Tablet.
It may be looking for links. Anyway, mine works on a GPU setting

Well I had absolutely no problems and knew nothing about the aircraft. I didn’t even know the passcode for the EFB and just use touch ID and it worked fine.

Logic would suggest that if the plane is working fine for most people and not for you then there’s something wrong with your set up somewhere.