Speed & Altitude AP settings no longer displaying in external HUD after Dec '23 update

This is another issue, try restarting with your community folder empty or in safe mode.

Is the issue with all the stock planes ?, can you try the C152 and post a screenshot ?

The C152 has a different HUD external camera screen than the Daher, Airbus, Citation, etc., so it does not have the same problem.

Yes you are correct. But since sealmyster reported a different issue than your, I suggested to make a test with the C152 to check if the HUD bottom informations were at least showing up on his screen, like this:

Ah, got it…thank you for all your responses. Hopefully some fix will come up soon.

2 Likes

I have the same problem and have tried everything to fix it. Definitely a new MSFS bug after the latest update


Here’s my issue. No airspeed shown in cockpit view and V speeds are superimposed on left side of speed tape. As the speed increase the speed tape lengthens towards the bottom of the PFD and the V speeds disappear.

This is a different issue than the one reported in the 1st post. I would recommend you to look if a topic exists in the support\ Aircraft & Systems for your issue, if not create a new one there. Only 1 issue per topic.

Understood. I figured it might be related as it involved the G1000 not showing the speed.

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes
Provide extra information to complete the original description of the issue:
Speed and Altitude Autopilot settings are not displayed for any aircraft. I reset my Xbox Series X and redownloaded everything on 12/27/2023, this did not correct the issue.

If relevant, provide additional screenshots/video:

Looks just like LeeAus2020’s screen shots

I have the exact same issue on xbox series s.
Happens with all planes.
Have remived all addons but made no difference.

1 Like

Hello all.
I want to bring some observations after I’ve noticed the same issue: only minimal gauges displays in external HUD mode: the heading…
I’ve noticed this for 3 or 4 weeks… And after having compared with a lot of planes, it becomes obvious it’s linked with the G1000: for example, the C172 with the G1000 has the issue while the GNS-530 has no issue at all… And it’s the same for all the planes using the G1000 base… Even with Microsoft planes…
Eg: the C-47 (DC-3) has not the issue…
Of course, my community folder is totally empty.
My PC runs Windows 11, but the game is configured with DX11 (Radeon RX 6800)… Honestly, I don’t know what’s the problem and I’m a little bit upset, at least because it’s really the 1st time I have to face such kind of issue…

Not sure it is G1000 related, in the 1st post, OP reported non G1000 aircraft too.

Do the developers of MSFS even read these messages? There are numerous complaints posted here after December '23 update. It is now February and no one has addressed these issues. I even installed he Steam version of MSFS to see if the altitude and airspeed worked in that version, and alas, it is broken there as well. Please Asobo, address and fix this problem.

Hello @DarnedBadge4,
Welcome to the forum. You can always check the tags on the top of bug topics:

In this case, this has been feedback logged.

For a list of tags used by MS/Asobo see:
https://forums.flightsimulator.com/t/welcome-to-the-public-forums/121637

It appears the problem has been fixed. All readings seem to be appearing correctly… at least on the XBox. it seems to have been fixed either during the last update or with the Caribbean World Update.
Perhaps we should close this conversation if others have the same outcome.

It has NOT been fixed. I just uploaded MSFS on a new laptop, so it’s a completely up to date version, and the issue is still there. Very annoying, and frustrating that after a couple of major updates, this is still a problem

Sorry to hear you are still having issues. On my xbox (much to my surprise) the displays are working once again…at least the last 10 or so flights with the Cessna 172, Caravan, CJ4, and a few other G1000 aircraft. I am quite sure it was nothing I did on my end.

I haven’t tried the PC version. I have the hardware and access to the software but unfortunately not the time.

Hope you get a solution soon. I love flying with external view and the hud available. Makes adjusting ais, vs, hdg, and alt more convenient without going to cockpit view. If my system reverts, I will let you know.

Have the folks at Asobo or MSFS acknowledged this issue, and committed to fixing it in the next update?