Stop setting the squawk code in the cockpit automatically

Currently when you request IFR clearance you are given a squawk code. If you reply to the ATC the squawk code in the cockpit is set automatically. On the other hand if you try to circumvent this by setting the squawk code before responding to ATC, the ATC gets mad with you for not responding quick enough.

Can there please be an option to not automatically set the squawk code?

… or give us 15, 20 sec. more before start yelling :slight_smile:

1 Like

I feel like that should depend on how busy the airport/airspace is. :slight_smile:

1 Like

IRL you’ll get like 2 seconds to respond before they repeat the message (instead of “Did you copy?”)

yes but here we have to actually set and activate the transponder code before reply to the ATC, else if you respnd before the transponder will be setted automatically :frowning:

If you have the AI co-pilot controlling radio comms, then maybe try turning that off, as it’s probably the co-pilot that is setting your squawk code.

No, this is a remnant from FSX. The transponder gets set as soon as you reply to ATC.

1 Like

I’m aware and agree it should be possible to manually enter it :slight_smile:

IRL you’ll reply to ATC and set the code about the same time. It should be possible in the sim as well. Dial/type and reply in the same time.

1 Like

:slight_smile: on the plus side I must say that if you dial in the correct code and activate the transponder the ATC interpret this as an ACK and skip ahead to reqest confirmation for the radar contact…

Yeah, but that’s also not right, because you’re supposed to readback the squawk code IRL

2 Likes

So we are trapped… :slight_smile:

1 Like

They should just add an assistance setting for auto-populate squawk code that people can turn on or off. I like the auto squawk code because I let my co-pilot do the thing so I don’t have to. My co-pilot need to work on something at least… I don’t want to do all the work…

If you look two posts above yours, you will see an alternative, that also worked in FSX.

Yep, here just as in FSX, you have to choose one or the other. If you’re quick with the transponder, you won’t even get scolded. For me this is in the category of, it would be nice, but it is not a complete immersion killer like some of the other ATC issues.

1 Like

It could be part of the ATC setting for the copilot

I did mention that in my post, but if you wait too long the atc will ask if you heard him. I do my stuff in the order it tells me, so the squawk is the last thing.

This is super easy to implement. it’s a matter of putting this line in:

if(ATC by copilot enabled){
do the automatic squawk code already implemented
}

Done. The ATC text even already exists for the case that you didn’t put in the correct code: try changing your code or setting your transponder off, the ATC will quickly tell you what’s wrong. :slight_smile:

So am I supposed to wait for the harder ATC stuff that takes longer to be fixed before this can be implemented? :wink:

1 Like

I usually set the squawk code while the controller is still talking. Works fine.

1 Like

I said that in my first post, and I also said why that is not good enough:

Never happened to me. I still hover my finger over the number key for the readback option, though.

1 Like

Remember Microsoft! This is a simulator! It’s surpossed to simulate real flying. In real life no one sets the squawk code for you. At least make it an option in settings. And do the same with radio frequencies.

Hahaha, and then we’re also getting the other side of the feedback where people are complaining “why ATC cancels my IFR because they keep telling me to reset my transponder… Shouldn’t my transponder be set already?”

1 Like