Strange airport ground textures in VR

Has anyone ever seen this in VR? I don’t get it when in non-VR mode, only in VR. I tried changing a few settings (reflections etc) to see if it would change the issue, but nothing obvious jumped out.

Lenovo Explorer WMR, RTX 2060 (so not particularly high spec)

Sorry, which part of the image are you referring to, specifically?

Do you have any add ons in your community folder that might be causing a conflict?


Sorry, I realised it’s harder to see when you’re not looking out for it.

In the foreground, the yellow-black dashed line goes through some “holes”, which you can see are repeated a few times.

I can’t think of anything in the community folder - it’s noticeable at any airport. I’ve noticed it seems to correlate with wet/snow on the ground.

1 Like

There are some strange marks on the runways in VR. I thought it was because it was not a paid airport but there are many . I think we will have to live with this for a while.
Good Luck

So you’re saying default airport runways have strange markings in VR? That’s new to me, I’ve seen some issues with DX12 Beta but not connected to VR. Care to show us a screenshot?

Thanks, this does seem to be a bug with the ground effects during snowy weather. Can you raise a Zendesk ticket and attach this screenshot? Should be a link at the top of the page. Make sure to describe the time and weather you selected during the flight and the airport location where these textures occured.

I’ve sent a zendesk. Here’s a good example of how it looks with snow. It’s like a weird bug with partially contaminated surfaces…

1 Like

So I raised a zendesk. No reply (not sure if that’s normal).

The issue is still there, but it appears there are other reflections happening as normal (see screenshot). It’s only happening in VR mode… That’s what’s so weird. And the texture is really, really odd as you can see. It’s super annoying!

I tried changing every graphical setting in MSFS in VR mode, which did nothing. I also tried completely emptying my community folder. Surely I can’t be the only one getting this?

This is Asobo’s standard customer service level. Don’t expect any reply or action.

Thought I might raise this one again, on the chance that anyone else has come across this issue…?

Could it be a texture issue in the base game textures folder?

1 Like


Are you using DX12 by any chance? The reason I ask is because I’ve seen an issue mentioned elsewhere in the forums where people have used DX12 and some experienced a texture bleed through issue. It doesn’t happen everywhere or at all times but for some it was annoying enough to cause them to switch back to DX11.

From memory, the issue specifically shows weird textures, mostly at airports, where it appears to bleed through or overlay the normal texture that is expected to appear. I think it was affecting desktop and VR users. The issue only appeared in DX12 and switching back to DX11 fixed it.

If you think this may be what’s causing the issue you’re seeing, I’ll see if I can track down the thread.


Ah, so I don’t think so… but I’m not actually sure how I check if I am in DX12. How do I check that?

It’s true, the ground textures in VR are really bad now. It was not like that before. I feel that MSFS is not going to do anything about 2020 because there needs to be a BIG change for the new sim. At this point it has to get better.

Did you try to temporarily empty your Community folder?

What does that do with textures?
I will give it a try

I’m curious to know how that goes - I remember trying it and not noticing a difference, sadly.

Any chance you can post a screenshot of your version of the texture issue?

Go to your General Display options when you’re in VR (settings will be different when you are not), it will say there whether you are using DX12 or DX11 in the first page I believe.

An update or two ago, my system got switched to DX12 even though I didn’t change it. I’ve set it back to DX11. I haven’t noticed any real differences either way. Maybe a few more full stop pauses approaching airports in DX12, but I can’t say that’s a real effect, really.

In MSFS, it’s under graphics settings, PC section.
From memory it’s on the list towards the top, located near texture resolution, clouds etc.

It’s only listed in the PC graphics section though, the option isn’t listed under VR, however, the setting affects both.

You should see two options available, DX11 or DX12 (beta). If it’s on DX12, change to 11 and you need to restart the sim.


I checked and it’s still DX11 for me…

Did you try with the Community folder temporarily emptied? There is a chance that you have some add on causing this issue.