Stuck at "Launch game when ready"

Flew fine yesterday and today I can’t get past this screen.

I believe it’s somehow linked to this error in the Store. Details report error code 0x80070032

If I click “Retry” it actually does something, but when I reopen the Store I’m back at this again. It’s like it’s not installing/updating properly and I can’t find out why. Is there some .log somewhere? Maybe some path is incorrect.


Hi @VirusSlo ,

Thank you for your post! Your topic has been moved to a sub-category of the User Support Hub

The General Discussion category is meant for discussions that fall outside of our other sub-categories.

If you would like other users to help you with an issue you are experiencing in the sim, consider these User Support Hub categories for your future post:

Aircraft & Systems
ATC, Traffic & NAVAIDs
Crashes (CTDs)
Hardware & Peripherals
Install, Performance & Graphics
Scenery & Airports
User Interface & Activities
Virtual Reality (VR)
Weather & Live Weather

I actually found an error regarding GamingServicesUI in the event log. I managed to reinstall the whole thing and now that error is gone, but unfortunately nothing changed regarding launching the Flight Simulator.

I can actually uninstall “Microsoft Flight Simulator Digital Ownership” via MSFS advanced settings and then reinstall it (verified by disappearance and reappearance of the files in the installation folder). And even when I do that it is still listed with an error in the Store.
Also after every re-installation during the first startup instead of MSFS this window pops up. There’s nothing I can do here, but I guess it hints that everything is connected to the Digital Ownership issue.

Launch MSFS as administrator.

No. That was one of the first things I tried. Thanks for the effort though.

Reinstall gaming services.

In windows seacrh bar type

Right-click on windows powershell and select run as administrator

Copy the following command and paste into powershell (right-click to paste into powershell window)

Remove-Item -Path “HKLM:\SYSTEM\CurrentControlSet\Services\GamingServices” -Recurse

press enter

Copy the following command and paste into powershell (right-click to paste into powershell)

Remove-Item -Path “HKLM:\SYSTEM\CurrentControlSet\Services\GamingServicesNet” -Recurse

press enter

Copy the following command and paste into powershell

get-appxpackage Microsoft.GamingServices | remove-AppxPackage -allusers

press enter

Restart PC

Run powershell as administrator.

Copy the following command and paste into powershell

start ms-windows-store://pdp/?productid=9MWPM2CQNLHN

Click Install

Restart PC

Launch MSFS

I did that yesterday, but I used some shorter procedure. I’ll do it again your way tomorrow. You might be unto something there because I noticed this error in the event log.

I’ll also check if I can find any clues here

I have a 1.5TB flight sim with over 300 addons and would really love to avoid reinstalling everything.

Reinstall of Gaming Services went fine. I checked folder and registry locations to make sure that hey were gone after uninstall and that they reappeared. However it didn’t solve the issue.
I think this is still the core of my problems

I did some research and this apparently means that Store is unable to write something somewhere. Unfortunately I can’t find any log to go into any further details.

Have you tried using the Xbox app?

Hi TheSevenflyer.

Have I used it to do what?

To launch the sim.
It could also be causing this.

1 Like

Yes I have. It’s the same result.

Anyone had any success with solving this yet. I read the thread but nothing I saw was very positive. I’m not a techie but I have done all the updates and re-starts I can…

This is current status.

It was just going nowhere, so since I’m already reinstalling the bloody thing, I decided to move from Win10 to Win11 as well (clean install). Now I see that the Digital Ownership app is now present. It wasn’t here before, so I’m guessing for some reason MS Store developed a problem writing to this folder. But that’s just a guess now.

It worked for 1 (one) ■■■■■■■ day. Now I’m stuck with this crap.

It’s again not strictly a flight sim issue since this is an error I get with other xbox connected games

Hi @VirusSlo ,
This post may help:

It actually doesn’t help. I’ve now tried everything from app resets, cache cleanings, clean boots, time zone and clock settings and sometimes it works for a day or two, sometimes it works only for a couple of hours, sometimes I can’t get it to work at all. At least now I can “quick test” it by trying it in the Solitaire game, because it loads up quicker and I also end up with this

The most messed up thing is that I’m using the same account for my Windows login and it works fine. Same account for MS Store and it works fine. I can ALWAYS login into the Xbox app with the same account without a problem. But when I start a game it refuses to login.