Stuck on decompressing fspatch files

Anyone else run into this?

I’m all of 10 MiB short of completely installing the 15.69 GiB patch. Download was complete and (seemingly) successful for fspatch.001, 002, 003 and 004, and fspatch.001 decompressed fine. I let it go for an hour or so the first time, then pause and exited. I’ve deleted the files waiting to be decompressed, and restarting the sim it cycled back to re-downloading those files as I hoped, and again seemed successful. But again, it seems to get hung on decompress of fspatch.002; about an hour into it again, and I see no activity from MSFS in Resource Manager.

Any suggestions on what I can try? I’m having flashbacks to the August 18th/19th/20th’s install nightmare…

EDIT: Watched a little closer to what was going on this time. The sim downloaded the fspatch.001 through .004 files again just fine, and sizes of the files matched previous downloads. Decompress of .001 goes fine, took about a minute, maybe a little less, then proceeds to decompress .002. I see a flurry of read disk activity for a minute or so, but no write disk, then those drop off and currently no disk activity from MSFS. There’s some ongoing network activity from MSFS, mostly small packets going back and forth to half a dozen different addresses on the order of 100-200 B/sec or much less, but with occasional spikes in activity into the KiB/sec range at other addresses. I’m assuming these 4 files are all part of 1 bigger file, broken up into sub-2GiB portions. I have no idea how the program reassembles these files, so if there’s some checksum process going on, it’ll take roughly forever if it’s doing it via a server at less than half a KiB/sec.

About 15 minutes in, 4th try. Will let it roll and see what happens, and update here.

2 Likes

same problem here

takes a loooong time. i though i was stuck too

2 Likes

im downloading it now lol was yall having issue wth the auto throttler not working on the 787

Never got that far. Haven’t been able to get in the sim proper since last night.

2 Likes

About how long did it take on your end to decompress? I watched it for over an hour, and saw no activity from MSFS whatsoever in Resource Manager past the first few minutes. Most folks I’ve been seeing here who haven’t had an issue have reported about 20 minutes, start to finish.

im almost done so i think its been like 15 maybe 20 mins

Quick update:

Took 10 hours, but patch finally installed. I ended up moving the few liveries I had in the Community folder out, then that specific file that would decompress finally decided to cooperate.

Although I have a new problem; my Saitek Cessna yoke and main throttle quadrant aren’t recognized. Which is freakin’ bizarre, as my second quadrant, rudder pedals, and trim wheel all plug in THROUGH the yoke, and all those are working fine.

2 Likes

Same problem, patch just keeps trying to get the same file for ages. There is definitely something very wrong with this patch, or the servers.

2 Likes

One hour later…still downloading the same plane…gets to about 2 to 10% (it varies) over and over again.
Mmm…am I grounded?

1 Like

I get the same thing. Have the Steam edition. Downloads 200MB then goes back to ~35MB and repeats. I tried deleting everything flight sim related, restarting my pc, re-installing the launcher and no luck.

1 Like

I’m in the MS Store edition. Just for MS info should they read this. In any case I gave up after 3 hours, waste of time. Maybe tomorrow.

2 Likes

Steam Edition here as well, packages get 80% of the way through and then restart. Seems like the servers are not handling the load for the patch release. Pretty disappointed, don’t think I will be playing at all for the next 24hrs

2 Likes

Similar problems here with Steam edition. Steam keeps asking me if I would recommend this game. Right now my answer is NO, because of stuff like this.

6 hours trying to install this patch (now trying to install the whole game). I quit for now.

1 Like

I am also stuck on the 002 file. It wants to download, sometime i can download 153,48 MiB of the file before it reatempts the download and sometimes it wants only to download 10 MiB. Donno whats is happening. i Just might try to take every thing out of the Community folder and retry.

I tried that actually, removed the community folder content (made a copy though). Does not help.

This is a but odd right now i am downloading the 003 file it really takes alot of time, looks like is many times stuck on 002 and suddenly it has downloaded it.

Not sure if this is related or not but I was struggling to get past 5% downloaded on certain files. It would keep going back to 0%. Tried restarting FS, rebooting, wiping temp files etc. nothing changed. Then I started another unrelated download and the FS patch started to download without resetting. When my other download finished the problem came back. So I turned on QOS on my router and set the maximum download bandwidth to about 33% of whats available. So far so good.

I kinda see whats happening here, every time it downloads a bit more of the same file each time it fails, it is strange. I am on the 004 file.

Update: And now it has downloaded