SU10 Cessena C172 G1000 Rudder Control and Wind Gust

Looking for feedback from others who have tried SU10 today. I am happy to report that wind gusts are now simulated an its making the landing more challenging which is great and making the G1000 autopilot work hard. I have my accessibility settings all set to hard mode.

What I cant understand if its correct or not is the control of the C172 when taking off and landing, keeping it on the center line. I am using the MFG Crosswind V3 rudder pedals and have not changed any controller settings or calibrated the pedals.

Before today’s update everything was “correct” so to speak.

1 Like

It’s due to the new crosswind tuning added to the 172, since you’re on PC there’s 2 ways to fix this depending on your preferences. In the flight_model.cfg file go to [FLIGHT TUNING] and either change
ground_crosswind_effect_max_speed
ground_crosswind_effect_zero_speed

to read

ground_crosswind_effect_max_speed = 85
ground_crosswind_effect_zero_speed = 5

to cause the wind to gradually be applied to the plane as you build up enough speed to gain sufficient rudder authority.

The other option is to add the following lines to [FLIGHT TUNIG]
ground_high_speed_steeringwheel_static_friction_scalar = 2.0
ground_high_speed_otherwheel_static_friction_scalar = 2.0

This will make the wheels “stick” more, allowing you to gain enough rudder authority before the lift component reduces the friction enough to cause the plane to start weathervaning.

2 Likes

Great thanks! I’ll check this out tonight.

I see this problem in the XBOX. Is there a way to fix it there?

This is what the default is after SU10

I am on Steam:

…\steamapps\common\MicrosoftFlightSimulator\external\Official\Steam\Asobo-aircraft-c172sp-classic\SimObjects\Airplanes\Asobo_C172sp_classic\flight_model.cfg

I created a copy as a backup.

Line 266- 269

ground_crosswind_effect_max_speed = -1000 // feet per second, default is 80
ground_crosswind_effect_zero_speed = -1000 // feet per second, default is 5
ground_high_speed_steeringwheel_static_friction_scalar = 1.0
ground_high_speed_otherwheel_static_friction_scalar = 1.0

ground_crosswind_effect_max_speed = 85 // feet per second, default is 80
ground_crosswind_effect_zero_speed = 10 // feet per second, default is 5
ground_high_speed_steeringwheel_static_friction_scalar = 4.0
ground_high_speed_otherwheel_static_friction_scalar = 4.0

I am using 100% rudder just to try and keep it on the center line when I taxi. Then after landing and slowing down I am heading into the grass.

@Raynen What do you have your settings set to?

HI,

have you also put your aileron correction during the whole landing when you were rolling down the runway ?

If not with more than 15kts direct crosswind i’m not sure you will be able to keep the centerline.

If you were keeping aileron correction it looks like a bug.

I have not tried that. I will give it a try.

@airmanparker I use the below settings, dialed them in using a custom weather profile to give a steady 15kt crosswind. With these it should be controllable, but you’re definitely going to have to work for it.

ground_crosswind_effect_max_speed = 0
ground_crosswind_effect_zero_speed = 0
ground_high_speed_steeringwheel_static_friction_scalar = 2.0
ground_high_speed_otherwheel_static_friction_scalar = 2.0