SU5 CTD on every sim start

Since I’ve installed sim update 5 I am unable to start the sim. I couldn’t get to the main menu for a single time. Before that more than 600+ hours with maximum 1-2 CTD at all.

Nothing has changed on my system. According to windows eventlog it seems to be a problem with ucrtbase.dll but none of the solutions I found online has worked so far.

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x00000000
Faulting module name: ucrtbase.dll, version: 10.0.19041.789, time stamp: 0x2bd748bf
Exception code: 0xc0000409
Fault offset: 0x000000000007286e
Faulting process id: 0xa28
Faulting application start time: 0x01d78394db905ef5
Faulting application path:     
Faulting module path: C:\Windows\System32\ucrtbase.dll
Report Id: fdaf72cd-6d5b-4bbb-bb36-5a10a985d0ca
Faulting package full name: 
Faulting package-relative application ID: 

Steps I tried to resolve already:

  • Community folder cleared
  • Restarting the sim several times
  • Rebooting Several times
  • Completely reinstalled the sim twice already
  • Stopped every other program
  • Disconnected all peripherals
  • Updated graphics driver
  • Installed US English language pack
  • Logged in and out of XBOX services
  • Made exceptions and even disabled defender protection
  • Reinstalled Windows and the sim completely, still the same issue.
  • Uninstalled and reinstalled Visual Studio C++ runtimes as described in many other threads
  • Stopped windows audio service as described here

I’m running FS2020 Steam version on my system.


AMD Ryzen 9 3900X

I was so hyped for the performance update and now I cannot even start the sim anymore…

Any help would be highly appreciated!

Oh and yes, I reported this issue on Zendesk #112215

Given that it’s crashing in ucrtbase.dll could try looking for fixes associated with that that are not specifically MSFS. Had a quick look and there are other apps with issues.

C0000409 exception code seems to be a generic stack corruption.

Thank you! Yes I tried that already, it mainly comes down to C++ Redistributable which I even uninstalled and reinstalled already. Did unfortunately not help.

I’m not sure what that is or how this could help fix the issue unfortunately.

An exception is an announcement somethings wrong and the error code 0xc0000409 tells you what. Problem is this is not a specific thing “file 22 is missing”, but a general I can’t fathom this out, giving up message AFAICS. Which is not helpful.

I have seen it paired wit explorer.see and recall some people saying msfs worked better if you closed explorer (windows front end), that might be worth trying.

Did you try disabling or deleting the rolling cache ? Sometimes faulty data there might cause a CTD ?

How far does it get through the startup ? Does it crash immediately or consistently crash at a specific position?

Thank you for your help.
I deleted the rolling cache before the update. But as stated above, I already reinstalled the whole sim twice and also on a completely wiped new install of Windows, so I guess at least on the new windows installation there cannot be a rolling cache, since the sim has never run before on the fresh install.

From the moment the sim window comes I can see the xbox, asobo screen etc. then it checks for updates, and after that it always goes to the screen with the cub in it and quits to desktop at about half of the progress bar.

It’s weird because it’s been working for more than 600h without any issues. Most stable sim I ever had. It also worked before the update on the same day perfectly fine. And after the update even when reinstalling it just CTDs all the time. While updating and also fresh installing it had a CTD at 100% progress all the time, I’m guessing at the point where it would usually go to the menus.

I have tried now copying the dll file into the folder where the flightsimulator.exe is, installing all the vcredist packages from 2019 back to 2008 and also installing the Windows 10 SDK as suggested in various other topics about this dll error.

I had this and I know others did. Because you reset the whole thing the logical place to look is the one thing that remains, the synchronised data. What the problem seemed to be is they changed the format of the usb peripheral file and it didn’t cope with it and crashed like yours mid load. Reinstall failed because it just downloaded it back. So it had to be manually removed.

If this specifically doesn’t work, is there a way of erasing your MSFS data stored in the servers ?

1 Like

Interesting! I deleted the 1250410 folder and it actually took me to a menu to set my user interface preferences. That’s way further than I was before :open_mouth: But unfortunately it still crashed after setting the preferences and continuing. And strangely screen narrator was on the whole time but I turned it off…

Oh and yes, I disabled Steam Cloud before.

I think there’s steam cloud and microsoft cloud ? I’d be surprised if MSFS data is stored on Steam servers

Do you have unusual hardware, something that’s not a standard joystick ?

I’ve asked elsewhere if there’s a way of deleting all of your synchronised data so you look to the system like a brand new user. Bit of a PITA but a bit lost for other ideas.

Thank you very much for all your help so far! I guess we’re on the right track but not quite there yet.
No unusual hardware. Only Mouse and keyboard and a Thrustmaster TCA Stick and Rudder, worked fine before the update.

There is a steam cloud but I am not sure what kind of information is safed there. Basically you get the exe and some settings from steam I think, and the rest (Official folder with all the files) gets downloaded from Microsoft then. Steam just gives the launcher instead of microsoft store. As far as I know…

Steam cloud is for games that don’t have online support I think, so I would guess it keeps copies of internal configuration files that games create on an individiual basis.

I started this thread Reset online state, no replies yet, as I can’t see what else you can do really. Your machine looks very standard, very like mine (still downloading SU5, rural broadband !), there’s no odd USB devices attached or PCI cards I suppose ? You’ve reinstalled everything.

Just to check, you have tried starting it without your Thrustmaster stuff plugged in since deleting the profiles ? The problem before didn’t show until you plugged the joystick in, whereupon it immediately CTD.

1 Like


No odd USB devices there, I even made sure to disconnect everything except mouse and keyboard before reinstalling the sim. Tried starting it with or without joysticks attached no difference.

Hi. I’ll be off grid for a couple of hours, I will check in later.

I reckon it is your synchronised MSFS data, which would explain the narration thing. Two things. You could try deleting the profile folder, starting up again, deleting any profiles that are in the controller section from the profile manager, and seeing if the sim will start without your controllers in. It sounded like it got started, you thought maybe you’d fixed it and tried to set it up again, logical thing to do, but it appears that there’s more problem(s).

The other thing is it will have generated another event in the log, which may possibly be different and give more specific clues as to why it’s crashed.

1 Like

I had an idea just to rule out my hardware could be the issue. Got the 1$ xbox game pass for one month now and downloaded the same via the Microsoft Store. Copied the content of my official folder over from my steam installation to the new one so it doesn’t have to download the full sim again. And could start the sim with no issues at all!

So it really looks like there is some cloud saving or something going on with steam that got messed up. I just haven’t found out how to deal with it yet.