SU5 - Tile texture corruption of scenery (AMD Vega GPU series related?)

Yes … my impression is that there is some common aspect … or two bugs in one (so to speak).

The tile corruption for me only (in DX12) or mainly (in DX11) gets triggered at airports.

Airports seem to be the only place with “layered” textures (regular sat ground with generated airport texture “on top”). This seems to fail in both.

It feels like in DX12 the bug is more “contained” … in DX11, once triggered, it spreads to non-airport places/tiles as well.

I have no clue how the sim works … but to me:

  • A) the “missing” (airport) tile overlays … feel like a timing or race condition issue (random but still predictable)
  • B) the blue tiles … feel like uninitialized texture memory (and based on what @WebSanity reports this is not limited to AMD)
  • C) the fractal tile texture chaos … feels like corrupt texture index handling

With DX12 I have so far only seen (A) … DX11 on AMD has all the above.

But then … I am just a goose

still a problem here…

I am only using DX12beta (for reasons state further above)
… and I just upgraded to AMD 22.1

… and the “missing airport tile overlay” bug is still present.

I have 2 vega 64s, and can confirm seeing this issue as well. I’ll try DX12 next and see how that goes.

Sorry for my poor English.
New drivers arrive every month and I install them but none fix the bug.
Before, that was easy: I had to resume the old version of April 2021 and everything was repaired.
The problem today is that this new driver (1.1.22), as bad as others, has removed this option and the squares are there even with the April version.
It must have broken something.
Now I have blue squares everywhere even on the Garmin!!!
Does anyone on this planet got a solution?
Is there someone competent at AMD who can answer?
Direct 12X unusable: too many crashes!
Regards

First … I share your frustration that driver version rollback is always such a nightmare.

Second … I can not help as I also do not have a solution

(maybe a little off topic:)
but … I would like to know more about your DX12 trouble.

I did switch to DX12beta because it does a least fix the tile chaos … even when then I get the new (related) “missing airport tile overlay” bug. But this is visually way less disturbing.

I do get (very) frequent CTD even when loading into the new departure location. This is somewhat random as repeated attempts for exactly the same airport and departure spot (ramp, gate) sometimes work … and sometimes crash.

So I suspect there is a DX12 specific “initial 3D asset loading CTD” bug … perhaps due to a race condition somewhere in the code or the driver.

But besides that I have not seen CTD crashes during the rest of the flight.

So … any further info on your DX12 CTD issue would be interesting (e.g. perhaps a pointer to a DX12 forum thread related to your issues)

… I already described my CTD issue here:

Well, so much for DX12 for me. CTD when flight finishes loading. Menus, all other aspects work fine, but can’t fly in dx12 for some reason. I’ll try a driver update.

Hello,
Same blue squares for me ! During Reno Races too.
Dx11 Asus dark hero AMD motherboard …

Don’t know if this helps, I get this exact problem with my 6800xt - but only when I use it with my iMac through an egpu. I don’t get the problem when I use the same card installed within my pc (not in the egpu case). Haven’t tried dx12 yet. Maybe this suggests it’s a bandwidth issue as the egpu case restricts the card to 4 PCIe lanes (I think) rather than 16

So when you use it in your iMac means … you run Bootcamp … boot regular Windows … and use MSFS there? … or are you using VirtualBox or that like to run W10+MSFS and then give it direct PCI access to the eGPU?

It could be possible that “transfer speed” plays a role. But given that older AMD drivers did not have the issue on the same hardware it feels more like a driver bug … now if that is triggered by some race condition … then “faster transfer” might make it less likely to occur.

Sadly I suspect that AMD does not really care about MSFS … and so nobody seems to be really trying to debug it (I would gladly be proven incorrect on this one)

… and it feels like a pretty nasty “low level” bug … so it might take some real effort to locate and fix it.

Personally I have given up the hope that we will ever see an AMD driver fix for the DX11 issue … that is why I switched to DX12 (even when it seems to produce more CTDs during asset load stages)

My apologies for this poor English.
Thank you for these clever thoughts.
I think, unfortunately, Nenenui is absolutely right about AMD’s attitude…
Fortunately, (I did a little manipulation), I managed to restore my old driver (April 2021) which works well. and everything is now working fine on DX11. Bye, bye squares…
DX12 is actually too “buggy”

OK … 1.22.2.0 was a World Update … but the DX12beta airport texture overlay bug jumped right into my face on the first occasion … and I just wanted to record it publicly.

Running the latest AMD 22.1.2 driver.

Menenui, It turns really crazy now…
We keep in touch, if someone got a solution on this planet… Who knows.

Glad I found this topic at last. I’d been googling for a while and seen loads of pink square issues but not blue, with corrupted textures.
I’d even reinstalled the entire sim without joy.

Just updated the sim with World Update 7 and the corrupted airports seems even worse now.

Oh yeah… I’ve got a Vega56 :frowning:

looks just like mine…

I’m getting the blue tiles away from airports, and only from a medium view point - perhaps 5nm away.

When get closer they disappear, even if I return to my previous position.

511.09 and 511.79 both tested with the same effect. Only run DX11 on 1080p on a Nvidia 2070max q

  • I’ve only started noticing this with the SU8 beta. So I guess not just AMD related?

Flying in France

Right hand one disappeared at this distance. Left one disappeared very shortly after.

Now when flying in Germany too

Sigh, back to 466.77 again? Surely not.

anyone try windows 11? I doubt it would make a difference, but maybe?

Yes … @PhilBean … your screenshots (sadly) fit perfectly to this bug.

It would be sad if SU8 would “expand” this bug to “support” Nvidia cards too.

What would be interesting to know:

  • Are the blue tiles “predictable” … so are they at the same location all the time
  • … or do they pop up at random places?

In the AMD bug space they are random … but they are more likely triggered in regions with layered textures (like airports) … but they clearly are not restricted to airports either.

And it seem like once you trigger that bug you will get more corrupt tiles all over the place.

Is this similar in your Nvidia case?

I’ve havenn’t really flown for a while (because of the bug) but first time I noticed it was a few updates ago at Heathrow. There was corruption around the gate I started at but nowhere else and the rest of the flight was OK. I then tried VFR from a few small airfields and they were all bug free.

That Entebbe was by far the worst I’ve experienced it.

Has anyone tried the very latest ‘optional’ AMD drivers ?
I’m still using the recommended.