SU5 - Tile texture corruption of scenery (AMD Vega GPU series related?)

Starting in SU5 … and also with Hotfix 1 (1.18.14.0) I am getting this:

  • A) I start an Honolulu airport … take the drone … fly up … and look around
  • … the scenery looks good
  • B) I slowly fly the drone eastward along the coast
  • … and start to see corrupted water an coast regions
  • C) I return to Honolulu airport
  • … and the scenery has (reproducibly) corrupted tile textures

First some pictures:

B1: mainly in water areas

B2: shows tiles have different “size” … and notice the blue one

C1: there is grass and water covering the airport

C2: Interesting “multi LOD textures” … some parts reappear in a scaled down fashion in nearby tiles

Some additional observations:

  • the texture bugs are not “healing” … but moving the camera changes them (to different “bugs”)
  • this is 100% reproducible for me … and not limited to Honolulu
  • it is easy to see on airports and coastlines … but it also exists underneath regular vegetation or cities (easy to spot in the case of the blue tiles).

Since the bug becomes worse (on the airport) when I return to it, it feels like a texture index mismatch with maybe a reuse of preexisting old textures or uninitialized memory (e.g. in the case of the blue tiles?) is part of the problem.

Additional remarks:

  • I have never seen this prior to SU5
  • I use a fiberoptic internet connection
  • the GPU is an AMD Vega II with 16 GB RAM … latest drivers installed
  • Settings … Ultra … 4K

Questions:

  • Are other people seeing this?
  • … with Nvidia cards too?

PS: Empty Community folder, the data cache has been emptied (and the bug happens with data cache either on or off).

You are not the only person with this issue, I’m glad you brought it up because I thought I was the only one experiencing this too. I run the sim on an AMD RX Vega 64 with also 16 GB RAM. I first see this problem when I load in to the world regardless if I’m in a cold and dark state or not. When I enter showcase mode and ascend away from the ground I’ll eventually see that the scenery textures get partially fixed. I have also not seen this prior to SU5.

Same issue here. I am using an AMD RX Vega with 8GB V-RAM. System is i7-4790K with 24GB RAM. I set up a short VFR flight from KLAX to KLGB and there is a lot of garbled scenery just south of KLAX. The results are consistent even after rebooting the PC. Again, not seen before SU5.

I found that setting (in GRAPHICS) TEXTURE RESOLUTION to MEDIUM (was HIGH) the observed texture corruption has disappeared. Maybe SU5 restricts the amount of VRAM available to textures compared to previous versions.

1 Like

I have the same issue with a Vega 56. Happens quite often when I use the drone camera around an airport, first the scenery tiles in the airport area are affected, tiles outside the airport less so, but it can happen there too.

First noticed it around SCAZ airstrip in Southern Chile (on the Patagonia bush trip), there it affects “normal” scenery too. After a while, it can revert back to normal operation, and interestingly, from the cockpit I almost never see this bug.

Will post some more screenshots later.

Hard to tell whether it’s a driver bug or an MSFS bug that gets triggered by the specifics of the AMD hardware/driver.

Interesting … so far we only have reports from AMD card owners.

Here is one more screenshot from my side:

What can be seen here is that it does have some “fractal nature”. The big blue tile bug contains sub tile bugs with different content.

I am running everything in “Ultra” … but I will try to switch to “Medium” to see if that resolves things.

To be specific, only reports from Vega series owners, nothing yet about RDNA 1/2 (aka 5700 / 6800 etc cards)

Good point … so far only GCN based cards ( Graphics Core Next (GCN) - Wikipedia)

Hi the same here, ive Vega 64 and have exactly the same problem since SU5

In some sense this is “good” … at least this bug seems “consistent”.

Sadly I will have to interrupt my virtual world tour until this is fixed … and the tool bar hides itself again.
It sadly makes no sense to go sightseeing under those conditions.

Hmm … interesting.

So it upgraded to SU 5 Hotfix 2 and check the tile bug again (at Honolulu).
I go the same result as with plain SU 5: tile cracks and blue “uninitialized” tiles popped up quickly.

That was … in Ultra.
Then I tried … Medium … no tile corruption, no blue tiles!
Then I tried High … no tile corruption, no blue tiles!
Then I tried Ultra again … no tile corruption, no blue tiles???

Hmm.

I quit MSFS … and relaunched it … went back to Honolulu airport in 4K Ultra
And “boom” … the tile corruption was back.

So I guess I can confirm what @scstony discovered. Switching to “Medium” fixes the bug.
But the really interesting part is that it might even fix he bug when scaling back up to High or Ultra.

I guess this only works in a region that was already visited in “Medium” before. But I will play with that workaround a little.

So mainly I would be interested … is everybody else who has seen this so far also using “Ultra”?

What is somewhat strange is …

So far I have not been able to trigger that bug when viewing the scenery from the aircraft (either cockpit cam or external views).

However, I still can trigger this bug pretty reliably (anywhere in the virtual world) when I use the drone cam.

So I wonder if that could be related to the “speed of camera movement”? When I use the drone I am typically moving pretty fast to scan the scenery etc.

It does not seem to be restricted to fast cam moves … as I have seen that texture bug also in the sims “intro animation which explains the departure airport” … like here are EDDF:

Strange …

I’m still using medium texture resolution but regularly seeing the issue at large airports. It is worse in the airport intro animation and somewhat clears up when once you’re in the main flight view. I do see the corruption in cockpit and external views. See the pix below from KLAX and RJTT.








I’ve also updated with the latest (21.8.1) AMD video driver - no change to the corrupt textures.

same here … upgrading to 21.8.1 did not change anything.

But it is interesting that you seem to get those issue also from the cockpit and external view cams. I have not had those yet. But your images clearly show that it is not restricted to the drone cam.

One more observation (SU5 HF2).

I did a number of long flights with the H135 … slowly … with ca 100 KTS.
And I have not seen those texture bugs during “normal flights” so far.

So it feels to me like this might be due to some internal (race condition) where very rapid position updates (like in a fast drone cam … or maybe a jet) have a far higher probability of triggering this bug.

Now the pics of @scstony clearly show that “fast moving” is not really the main reason, as he is just taxiing. So maybe it is also related to being very close to the ground.

Hmm … tricky …

I have noticed the corrupt tiles disappear when your plane is approx. 100m away - even while still on the ground. On the other hand corrupt tiles that are further away from the runway do not disappear until you’re a much greater distance away. It seems like the tile cache process trips on itself under some conditions, one being rapid movement as suggested by @nenenui.

Increasingly I get the feeling that this is some kind of …

 uninitialized (texture index) memory 

… typo of bug.

It happens very commonly right at the beginning of the game. Today I even have experienced it in the “World Map” when I was zooming in (quickly) to my departure airport.

After some time of flying the bug more or less is gone. This leads me to speculate, that by then all those index maps have been used and contain some valid information … and from that moment the code works as expected.

However … there also seems to be some correlation with “airports”. Especially the layered “airport tiles” over “natural sat image tiles” nature seems to get exposed by this bug. So perhaps my “World Map incident” was also triggered by the airport location.

Clearly the bug is not limited to the airport region … but it some becomes more likely to occur if there is an airport in sight (and in close distance).

… here is one example from the “corrupt texture tiles in the World Map” which I already mentioned:

I just upgraded to the latest AMD drivers … 21.8.2 … and the bug is still here.

First flight in 1.19.8.0 WU6 … and this texture bug is still around … hmm