SU6 Telling me to download 84.36 GiB

The directory I’m trying to install it to is C:Users/my username/Appdata/local/packages/microsoftflightsimulator_8weky…/localcache/packages. Please someone help :sob::sob:

Other info: I’m on pc Microsoft store version

Mine’s 82GB. Clicked update hoping it’ll download just the latest update, but so far it’s looking like it’s going for the whole 82GB.


So I would need to uninstall and re-install to get the update? I have only 40GB free on the SSD where FS20 is installed… :thinking:

Same here, it’s telling me to update 85,72GB. Also on PC and MS Store. Premium Deluxe Version.

when it tells you you have to update theres that box on the bottom of the screen, you have to point that to the directory that you actually have it installed to. It’ll try to fool you and want to update to the default install directory, so you’ll have to point it to where it really is.

Actually, it is pointing where the sim is installed (which is at least for me, the standard C://AppData path). If it would be pointing to another directory, it would ask me which packages I want to install, I tried that already :smiley:

However, since it’s pointed correctly, it only shows the 396mb update it wants to install in the middle of the screen, but the “Update Button” then shows 85.72GB for me, which I can’t click because I’ve not that much space left.

I’m having the same issue. Sim is still installed. Any solutions?

What size is the drive? because you really should leave 11% free and for system drives that doesn’t include a virtual cache.

Rename your C&O folders then start the update but pause after a couple of files. Delete the two newly created C&O files and then rename yours back checking and if necessary editing their path in UserCfg.opt. Close and restart the sim, it should only download core sim files plus any mandatory updates. You will then need to check for other updates in your content manager.

Of course if it recognises the lack of space you may have to point the packages to another drive initially but the procedure’s the same.

1TB, (50GB free, with MSFS of course installed) but that doesn’t matter, since the update should only be a couple hundred MB and not 85GB. Changing the path to somewhere else, displays some kind of a completely new download, where it asks me to select all the packages I want to install, with an even bigger download.
So the path is definitely correct, but some

I guess this could be some kind of server issue, with the update check. Because it emerged just today for some users who didn’t load SU6 until now, including myself.

Try moving something off of the install drive not msfs related and make some more room? 50 gigs isnt much room especially if its also your swap drive.

Again, this isn’t the issue and it is more than enough space. The issue is that MSFS is telling to update 85GB, instead of about 400MB.

So it would be more helpful if that issue gets solved, instead of pointing to full drives :smiley: I can’t make that room temporarily either way.

BTW, I have 3 SSD’s. One for the system (256GB) (C:) and two (1TB+500MB) for other stuff (D: and F:). MSFS is technically installed on D:, however it’s standard-updated through the rolling cache on C:/Users…/AppData/Packages/etc…

read my last post again, I have edited it

I’m having this issue as well. Plenty of space on my dedicated SSD though. When I first tried to update my current install, it kept getting to around 8GB of download then it fails and starts all over again. Completely removed and attempted to reinstall, and it’s doing that loop again! It gets to around 6-8GB than resets. I’m going to use up ALL of my allotted ISP data doing this…

Will MS/Asobo fix this?

1 Like

Sign out and re sign in to Xbox and Store, restart your PC and if only using a local account then sign in to your MS account as well. Check Store for updates. … the same procedure for Steam I would think.

Also it will greatly save your data allotment if you only delete the file that it fails on.

Still asking for the 85.72GB to update.

Version of the client. Opened a Zendesk Ticket, hopefully they have a clue what’s going on. Not really interested in a complete reinstall.

I’m having the same issue, and I tried above. I opened a Zendesk Ticket recently as well so hopefully it gets sorted.


It will ask but when you restart the update it should then make a recalculation … at least it did with mine but that was SU5

Yeah, it did recalculate - however from 95GB for the full game, back to the mentioned 85.72GB.

Had another one over at a german forum who also had the problem with the over 80GB download, just trying to update yesterday.

So I guess something broke on the server side yesterday, with the ingame update check.

I have no other ideas. It worked for me for the previous update but I suppose they may have changed something.
If you were getting the Safe Mode warnings it might have raised a flag server side to reinstall the official folder anyway.