SU6 won't update [decompression from... ]

Please tag your post with #pc and/or #xbox.
Are you on Steam or Microsoft Store version?
microsoft store
Are you using Developer Mode or made changes in it?
Brief description of the issue:
update “stop” at “decompression from…”
Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
just clic on the flipping “play” then accept update process
PC specs and/or peripheral set up of relevant:
Ryzen 7 5800x
32go DDR4
500go SSD
Build Version # when you first started experiencing this issue:
updating from last version before SU6

Like Sims Update 5 i got the same “freeze” at the decompression process during installation update.
Last time i waited month before a corrective update.

I love it, really.

i’ve tried this so far, unsuccessful.

same problem from here

So far i’ve tried:

  • reset game service
  • reset xbox app
  • delete faulty folder into local cache

Little update:

  • helpdesk try to make me reset my Xbox (nuff said…)
  • after understanding that im on a PC with the real problem they gave me the link above, of course it didn’t worked at all.
  • desperate for them to answer i’ve tried a full reinstallation of FS2020, i can’t install the soft now

Should i ask for a refund?