Sudden insane performance improvement?

I have no clue what is going on but I’m suddenly experiencing a ridiculously fluid image.
I even cranked up resolution to 4000 x 4000. Quest 2.
Anybody else?

1 Like

Let me check lol

Wake up! You’re having a fantasy dream :rofl:


yes, VR is perfect for me. Never in life has it been so good!!!

VR is cracking your brains. :wink:
It’s a virtual reality that the sim runs fast and smooth.

1 Like

No I’m dead serious.
Can someone check what happens if you turn on threaded optimalisation in nvidia settings? (rest of the settings are default)
That’s the only thing I can think of right now that I changed recently.


Nope its still the same and same meaning Needs a lot of work . I’m glad that it’s working for you tho.

I will post all my settings later today. Really curious how these behave on other machines.

btw I’m on the beta releases.


I’m on the beta too so I’ll give this a go tomorrow when I fire up my MSFS computer.

Following with interest.

I really hope some of you get the same results as me. It’s insane to see a fluid 4000 x 4000 image.
I’ll try to capture some inside lens recording and post it in this thread.
Note: taxing can still be choppy. (I do run FSLTL which may impact frame rate)
Also, be patient and give the motion reprojection some time to settle in.
This can take 10 to 30 sec. You sometimes also need to open the oculus tray tool and hit save again.

Good luck :+1:
Oh and as a reference use
It’s a good test environment with city, airport, clouds, sea, mountains.

Startup sequence:
When in world map start up oculus home and oculus tray tool.
Switch FS2020 to VR and check in openxrtool if frame rate and resolution
match up with settings in oculus tray tool. (As I said, you sometimes need to open the oculus tray tool, hit save, go back into FS2020 and toggle Ctrl+Tab if you changed Default super sampling

Here are all my settings I can think of.
Quest 2 with airlink
3080TI / i9-11900K
Computer is hooked up with ethernet cable to 5G router.
Headset is hooked up over wifi to the 5G router.
Router is 9 ft away from headset.
1Gb internet connection.

I’m in the fs2020 beta program currently 1.29.30





Oculus tray tool, everything default except screenshot showing here.
You can set Default Super Sampling lower or higher, depending on your system.

All nvidia setting are set to default except Threaded optimalisation = ON


1 Like

The one thing that strikes me is that you use ASW18, like I do, although I’ve got my refresh rate set at 120 Hz rather than 90 Hz. My target is 24 fps, while yours is 18 “real” frames per second. The other 72 frames of those 90 are interpolated by ASW. Might this be the reason for your sudden improvement?

I have tested all kinds of scenarios and on my lowly Ryzen 2700x with 3060Ti this extreme motion reprojection gives the smoothest image while still preserving enough sharpness and visual goodies. Of course I don’t like the wobbling in the menus but in flight things are indeed quite smooth and stable.

I experienced the same on the latest beta. VR as good as never before. No more fps issues on the ground.


The thing is I’ve had these settings for more than a month now. I flew yesterday until 8pm Zulu, took a break and round 3am Zulu started an new flight which was the first time I experienced these ridiculously smooth frames in super high resolution.
I suspect something changed in the beta code. I’m sure more people will start noticing this.

Do you mean a code change at the server level or did you have an update on the PC?

The code does not change by itself, there must have been a beta update for that change to occur.

There was a very small update yesterday I believe.

Just tried turning threaded optimisation on. No difference in FPS for my system.


you have a fov 0.7 and 0.65 thats is a bulleye From the Ship you can See Max 40percent.

Next is 18aw you have 18 fps? thats is Bad for me. i have 40 fps

Next is airlink the max 150mbit connection is Bad also.

you have a smooth pic but See 40 percent and 18fps

Thats Bad for me.


1 Like