Sudden LOD "Priority Loading" & Very Low Quality Photogrammetry Issue - please help me

Am in need of some emergency assistance please! :warning: :ring_buoy:
Been trying to figure this out for 3 days and not getting anywhere :sob:

I am pretty experienced with issues so I have tried all the likely things but I cannot fix this one.

Suddenly, all my photogrammetry is seemingly staying in the lowest quality (far LOD versions) no matter how close I get.

It is also affecting other objects (trees appearing suddenly in middle distance, snapping seams in water tiles, creeping water and/or sunken buildings, terrain mesh morphing) and some objects in 3rd party content (rocks LOD’s). But Autogen buildings are fine.

So it’s like something has globally broken and not respecting the LOD priority now, but it’s most noticeable with Photogrammetry as it just looks so awful.

Noticed some taxi lane boards jumping up and down (they snap to like 100ft in the air then back down again as if it thinks the terrain under them is higher for a moment).

I can see large patches of objects in middle distance missing then loading in / changing / removing themselves again.

Seems that my frame rate is also hitching regularly when the quality is low - like it’s struggling to compute something where it was much smoother before. With PG off in Data settings everything is smooth and fine.

Even happens with freeware PG mods that are on my disk, so it isn’t an internet streaming problem. It’s like it’s just staying in the furthest distance LOD state for ever. I tried restarting with no mods (totally empty renamed Community folder) and it’s no different. My internet speed is fine (900mbit down). Happens everywhere, not specific airports / areas.

I did add and update some mods (free and paid) before I noticed this happened, but I usually am adding something! Could it be that even after disabling a mod that may have made it behave like this, it can still have changed something in the core even after booting without it active?

Is there something I can reset, manually?

These are the things I have tried:
  • I do not, and never used Rolling Cache. I am not in the Beta.
  • Settings > Data > Online Functionality switch off > switch on > restart sim
  • Deleted all SceneryIndex files
  • Deleted mysterious cache/0 folder from Roaming folder
  • Completely empty (renamed) Community folder
  • Manually updating REX AccuSeason (as this changes core files so even with empty Community, there is still effects of that - didn’t try uninstalling it yet though)
  • Latest Nvidia RTX drivers (528.02)
  • DDU in safe mode to clean install the previous drivers that were fine (526.86)
  • Increase TLOD slider to 300 - frame rate gets worse but still low poly + weird patches everywhere
  • Increase OLOD slider to 120 - I get further draw distance of some objects but still low quality PG
  • Probably some other stuff
Some screenshots

The ONLY things I MAY have done on this PC since it worked last Tuesday (the last time I had time to fly):

  1. Windows update
  2. .net Update
  3. Update REX Seasons (daily automation thing)
  4. Updated payware: DC Designs F16, Discus, CowanSim Bell
  5. Installed a few free airports and Cape Town PG / Le Mans PG / updated existing mods (but since loading empty Community I can rule those out?)
  6. Moved all my airports to external disk (was out of space on my NVME!), but again I think I can rule that out, as empty Community isn’t even aware of those.
  7. Set Terrain Vector Data and Buildings to Ultra, before I noticed the problem. Changed back now.
  8. Cleared C Drive (disk cleanup: temporary files, event logs, shader cache, delivery optimisation files, windows update temp download etc).

I see there is a Windows update for Windows 10 “22H2” but I heard of issues with that. Should I install that? But it was working before so I don’t really see what that would help.

Not sure if this could be connected, but sometimes after I quit the sim and go to load it again, I just get black screen. The only error when this happens may be this:

Event Viewer Error

Faulting application name: FlightStreamDeck.AddOn.exe, version:, time stamp: 0x63558578 Faulting module name: ntdll.dll, version: 10.0.19041.2130, time stamp: 0xb5ced1c6 Exception code: 0xc0000374 Fault offset: 0x00000000000ff6a9 Faulting process id: 0x29a8 Faulting application start time: 0x01d92da26d8e08cc Faulting application path: C:\Users\mail\AppData\Roaming\Elgato\StreamDeck\Plugins\tech.flighttracker.streamdeck.sdPlugin\FlightStreamDeck.AddOn.exe Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll Report Id: 590952f2-0cd7-497c-b08a-a0a6f2ac6118 Faulting package full name: Faulting package-relative application ID:

I am out of ideas - I mean with totally empty Community folder it’s the same so it can’t be any mod I have tried to add?

I am suspicious that it happened after I moved my airports from the internal disk to external, but as I say even with empty Community (so the sim is not aware of any of those) it’s the same.

Thanks for any help and sorry for the long post, I just wanted to be as detailed as possible. This is driving me crazy and I don’t know what to try!

1 Like

Editing to add, it is also affecting some Autogen. Mainly smaller/lower buildings?

I see chunks missing in the mid-distance, then it fades them in, then they sometimes all instantly disappear again, only to come back when I get closer. Really strange but I think it reinforces my theory that something with distance / LOD selection, awareness and swapping is borked.

For example, whole area in red is missing - but at same distance on left is visible.

Then when I got closer, they all faded in, but also the taller buildings (in yellow circle) vanished then faded back on. Something really strange going on! It seems to be doing this in chunks all over the place, sometimes as I look around the cockpit too, I will see stuff suddenly appear / disappear

Now that you mention it, recently I noticed PG buildings appearing where there were “regular” graphics buildings. I see this happening each time MSFS says that I’m offline. After ending the flight and before exiting, I checked my connection settings because sometimes MSFS doesn’t restore the connection. But when I checked the data settings, they were correct for being online. I exited MSFS as I was finished for the day.

And there was a very recent Windows 10 update. I’ll check MSFS again.

A pound to a penny you need more space to stop unnecessary paging … if it’s a Samsung check out their Samsung Magician firmware, it should tell you how much provisioning is needed.
Also if your PC is up to it try

Enabled 0
Quality 0

Hey :wink:
I have 180gb free now on the internal D partition and 100gb free on C. Not sure what make it is (1tb NVME), it was all included with the device I use. Probably not a “known brand” though!

But it’s not the reason I think. There is MORE space now than before, and it was the D partition that I made space on, paging file is on the C partition. Set to “Let Windows Manage”. And this is a recent issue - not since I have touched paging file and the C has had that much free space for a few months.

Been doing a bit more flying in PG areas today - and it’s sometimes “better” but definitely not as good at loading chunks of higher detail as it was a few days ago. Can see whole zones snapping in and out of LOD states. And frame rate is worse. I am lost!

If that needs a beefier PC than the Ultra I have it set to now, then I don’t think I could handle it :frowning:

IMO that this works great for me probably has more to do with my 8GB ramdisk rolling cache than actual beef.

PS did you TRIM your NVMe after moving those files?

1 Like

Well, this is all pushing me to get a new system so I’m not too upset lol.

It’s just weird how it was fine one day and borked the next.

Hurry up and release those 7xxxX3D’s please AMD! :slight_smile:

So maybe there is a setting I should lower to help free up ram? Or, maybe some of my ram got too hot and died?!

I think that could also depend on location … I live in Nuremberg which very very rarely gets outages yet an aquaintance near Stuttgart suffers immensly.

But I first “noticed” the problem with a downloaded PG from (Cape Town, meant to be AMAZING. 2 of my screenshots are from that and it’s the worst effect by far of this problem there). So as it’s on my disk that would not have needed online / servers etc?

Thanks for replying by the way. I had a rare weekend to myself and was looking forward to flying around, then this problem hit me on Friday and I stayed up til past 4am trying to fix it.

Whilst I have had some fun flying in non PG areas this weekend, I’ve had this issue in my mind all the time and it’s made me a bit sad, as everything was working really stable until this :frowning:

Uninstall Geforce Experience
Restart PC.

Restore global and program settings via NCP (nvidia control panel) > apply.

Turn off PC > unplug streamdeck.

And possibly the 2nd best advice ever given on these boards :rofl:

1 Like

I don’t use Experience. All drivers handled manually.

I will try the other things though.

As unlikely as it is the occasional bot has got through their security, usually with some obscure freeware. One sign for mining bots would be quieter fans and a decrease in internet usage with task manager open but you’ll need a 3rd party app to spot it.

Oh, blimey. Umm well that is an angle I had never considered!

So you mean once a mod that has that “infection” is used, it’s running all the time? Like malware?

What would be the trigger to install itself on your system, as just dragging the folder in the downloaded Zip to my addons linker folder, then MSFS indexing it on startup, then reading it when I fly there, seems like those actions wouldn’t make the malware side of it work. I haven’t actually “installed” anything as such?!

Then I’d say you’re safe, removing it from community would eliminate any possibility but as I said it is unlikely the problem

1 Like

This didn’t help… I need to re-apply my max frame rate though (for MSFS Program specific setting) as it was struggling when not capped. I had it at 30 before, trying a bit higher, 36 now - let’s see!

Some buildings look good though - bigger ones?

It’s like for small props the ‘detection box’ (or whatever they call it) is suddenly smaller so it doesn’t draw the higher detail in for those because it thinks I am still far away (but I don’t think PG works that way like 3D objects do). Same theory for Autogen.

Disable iGPU via BIOS settings.


via Device manager disable wifi card and bluetooth.

I can’t disable the iGPU because it needs that screen on bootup before I can switch to my eGPU RTX2070.

BT and WiFi I can, but again… it was all fine like this until Friday so it’s super weird!

Anyway THANKS for the tips - I will try them all!

Here is RAM after setting to 38fps limit in NVCP and restarting the sim:

I have disabled the Intel WiFi driver.

For BT do you mean this Intel one, or all 4 of those items? Or in Network Adapters (the top one)?

Another strange thing here:
Whilst removing BT devices (I unpaired all the BT things I no longer use first) I seen that there was an unrecognised USB device so I removed that. Turns out that was my Ethernet USB adapter. It was a decent reviewed one on Amazon but “unbranded” and it’s plugged into my eGPU. It works though, I mean I get this internet speed:

I unplugged it and plugged it back in, and I have internet again now - but it still shows as this:

Strangely, after plugging that Ethernet adapter back in I must have knocked the USB Hub cable for my peripherals out of the eGPU and when I wiggled it back in, it redetected all my Logitech stuff as “new” items and “set them up” again!