Tail number and call sign not registering

Same issue here: call sign, etc are not remembered and the fuel/weight parameters are not transferred into the flight.

I have noticed this. Even if nothing is in the box the tail number I previously typed in there is still applied to the aircraft.

2 Likes

I put in the tail number then clicked on the aircraft picture to i guess lock it in

1 Like

On top of the problem reported by the OP, I also noticed this.

Still occurring. In a bush trip I am creating, I have set a custom tail number for the sim to use. Before SU5, it worked perfectly, however afterward the tail number is stuck on whatever it was set to on the world map. And I am also having trouble setting it on the world map.

Really hoping this gets addressed.

1 Like

Any news on this?

There will be more system fixes included with World Update VI which is currently scheduled for August 24th. I wouldn’t expect to see anything before then.

Hello everyone, this has been logged internally! Thank you for this feedback.

3 Likes

At first, it was the issue of previous entries coming back, now by the time I get to the 3rd field, they are wiped clear. Almost as if the F4 key registered as a keypunch, even though I am nowhere near it. It seems like this happens as you are moving from one field to the next.
VERY FRUSTRATING.

1 Like

I had this happening, any text input disappearing (although it did seem to register in the sim). But it was just one thing in a number that were getting worse with SU5 first update so I bit the bullet and spent 24 hours reinstalling and reconfiguring the sim.
Now the text stays in the boxes until the next restart when they are empty - again though the last details are remembered although they no longer show, which was what used to happen before SU5.
Hope the revamp later this month sorts this out so I know what callsign I’m going to get when I start to fly.

1 Like

Same issue here

Thank you for the response.

I think these UI issues go beyond the Customization page. Weight and Balance is also messed up (for me at least). Numbers do not necessarily disappear, but it is more difficult to enter anything in the fields. The cursors show up right-justified in the text fields. I can still enter new values by using the backspace key, but it feels unnatural compared to how text fields behave in modern UIs. I’m sorry, UI issues like this are just sloppy.

3 Likes

I have the total opposite issue, I can’t turn mine OFF, no matter what. The Tail number always shows, even if the box is blank, it’s infuriating.

Well, you can edit the panel.cfg file for your aircraft directly to turn this off, under the [VPainting01] heading, I set the 4 numbers in the painting00 parameter to 0. Maybe there is an easier way to hack this (check the forums), but that is what I did for one of my custom liveries.

I am also experiencing the same issue as most of the people here. When I first installed the game I never had this problem, the last patch broke it or/and I also upgraded to the premium Delux edition.

Issue: ATC OPTIONS not saving (auto clearing)
-TAIL NUMBER
-CALL SIGN
-FLIGHT NUMBER

Seems like an issue writing and saving to the config file

Update from me. This actually started to work, granted it doesn’t save the text in all of these fields, but at least ATC now picks up a correct airline and a flight number, before it used to call the last entry I made prior to downgrading to SU5.

Last night, I got the tail number to stay long enough to click ‘OK’.

During the flight ATC referenced that tail number, but it did not show on the panel tag nor on the exterior view of the aircraft.

After Clear cache / uninstall and reinstall the whole simulator in another disk / launch as administrator…
I still have the same bug in customization setting
Tail Number, Call Sign, Flight Number, “Heavy” reset to blank
i’ve found it reset after every 30 seconds.

(Almost Fix):
In flight conditions just unchek live time in the “custom weather and time” and it stop reset after 30 seconds.
You can set the real time later in game.
Live Weather don’t cause the bug, only Live time.

Gods this is an annoying bug. Tried the trick above but it keeps my callsign from my previous flight even when I switch to general aviation.