Tail number and call sign not registering

Isn’t a tail number required by law IRL? :man_shrugging:t2:

1 Like

Yes obviously mate…?
We’re talking about the in-game Tail Numbers opposed to the ones that are already printed on liveries if you hadn’t at all read the thread.

This is STILL not fixed. What a bunch of amateurs.

1 Like

Microsoft Store version

Add-ons not relevant, but has been tested with and without community folder

Not in developer mode.

When setting up a flight, the customization page/ATC Options will not continue to display tail number, call sign or flight number after they are entered. This has been occurring since the last SU release. Also, the “append heavy” option is now constantly defaulting to “ON”.

No screenshot necessary.

To reproduce, type in data in the fields and either wait for the entries to disappear, or click on another option (like “weight and balance”) then go back to Customization.

Version 1.19.8.0

Problem started with base version right after SU5.

Have not submitted to ZenDesk yet.

Yeah incredibly that this simple thing is not hotfixed … and then not even with WU6 !!!

Horrible :-1:

2 Likes

Here’s a good one:

Flew A320Nx earlier today. It took a couple of tries but I got the callsign and flight number to stick. Now I’m trying to fly the King Air (and after shutting down the sim for part of the day) and even if I get the tail number to stick, I’m still called United 477 by the tower. Not sure how that one works… :frowning_face:

Don’t forget to upvote this bug to make sure it gets attention. Has anyone submitted the bug to zendesk?

2 Likes

Same issue here post update hotfix…

same thing is happening after I upgraded to WU6. Lost my call sign, it won’t remember what I type in. very frustrating. I don’t have much time doing the sim these days, every time I squeeze some time trying to enjoy a flight, theres always something wrong. Losing interest in this

Exactly what is happening to me. Not sure which “Update” downgraded this, but I want it back.

1 Like

Not at all the problem. You have walked only half way through this issue. The issue is not only visual. it effects ATC coms also. I have noticed that SimBrief seems to be able to fix the ATC issue, but only when using SimBrief to load flights are you able to modify the call sign, Append “Heavy”, Registration (N number) etc…

Are you on Steam or Microsoft Store version?
Steam

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
No

Are you using Developer Mode or made changes in it?
No

Brief description of the issue:
Custom settings for tail number, call sign, and flight number no longer persist across sessions or after returning to the main menu. As a result, they need to be set before every flight, which sucks.

Detail steps to reproduce the issue encountered:
From the main menu, click world map. Click on your aircraft picture. Click customization. Type in a tail number, call sign, and flight number. Click close. Click on your aircraft picture again. Note that the values persisted. Click close. Click go back. Click world map again. Click on your aircraft picture. Note (in customization) that the values for tail number, call sign, and flight number are all blank!

PC specs for those who want to assist (if not entered in your profile)
I5-9700k, 32 gigs of RAM, 3080ti (no overclock)

Build Version # when you first started experiencing this issue:
1.19.9.0

Did you submit this to Zendesk? If so, what is your ticket #?
Not yet.

They are persistent for myself (Steam version) but what I have noticed is that if I go into the settings, they are all blank.

If I enter the sim the details are all there (on the plane, ATC using the correct call sign, Etc…) but the boxes to enter it in config are all blank.

Yep, what he said. I have tried to just get rid of the 1123 in CS to no avail. Must be bug, which is in the queue to fix. Make if a config file we can edit please.

Yea … just hit me too… I run ATC all the time. I stopped answering ATC cus I didnt hear my call sign… Oh well, turn ATC off and hook up my xbox controller. Its looking more like a video game to me… lol

bn trying for hours to figure this out. I think it might have something to do with real time traffic. I was able to get it to remember my tail # between sim loads by toggle that option. but rebooting the pc brakes it again. I am able to save then load a flight at startup with my tail # but the drop down menu disappears.

Same problem for me. It’s not possible to use a callsign only without a flightnumber. If you do so, ATC uses the latest flightnumber you’ve used before.

feels like it now part of the flight plan startup procedure. every time i load a plane it ask for at least a partial departure flight plan. so now I do the modify thing to uncheck heavy because I usually fly a B58 then add my tail #. Have to be quick about it tho, if I take too long it goes back to default.

I ran into a few procedural changes here that are different from the old FSX days. Are they trying to make it more realistic?? Uno in real life we have to file a flight plan and enter the tail # before we get in the plane… LMAO…

Same issue here.

Was reading through the Release Notes for SU6 - Beta is now out for testing - and there seems to be some sort of fix involving this bug. Let’s all cross our fingers!

2 Likes