Taxi Objective pointer wont disappear during flight (Remains at end of runway)

Creative, but still a fix. :slight_smile:

1 Like

Yep this is what i do when the icon stays stuck on.

1 Like

Thank you for this workaround.

I struggle with this a lot recently, as i prefer to fly VFR from small, uncontrolled airfields since VR came out.

That blue and white circle was really disturbing.

I honestly hope, there will be a proper fox to it.
I dont want to go through severl menues to (de)activatd the ribbon as in some airports i simply need them due to lack of possibility to display Charts in VR.

So either an assigned key or a better logic would je really nice…

1 Like

Resizing the ATC window on the second screen brings it back to normal for me, after it got wonky when I changed something in the options.

What Pilots do is have the diagram of the Airfield to hand to reference the taxiways. They also research the destination airfield before they file the flight. Some even have co-pilots.

Some put the diagram behind a clear acatate sheet and draw the taxi route with a chinagraph pencil.

This is a bit tricky in VR. The ‘ribbons’ substitute for the chinagraph line. :grin:

This is an old problem at un-towered airports.

If you watch the objectives window, from the ramp it won’t trigger the “taxi up to 15kts” step, the next step being to follow the taxiway to the runway, then hold short.

I have not tested this fully since the last update, but just going through the motions as I did over the weekend, it still does not detect you take off.

Interestingly, if you then fly to another un-towered airport, taxi to parking, then request takeoff, this second flight will detect you taxiing up to speed. but never the first.

The post below I tried to list all the steps that appear in the objectives window in order, covering taxi, take off, landing, and taxi back to parking.

This is the step that does not trigger from un-towered:


But it works the second time just fine, so it’s definitely a bug, but seems to not get much interest, sadly, as it is so easy to demonstrate. It does not occur at towered airports, ever, as long I interact with ATC.

Will test again later this evening, hopefully, but I believe it is still broken.

To remove the pointer back to where you just left, the workaround is to interact with a different tower, and announce your intentions.

Taxi ribbons is the only assistance I have enabled. The instructions Ground Control give are so terrible and so many of the airports’ taxiway data don’t match up with real world charts. The only way I can find my way around in unfamiliar large airports is using the ribbons.

That said, I’ve also had this happen several times since the last patch. I get instructions to my runway or parking spot, but ribbons don’t appear, even through the option is enabled. Luckily, this has only happened to me at familiar airports. It doesn’t seem to be specific airports, and can hit at small or giant airports. The occurrence seems quite random. I’ve had it happen at CYGK (Small local airport), CYYZ, KLAX, KSAN, KAPF, KOPF and KORL so far in the last few weeks. These are all locations I fly in and out of regularly. Nothing is different from flight to flight. It’s happened with both IFR and VRF flights out of all locations. These are all towered airports. I can’t remember this happening to me at an untowered field as of yet.

And to be clear, I do use ATC and follow their instructions to the letter.


the issue is due to an objective not being met. what i’ve found is the objective of taxiing to the edge of the runway doesn’t always work properly. there is something that needs to be done to trigger that objective so it’s met. i’ve arrived at the edge of the runway and found the objective hasn’t changed, so i taxi along the side of the runway and eventually i generally hit the point it was looking for me to taxi to, and then the objective will change and then i can take off from the runway.
the only other workaround is to start your flight from the runway and not from a parking spot or gate.

1 Like

@LikelyMatt I have modified the thread title to make it clear that it is an ojective pointer that is not updating, rather than anything to do with the taxi ribbon. I trust you are happy with this change.

… and if the objective pointer stays there (doesn’t detect that you took off)… it doesn’t log the take off in the pilot logbook at the end of the flight… (bug collateral damage).


I just came to say what BarrelShip just said. Happens usually at airfields without tower, if using cold start, but can also happen where tower is present.

If you takeoff from a runway start, it will log. But from the ramp, it will get stuck at the “Taxi to 15kts” step, and will not proceed to the “Follow taxiway to runway” step.

It’s interesting that it does work as intended if you then visit another untowered field, and repeat the process. I’m not sure I’ve ever tried this while remaining in the pattern i.e. take off, complete a circuit, land, taxi to parking, then request takeoff clearance, and repeat. In theory it should log 1 takeoff, and two landings only.

A pointer about taxi speeds.

If a runway is part of the taxi route, 25 kts is OK.

15 kts is OK on the taxiway straight.

Drop to 12 for a bend and 10 for a 90 deg or greater turn.

If the airplane pulls on idle, drop the flaps full and/or operate the air brake panels.

Try not to use the toe brakes. You will be paying for pads replacement before time. :grin:

1 Like

Its a bug. If you do not follow the ribbon exact to runway this happens (taking own route not following ribbon). If takeoff not logged this happens. If airport has no tower it can happen. All sorts of reasons will cause it to happen. Another MSFS bug


I took my own route to the runway for take-off a lot of times, and I got logged. Because when I take my own route, the ribbon changes and update itself with my new position.

It is a bug and was also reported by myself in another topic 2 days ago. A workaround to get rid of the taxi marker:

  1. cancel IFR in the air. (if you use)
  2. tune the nearest airport from the atc menu. MUST be different that the one you took off from!
  3. when you click on the airport menuitem, the taxipoint will disappear.
1 Like

It is an old bug, but there is a mod that fix this by removing the pointers, it is a part of the taxi ribbons size mod, the payware version have an option to remove the pointers and the green square at the end of parking.

This is the most annoying bug so far. 6 months since release and still not solved

1 Like

There are ways to get it to disappear, but you have to interact with ATC, essentially request taxi, then request takeoff.

At untowered airports you have to do them in that order. If you announce takeoff, it won’t matter if you then request taxi, the markers will remain until you switch to another tower.

It’s not just about the marker. Marker is just a symptom. The underlining problem is that the game does not register aircraft arriving to the runway and taking off. In some cases it doesn’t even recognize taxiing. Go to uncontrolled airport like Sedona and test it using Objectives menu.