Logbook not updating after patch

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

I logged this with Zendesk maybe 2 months ago. For me at least, it’s a known issue. Don’t press Continue, as it will only ever log the last leg of your flight that you return to the main menu on. Continue effectively ensures all flights before that are forgotten.


Vote on this issue here… it is well known and has been discussed for many weeks.

It happens to me few times too.

MSFS’s log is different then the real log and it log only last take off and landing if you don’t go back to the main menu.
For example OP fly from A to B without going back to main menu and continue from B to C you loose A to B.
Correct way to do it A-B, main menu, B-C, main menu, C-D… Pain in the behind!
Oh if you fly A-B-C without shut off at B and continue to C and end flight there you will get a AC log with 2 take off and 2 landing.

1 Like

Below is a log of all the steps the steps followed at a towered airport, to ensure both a take-off, and landing, are recorded correctly. If one or the other is not, then it is likely you are stuck at one of these steps, and the next did not trigger for some reason.

Cold & Dark.
Choose pushback if wanted.
Request taxi clearance.
Engine started, fuel shut-off valve opened.
Taxi to runway.
Tune to tower.
Request take-off clearance.
Enter runway, and line up.
Entering runway.
Throttle up.
Raise nose and life off.
Stay in line with runway
Complete climb.
Frequency change approved.
This one only seems to appear if you have an actual plan loaded.

Request landing clearance.
Line up.
Follow guidelines, and land.
Reduce speed.
After landing and pulling off the runway.
Clearance granted.
Stop engines.


I just made a Logbook issues thread for the upcoming Q&A with Asobo


Feel free to vote if you think the logbook needs improvement.


Somebody already mentioned that some time ago … but “Crashing” an aircraft after (during) landing seems to be the most reliable way to get the flight logged.

I tried it today and it so far was reproducible.

All smooth landings + taxi + park have been ignored.
The three where I did … smooth landing + full throtte + pull up + rotate left and crash on the wing or roof … all got logged. So I at least can book the flight duration. Obviously … the landing is counted as “zero”.

So now to me it increasingly feels like the actually “internal” flight trace (log) works … but there is a bug in the final “commit” into the log. Only certain actions (e.g. like “crash”) guarantee such a “commit”.

So from now on I will happily crash on all final destinations. Buckle up! :slight_smile:

1 Like

I was able to get my logbook to record my takeoff, landing and flying time correctly at a non-towered airport (Casa Grande, AZ from Tucson, AZ). I kept the objectives window opened. After I landed it said to end flight. I picked an empty spot between some other planes. There were no parking Marshall’s to be found, just a bunch of guys walking around doing nothing. I turned my key off, turned all my avionics off then killed the batteries. Once I did that, it popped up the window for my logbook. Usually I would hit Continue at this point so I could go in and make sure everything was shut off. This time I just hit the option to go back to main menu.

1 Like

Even at airports with an active tower you can’t always get access to the correct ATC options. Sometimes it’s completely blank.
When planning a flight I always go from parking spot to parking spot but often the game forgets this info and I can’t assign a new parking location.

When people are planning their flights that do log are these purely A to B with no waypoints in between?
I’ve noticed more failures when you have waypoints.

With no tower, you usually just tune to a Centre that covers that airstrip, or simply announce you are taxiing, taking off etc. You don’t get a response, you informing other pilots in the vicinity.

These are the ones that will often not transition past the taxi to runway phase, and thus no takeoff logged. I have for them to trigger before, but involved taxiing around the threshold of the runway till it detected a change in my location that would trigger then takeoff phase.

I had similar failures with either waypoints … or no waypoints. At least I could not detect a big difference there. It feels “stochastic”.

But “crashing the aircraft” after arrival so far consistently registered all flight minutes and all takeoffs and landings during the flights.

It feels to me like all the internal “logging” is OK … but the final “commit” into the Logbook only happens unter certain conditions. The most reliable condition (so far 100% for me) seems to be … crash the aircraft on the final destination (e.g. into the terminal or whatever)

1 Like

I thought I solved it. At least with bigger aircrafts. After landing tune to ground and ask taxi to gate or parking then the game will create big rectangle around your designated parking. At that spot you need to turn engine and batteries off. Some kind of menu pops up and at this moment the flight is ended and properly logged in. But I was wrong. Today I landed in Kuwait International Airport and there is no option taxi to gates or parking only taxi for take-off even though there are gates. Since turning engines and batteries off will work only if I am in the rectangle I can’t properly end the flight and it is in logbook as landing in vicinity.

Hmm … I have to correct myself. Today I lost two takeoffs during one flight … but at least the original departure location and the flight duration and two landings have been registered correctly.

So this clearly suggest that the “final crash commit” only gets my flight logged, but the takeoff-landing-count question seems to depend on yet another aspect. Hmm … tricky.

The next time you get one of those flights where you suspect it might not log, just bring up the Objectives window, and post a copy of it here. That will give you a pointer as to why a landing might not be recorded. It’s worth having it open when about to take off as well, as it will indicate whether your take off might be logged as well.

It may be that it didn’t detect your landing. It’s a towered airport, so if you were tuned to the tower, you should have heard ATC give you a couple of messages about exiting the runway at the next taxiway. Did you hear that? If not, it could be your flight was stuck at a different stage. As you taxied off the runway, you should have then been instructed to change to Ground? Did you hear that?

To me there are (at least) two key questions here:

  • How to work around this bug?
  • How to explain the cause of this bug?

The “ATC” and “Objectives” window to me fall into category one.
For the second question I observed the following today:

  • Three airports + two takeoffs + two landings … and lots of taxiing.
  • The flight was logged … the duration looked correct … and the departure and final arrival were correct.

The interesting parts are:

  • (a) I did fly … and the log has the correct departure airport … but no takeoff
  • (b) The flight duration clearly only recorded the “air time” … my excessive taxiing has correctly been “ignored”

Especially (b) suggests to me that the internal tracking of activities can clearly distinguish between “air time” and “ground time”. So the overall tracking seems to “pay attention” all the time (as expected) and the fact that there have been transitions between those state should allow counting the “takeoff-landing”. For some reason the game engine does not use that information.

(Looks like there is a pending update … so fingers crossed)

If we consider it a bug, then it might be perhaps one of two things:

  1. The player has fulfilled all the objectives to trigger a takeoff/landing, but it did not trigger for some reason. I see this a lot at untowered airstrips, where it does not detect you taxiing, then entering the runway.

  2. Sim logic for advancing through those states itself are bugged.

A workaround for 1 might be to simply credit the user with a takeoff. I’ve observed that even when it still thinks you are supposed to be taxiing to the runway entrance, even though you are currently climbing, it will eventually switch to one of the later states, such as climb to cruise height. Just consider that as a take off event.

Take off are fine. those are correct and logged every time.

I landed at kuwait airport with IFR gently, no hard landing or crash. atc asked me to leave at nearest taxiway and then contact ground. I change to ground and there are no taxi to gates or parking only taxi for take-off or ground service. Today I flew to anchorage and flight is fully logged.

Did you use the recently released Kuwait community add-on? Anecdotally, I have more issues with take-offs and landings not logging at community add-ons compared with default airports.