TBM autopilot question

I am flying a from KOPF to KFHB and start the rnav approach to RWY 22 from fix HEVIP and the next fix is CUGTO and the FIVBA. I skip and fly direct to FIVBA and all is good until I get to FIVBA and then the auto pilot wants to the then fly to CUGTO again and basically start the approach again. I hit the direct to FIVBA again and it keeps resetting to CUGTO. Is there something I am missing, or is it a bug

g?

1 Like

Watching with interest as I have the same and believe its a bug…but waiting on an expert to confirm.

I don’t know if it it’s a bug in the TBM AP or in the RNAV data. Sometimes it happens, but in RNAV approaches only

This is a bug, and a very critical one, that hasn’t been fixed yet, despite numerous bug reports, votes and threads. See:

https://forums.flightsimulator.com/search?q=u-turn

@Sunday748 it happens in ILS approaches as well.

5 Likes

Yip IFR just tried to kill me as the ATC instruction tried to fly me into a mountain :slight_smile:

I enjoy the TBM nice aircraft.

1 Like

The same thing happened to me, I was 10 seconds from death when I disconnected the autopilot and steered away from the mountain, IFR is absolutely life threatening in bad weather.

Wasn’t even bad weather but I must of had about six different flight level corrections in the space of about 2 minutes.

2 Likes

I don’t think this is 100% wrong, I have had this in real life with the Garmin 430/530. What you should do is select direct to the final approach fix and then select the leg from the final approach fix to the runway in the flightplan and select “activate leg”. I don’t believe it will sequence back to the waypoint you skipped in real life but with GPS approaches the auto sequence is disabled if you fly direct to FAF without activating the next leg.

I don’t know if this option is available in MSFS, but selecting “activate vectors to final” will disable the whole flightplan and draw an extended centerline, intercepting the final approach course before reaching the FAF this way will enable auto sequencing to the approach.

That being said, I’m not sure if you are allowed to fly the approach like that. I’m not 100% familiar with the G1000/3000 anymore but I know that on a couple of other avionic systems I have flown, not flying the approach as published via the IAF will result in GPS not switching in terminal and approach modes (1 nm and 0.3 nm CDI deviation), since in MSFS the CDI is always in en-route mode this probably doesn’t matter though.

Edit: I just noticed that FIVBA is not the the FAF, CUGTO is! Why would you fly direct to FIVBA, skipping the FAF? You can’t fly a GPS approach that way, I’m pretty sure this will create problems in real life as well. You probably could do it if you want, again by activating the leg from FIVBA to the runway, but in real life nobody is gonna take the responsibility and clear you for that. You are basically creating your own procedure, hoping you won’t hit anything in IMC while not flying the published tracks below MSA.

2 Likes

I know I skipped CUGTO but what if ATC cleared you to FIVBA or any other fix if it was a controlled air port? Or how about when they change approach and the auto pilot wants to fly backards to a prior fix? This is why I am asking if it a bug or user error.

Whan you have to change your approach, remove i from the flight plan and then select the new one
If you dont’t delete previous approach AP will try to direct the flight to new APP via old APP !

Well when flying a RNAV approach ATC will never clear you in such a way as to skip the Final Approach Fix (FAF), I’m not 100% sure how the real G1000/3000 will react. My experience with other Garmin systems is that they don’t like vectors to a FAF or flying to any final approach waypoint skipping the FAF, this screws-up the waypoint sequencing and therefore you might need to use the “activate leg” feature. It might want to intercept the FAF and pick-up the approach from there, I’m not sure.

Thanks! I will stick with that.

when back and flew it again, worked out better and noticed the VNV is working now!

Ok the VNV was a little behind but the APP work on the RNAV approach even with me dialing up the wind to see if it would hold the approach. So I suspect some of my problems was user error since most of my flying has been VFR flying

1 Like

I just came across this text when refreshing PBN knowledge:

  • The manual entry of coordinates into the navigation system by the pilots for operations within the terminal area is not permitted.
  • Direct to clearance may be accepted to the intermediate fix (IF), provided the resulting track change at the IF does not exceed 45 degrees.
  • Direct to clearance to the Final Approach Fix / Point (FAF / FAP) is NOT acceptable.

Still I’ve also noticed the same problem en-route a couple of times where the waypoints weren’t sequencing correctly after a direct-to. So it might very well be a bug.

1 Like

This is a problem for all aircraft, maybe not the FBW mod for A320. I haven’t used it in a while. The direct-to function for Garmin is faulty and should be used with caution. This has been a problem since initial release. My best advice is if you want to do a direct-to, check your flight plan page on the garmin and verify your legs. If there are duplicates, delete them. If not, you’ll be flying much longer than anticipated.

1 Like

Yes you are correct. On a legal RNAV approach, you can’t alter or fly direct to any fix beyond the FAF. There’s a good reason why. Because that’s the whole purpose of the approach being built is obstacle clearance. You fly direct to the MAP does not guarantee you clearing the trees/towers/mountains, legally speaking.

For extra credit, you mentioned that ATC can have you direct to an intermediate fix, however on RNAV RNP approaches, you have to be careful because those fixes may be fixes that the AP can’t turn tight enough to rejoin the approach. Airbus has this limitation.

2 Likes

Yes and some types I have flown will not transition into GPS APR mode (RNP 0.3) when not flying the approach as published. Regarding directs to an IF, that is where the 45 degree limitation comes from.

2 Likes

Oh yeah, that’s most definitely a bug. I’ve been fighting my way around it since the start. The GNS530 mod actually fixes it for those planes, but the G1000/3000 is still hopelessly broken. Hopefully the WorkingTitle team can fix that, as I don’t have very high hopes that Asobo will in any reasonable time frame.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.