Terrible Performance after SU8 with RTX 3080[SOLVED] Might be Useful for People Having Performance Issues

So I have in game vsync now set to 30, but please can you talk me through what I need to do in NVCP?

When you say there smoothness tweaks?

Quite literally described in this post here. Do the NVCP in a new tab for FS only not global settings. reset everything first then set them as described below-


Okay so made the above changes except “prefer max refresh rate” as I can’t see that option. Under the change resolution tab it’s set to 60 though.

Let me boot up MSFS and see what happens

I prefer to use Fast Vsync in the nvidia control panel myself.

I only have the choice of G-Sync or fixed refresh on my 60hz monitor. In this case choose fixed refresh.

I’ve found that against previous experience, using VSYNC 30 in the game gives a better end result.

The credits should be gone to @BragRaindrop933 and the person who is owner of the video that @BragRaindrop933 referenced. So finally, combining everything, for the future readers try to follow these guidelines and check which one works for you.

This is the suggestion from @BragRaindrop933 and explains step by step what you should do:

Here’s what I did different than what has been suggested. I’m not sure if @BragRaindrop933 suggested to perform the Nvidia Control Panel:3D Settings for the Global Settings or for the Program Settings but I did it for the Program Settings, so the same settings for the Program Settings. I’m using everything in Ultra and Render Scale is %100 which is the native resolution of my monitor which is 2560*1440. TLOD is 200 and Object of Details is maximum.

From the same Nvidia Control Panel, Display → Change Resolution → I kept the refresh rate as high as possible but I think keeping this 60 could be ideal too, I don’t really know since MSFS definitely can’t reach 165 FPS.

Furthermore, I didn’t turn on the V-Sync in the MSFS and never set it elsewhere. So I’m not using it. Well this is up to you, if you wanna get a stable performance and 30 FPS all the time, then I’d suggest you to use V-Sync, but if you wanna get more than 30 FPS and you are okay with microstutters and changeable FPS throughout the fly, then don’t set it and don’t enable it.

I hope this helps everyone and I’m pretty sure @BragRaindrop933 and I would be so happy to hear that if the solutions that we shared and combined worked for you.

Oh, by the way for the final note, here’s my system, please bear in mind that everyone’s system is different so there’s no guarantee that these will work for you.

EVGA RTX 3080,
i7-10700K not overclocked,
32 GB RAM 2666MHz,
512 GB SSD for MSFS

This the video that @BragRaindrop933 suggested;


Very interesting so in your opinion which setting helped you the most? low latency mode? Or texture filtering? or power management mode? I think there is mileage in all 3, or was it balancing your CPU/GPU load first? Just curious where you saw the most difference coming from.

I don’t really know to be honest, can’t really tell which one of the Nvidia Control Panel settings did this effect but I’m so scared to try them one by one :smiley: But I’m %100 sure that Nvidia Control Panel settings changed everything for me in the game. I don’t think balancing CPU/GPU because my settings are the same as the one of my first posts that I shared for my in game settings.

1 Like

Yes when you find a good spot there’s a huge reluctance to change a thing! The 30FPS gives me the fluidity (along with a quieter GPU fan!) I like when panning wildly about in the cockpit, but it’s very interesting to see that it works for variable FPS up to 60 too. I’ve seen all kinds of claims on here about NVidia CP settings, it’s also another area where people seem to have entrenched views and a wild variety of settings. Do you have HAGS OFF too? It’s HAGS off for me in Windows but Game Mode is ON. Again I’ve seen varying claims about these two. In relation to stutters.

1 Like

That’s exactly the same on my end. I’ve also read couple of suggestions that suggest to turn them on/off, but this is what I’m using at the moment :slight_smile:


Thanks sooo much, i think this just solved all my issues!!!


We’re glad that it works for you !

1 Like

I had it in 144hz and the geforce settings were all standard. Changed to your settings you advised, Turned up the resolution in the options to make the gpu work a bit arder and bingo, solid 30fps constantly.


Again, all credits to @BragRaindrop933 :slight_smile:

1 Like

All credit to Pilot Pete wherever he is. Just pass the info on for others to try. The more people we can try to help the better. FS shouold be able to be enjoyed stutter free irrespective of the hardware combinations we use.


So I saw better performance last night at Charles de Gaulle as posted above, but this morning it’s no quite as good as last night, so I think the servers play a part.

I actually tried low latency mode on, but turned it off again as it didn’t seem to do much and my system is more CPU limited than GPU, and I believe low latency mode is there to help GPUs.

The bigger result from @BragRaindrop933 was by turning TLOD down a bit, and pushing render scaling up to 125 @ 4K - this got me around 4-5 fps and the take off roll at Charles De Gaulle doesn’t go below 22 FPS so appears smooth.


Did you try the 30FPS/60Hz tweak for smoothness? It seems to drop CPU/GPU loading a good bit for me too.
Also keep all traffic down a bit as it’s CPU intensive. It may well be your CPU is the bottleneck, but keeping it from being limited by dropping it’s load while keeping GPU busier is key when mainthread limited with a high end GPU.
I suspect that each sim update change CPU/GPU loading a bit so everyone who isn’t already optimised ends up seeing issues without realising that CPU/GPU balancing may be required.
Look up ‘32ms latency’ on here Grabber523 has done a lot of ground work for us all on balancing CPU/GPU loads and has been a great help in understanding the issue. You may want to further optimise/balance to target the 32ms GPU render latency as that seems to be his recommendation, although that could just be for the 30fps use.
Anyway the main part is having the awareness of how to reduce mainthread limiting, you can further your research from there.
ps. mornings may just have more AI/live traffic at LFPG than evenings. It could be a factor on your CPU.


So my vsync is set to 30 fps in the game, and NVCP is set at 60hz under “change resolution” tab. I don’t have an option for “prefer max refresh rate” anywhere.

So hopefully those are the tweaks you are referring to? Except with low latency mode turned off as I’m more CPU bottlenecked.

1 Like

You could also try with VSync off as @CkTheWinner has seen his system free up to where he’s happy just with the NVCP changes. Also make sure HAGS is OFF if you haven’t turned it off yet. Windows Display Settings->Graphics->Change Default Graphics Settings->Harware Accellerated GPU Scheduling->OFF (+restart)


HAGS is off :slight_smile: