Terrible performance after switching 2D/3D

Using an RTX3080ti with a G2 headset and sometime around or after SU11 the performance after switching modes has gotten bad. It used to recover after a bit.

Now if I go from VR to 2D it gets so bad I have to sometimes use task manager to kill the process.

Otherwise it’s super smooth

Anyone else have this issue? Currently I don’t load or exit a flight now without VR mode on first.

1 Like

Yeah it used to be very well behaved, could go back and forth 2D/VR several times in a session and all was good. Recently it’s often not, and switching can give extremely poor performance outside the realm of reasonableness.
One thing that worked for me a few times, is if I get bad 2D perf after switching, shut off the WMR portal, and it’s back to good. Haven’t extensively tested any of this to know how consistent any of this is but that is one that that worked at least a few times for me.

I noticed the same thing before reading your reply. I shut down WMR and regained control of the sim.

At the SU11 launch, I’m sure I could hop in and out of VR without issue.

1 Like

It could have been a Windows 11 update or WMR Portal update. But yes, I remember during SU11 beta I was amazed at how smooth 2D/3D transitions were.

This has been an issue for me for as long as I can remember now.

But yeah, closing WMR usually clears things up.

Still wish I didn’t have to do it, since once in a while it does cause me to CTD.

1 Like

I have the exact same issue! Does anybody know how to fix it? My issue is I start in VR on a long flight, toggle out of VR and go do something else, come back and crash into the runway because the lag is so bad. Also on a 3080TI with a 9900k Windows 11 32GB RAM. Performance is the same in VR after toggling in/out as it was on my 1080ti.

I’ve just stopped toggling out of VR. I’ll even exit to menu in VR first.

I think there is a mirrorng mode in WMR that can help with keeping an eye on things.

There is no known definitive fix. It’s been an issue for quite a while, and been talked about up and down.

What works for me…MOST of the time, is closing WMR and re-opening. Still, it doesn’t work 100% of the time. Sometimes, it just makes the sim CTD.

What solved it for me was a 4090 seamless transition,3080 i had the issue always.

So with a 4090 you can toggle in and out of VR without risking getting major lag?

I have the same issue. No real solution yet unfortunately.

Yep its instant not even a hint of a struggle,Night and day difference.

I fixed that problem by matching my PC and VR graphics settings.

My PC settings were initially much more demanding/agressive than for VR. I feel like handling that transition is what was causing problems. I would often get 4fps switching back into VR during a flight.

3070 Ti
G2 v2
32 Gb
Win 10
MS Store version

That make sense. I can also try to drop the resolution down to 1080. I usually have it native since I use developer mode a bit.

But around summer or fall it was toggling without issue.

I try to keep the vehicle densities the same so simobjects aren’t changing when toggling.

Any news on this topic? I experience the same problem. As in the other reports, this was not a problem before (not sure when it started).

There is this bug report to vote on:

After switching back to 2D, kill the WMR window.
Now you have good performance in 2D again.
Switch to VR (3D WMR).
After some seconds (!!) you have good performance in VR again.

Logically, it will be difficult for programmers to improve since MSFS looks better and better. Think about what happens when you suddenly jump from low-detail VR mode to 2D with different settings. The small amount of memory of the graphics card has no place to quickly put this amount of scenery with different settings. So the first thing you should do if you want to fly in VR is to adjust the settings for PC to those of VR. The more memory the graphics card has, the more this type of switching will be tolerated - e.g. 3080 I had these problems and with 4090 there are almost no such problems. I write almost because there are scenery where the jump from VR to PC tragically beats the performance even on 4090, unless I have the same PC / VR settings.

On mine, when I switch sometimes, WMR changes the focus to some other app, and the screen goes to desktop, with all windows, including the game, running but minimized. This is from peeking out under the goggles. I have to hit alt tab until the game window is highlighted, then the performance comes back in VR. MSFS doesn’t do well when the game app is not in focus and something else is, like LNM, or Discord.

Have this too but only if i push my 2d Resolution too high. If i set it to normal i can switch 2d/VR without problems

This trick does not work for me.