The game freeze because my game keep connecting to dev.ditu.live.com:443 and returning HTTP 502

Are you on Xbox, Steam or Microsoft Store version?
Steam

Are you using Developer Mode or made changes in it?
No

Brief description of the issue:
I am living in California, US. Recently, I move to a new apartment and start using AT&T fiber. However, I encounter a very strange problem. Each time I start the game, even in the menu, the game will totally freeze for a couple of seconds, and then back to live for a couple of seconds, and then freeze again. I tried to reinstall the game, and windows a couple of time, but nothing helps.

Since AT&T fiber has a bad reputation for connection stableness, so I connected to my cellphone hot spot for testing. Magically, everything works fine. Than I suspect this is going to be a network issue.

I use Fiddler to check all my network traffics, and I find that, each time the game is trying to connect to dev.ditu.live.com:443, the game freeze until it returns HTTP 502 (which is an error) the game back to life. until the next time, the game tries to connect to dev.ditu.live.com:443 again.

dev.ditu.live.com is a server in Beijing, China (about map service, I guess), and like I said AT&T Fiber sometimes has problems to establish a stable connection to some servers in China. I know this should be a problem for AT&T. But I am still wondering why my game is trying to connect to a server in China while I am living in the US.

Currently, my Windows 11 location is set to Hong Kong and uses the Chinese language. My Steam region is the US. I tried to change the Windows 11 location to the US to see if the game is trying to connect to another server. But it doesn’t work.

Is there a way to let my game connect to a more local map server?

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:
Simply start the game, and the game will start freezing for a couple of seconds, and again and again and again…

PC specs and/or peripheral set up if relevant:
Not relevant I guess

Build Version # when you first started experiencing this issue:
latest version

check your hosts file
C:\Windows\System32\drivers\etc

1 Like

which address is used if you use the simple windows maps tool ? I assume should be somewhat with “virtualearth”…

PS: sounds not like a MSFS Issue

1 Like

When in the sim, from the General Options, Data menu, ensure “multiplayer” is on.
Next, from your icon (top right), select a new server.
You will probably need to change to English(US) language on your PC, as currently MSFS does not support Chinese.

1 Like

Thanks, I checked it and it is empty. no other item.

Thanks!

The location is in California, US, which is the address I am currently living in.

I agree this is not an MSFS issue because I should blame AT&T Fiber more. But I am wondering why MSFS is trying to connect a server in Beijing, China. I am living in the US. My steam region is in the US. My windows system region is in Hong Kong. The system language is Chinese (Hong Kong). The MSFS multiplayer server I am connecting is US West. So I don’t see an obvious reason for MSFS to connect a server in China. Is it because there is no server in Hong Kong, and the nearest server is in Beijing, China? That is 2000 miles away.

The most interesting thing is, the game is not trying to keep connecting to the server. As long as it connects to the server at the very beginning, then I can use the AT&T network with no further problem. Fortunately, this is a workaround that works for me so far.

I can only guess that it is windows setting ( therefore question about what windows tries ) and MSFS use the System itself or like @TheSevenflyer mentioned it choose it from in-game setting.

Also these URI itself… I’am not sure… it looks like a not official supported bing api… but I’am realy not an expert here and may I’am wrong with that :slight_smile:

1 Like

Thanks, the server I am currently connecting is US West (auto-selected). The MSFS language is English.

Like I said in the above reply, I am living in the US. My steam region is in the US. My windows system region is in Hong Kong. The system language is Chinese (Hong Kong). The MSFS multiplayer server I am connecting is US West. So I don’t see an obvious reason for MSFS to connect a server in China.

This should be an AT&T Fiber issue for sure, just trying to understand the root cause of why MSFS is behaving like this so that I could skip the horrible AT&T customer support, haha. Thousands of people are complaining about the connecting issue with servers in China, but AT&T Fiber says they acknowledge the problem for a while, but they just refuse to solve it. I heard people are trying to sue AT&T right now, hopefully, it could push AT&T to get their job done.

1 Like

I also thought it ties to the windows setting, so I tried to change it from Hong Kong to the US last night (and the in-game setting was US West already (auto-selected)), but it doesn’t help. Maybe the game remembered something before I change the system region.

I think the URL is officially supported Bing API, “ditu” in the URL is actually “map” in Chinese, and the domain name is live.com which is owned by Microsoft as well. One thing I found recently is that Bing map changes their API address to " dev.virtualearth.net" or something. But I could still find “dev.ditu.live.com” in their API documentation. So I think this is just an old API address but I guess it is still officially supported.

Hey, guys! I find a better workaround. When I use the Fiddler to monitor network traffic, I find the response of dev.ditu.live.com:443 contains some alternative server addresses. One of them is named hk2.dev.ditu.live.com which does not reside in China. I thought this server is in Hong Kong because of the name “hk2”, but the IP address seems in Korea.

But anyway, I bind the IP address of hk2.dev.ditu.live.com to dev.ditu.live.com in the host file. So each time the game is trying to dev.ditu.live.com, it is actually connected to the server of hk2.dev.ditu.live.com. Since it is not in China anymore, so no problem so far.

I even wrote a small exe to grab the IP address of the hk2 server, and update the host file automatically in case Bing changes the server address in the future. At last, I add this file in the exe.xml so the IP address in the host will be updated every time I start MSFS.

I thought this solution is better because I don’t have to change my wifi connection every time I want to play the game.

Although the problem is solved temporarily. I am still willing to discuss why MSFS is trying to connect the server in China.

2 Likes

I find another who seems have the same problem, but no one replies to the question (https://answers.microsoft.com/en-us/xbox/forum/all/microsoft-flight-simulator-2020-freeze-every-3/10fca8a6-9212-42e7-bc76-5a98023b3bd5). From the name of the question author, I don’t think he or she is Chinese, so maybe not the same root cause. I don’t know.

but would be still intressting which setting is responsible that it choose in your case servers in China.
And yes, the virtualearth addresses are exactly why I asked.

Have you tried these little Windows own Map tool and checked which address is used ?

Have you also checked to choose a different DNS ( e.g. 1.1.1.1 ) … just in case it is the dns ?

PS: I not think that the linked post is same issue.

1 Like

Hello, I have a similar problem since the last update, the game stutters every 3 seconds, which is completely new and very unpleasant, it makes any flight really awful. My ping and connection are excellent in other online games.

stutters is not same as application freeze :slight_smile:

Yes, I tried the Windows Map, the default address is in the US, which is the apartment I am currently living in. I will try to use a different DNS later tonight. Thanks!

sorry, as @MichaMMA said, stutters is not the same as application freeze. my game totally freezes for a couple of seconds starting from the main menu (technically, starting from the very first loading screen, it is just hard to be noticed). I don’t really need to start a flight. and the game has zero response for a couple of seconds, and back to life for another couple of seconds again and again.

You may want to participate in this thread, it is more on topic.

well, switching server solved the problem, from west europe to south-asia, no more freezes …
switching again to west europe and freezes are back.
regards

1 Like