Stutters Stutters and more stutters

Just dont get it, nothing changed on my side but since last patch I have plenty of sttuters when I am close to the ground, also turning to the side views now is not as smooth as it used to be. The FPS is solid above 37 but still a lot of stutters using the monitor.

Now, I play VR and is horrible now, is not smooth anymore. Anybody else is finding this behaviour with the sim? I have never had these problems before.

11090k
2080TI
nvidia 457.30
128GB Ram
M3 drive

19 Likes

Download Nvidia drivers 472.12. I don’t have any problems. I suggest yours are too old by some way.

Drivers

2 Likes

There is a bug for many users that you get massive stutters on the ground, but when you turn off photogrammetry it is smooth. This happens even on small airports with photogrammetry areas far far away thousands of kilometers even. Definitely a bug. Try to see if you are one of the unlucky ones.

5 Likes

You don’t say what resolution monitor you’re running, but with a system like that you should be able to achieve smooth flight, if you aren’t abusing the terrain LOD system. If you’re running your Terrain Level of Detail setting higher than 100, try setting it to that first. Also check to see if your render scale has been set higher than 100. If so, set it to 100 also. After that here are some other things you can try for removing stutters…

  1. In both 2D and VR graphics settings in the sim, set Off Screen Terrain Pre-caching to “ultra”. SU5 and WU6 changed many things about how scenery is loaded and rendered, and that should help with stutters when panning your view or turning.

  2. For monitor use, since you say you can regularly hit 37 fps (seems low for your machine), try turning on Vsync and limiting fps to 30 in the sim’s graphics settings. If that helps, you can try resetting it to vsync off and then try the next step…

  3. In your Nvidia control panel, in the MSFS program specific settings, set the “max fps” value to 30. That will prevent the sim from rendering more than 30 fps, which can cause synchronization issues with your monitor and show as regular stuttering (if it’s a standard 60 hz screen). If you’re running a higher refresh rate monitor you might need to find an appropriate fps lock setting that is an even factor of its refresh rate. This will also help stutters in VR, if you’re using a headset that renders at 90 hz (Reverb G2, Oculus etc). If this works for you then you can smooth things out even more by enabling ASW (oculus) or Motion Reprojection (WMR/reverb). Some like it, some don’t.

  4. Check your task manager to see if any processes other than MSFS are consuming a lot of cpu time. You might have something running in the background that’s eating frames.

  5. If none of these help, and you’re feeling adventurous, you can download the free version of Process Lasso, and try restricting dwm.exe (desktop window manger) and your VR software to the last 4 cores on your system, preventing them from competing with MSFS for core 0. Those processes can chew a lot of cpu time up and definitely cause stuttering.

  6. Check your internet connection and latency, see if you’re being throttled in some way. MSFS streams a lot of data, and when it gets plugged up stutters get introduced.

  7. Try disabling the rolling cache in the sim, in the data settings. For some reason having it enabled still gives me stutters, even when having it on a ram drive.

Even with every trick in the book, some occasional stuttering is just par for the course with a sim of this size, especially given how tied it is to server output. MSFS occasionally just has “bad days” as well, and no amount of tweaking can cure them, especially on patch days. Thankfully they aren’t all that often.

Hope some or all of that helps! Good luck.

12 Likes

https://forums.flightsimulator.com/t/nasty-fps-drop-and-lagging-on-take-off-and-landing/459520/20

1 Like

Also after SU5 I think just about everybody took advantage of the performance boost to raise their quality settings not realising that some things haven’t been improved (I’m thinking 3rd party stuff here) and will always be impacted. The result is that those extra settings now put even more load on the gpu or cpu when these unoptimised mods are used or encountered.

1 Like

Thanks a lot for your suggestions, I will try them and report back.

To complement,
2D:

  • Resolution: 2560*1080
  • Monitor Refresh Rate: 144hz
  • Ultra
  • LOD and Render Res : 100%

VR:
TAA 100/OXR 80
Med-High Settings
Reverb G2 at 90Hz
Motion Repro Off

Make sure your off screen pre render is set to ultra.

3 Likes

Can you try a ethernet connection if you are not already doing so?

Try this and see what results you get back!..

Don’t rely on your installed anti-virus at the moment. Use the Microsoft scanner!

I am on full ultra with a Ryzen 5600X and B550 MB and GTX1070 with 16GB RAM. Very few stutters for me at the moment.

Turn off system restore and, (assuming you are using a Windows PC) if using an anti-virus, set an exclusion for the MSFS 2020 locations on your PC. Your stuttering could be linked to a third-party add-on. I removed two freeware MSFS 2020 add-on apps that were doing their own thing behind my back connecting to the internet. This I did not like!

Hope you get sorted.

Charles.

ter afterwards.

1 Like

I doubt it’s your setup. On the X it has been a stutter fest since the last update. Places which were silky smooth before now are nearly un-flyable.

3 Likes

I should mention that I had to do a complete re-install of my simulator which just disappeared off my computer into the ether. Other people have reported the same. While I was re-downloading the simulator I went shopping and returned home only to discover that a third-party application for MSFS which I downloaded from flightsim.to, had the CMD prompt open on my desktop and code was being entered into the CMD prompt. I cannot mention the app for obvious reasons. I was not happy and removed the portable app from my computer. It had created a number of folders in several areas of my operating system. I wished I had snapped a screenshot, I managed to close the CMD prompt before any changes were made to files on my computer.

This is why I am advocating using the Microsoft Security Scanner.

Be wary of any app for MSFS 2020 that has an automated process, and connects to the internet without permission. After searching out all the folders created on my PC by this app and removing them, my simulator appeared to run considerably smoother!

In this case the software may have been buggy and vulnerable to an exploit NOT introduced by the author.

Charles.

Why for “obvious reasons” can you not warn us which app it was?

5 Likes

Hi,

I have spoken to Microsoft about this and they say it’s ‘out of their hands’ and warned me about using third-party applications for MSFS that can potentially modify your files on your PC. I don’t want to open a ‘can of worms’ at this time and cannot say much about this at the moment.

BRGDS

Charles.

1 Like

That I understand but if a 3rd party mod is wittingly or unwittingly distributing malware it should be investigated, if not by Zendesk then at least by the community. IMO the dev is probably unknowingly using a compromised installer from an unofficial source and that is something we should all be made aware of.

6 Likes

Ah yup, you have a bit of a conflict between your monitor and VR regarding refresh rates. Running an uncapped framerate (even with vsync off) in either mode is pretty much guaranteed to be a bit of a “stutter fest” and or “tear fest”. Running uncapped is also pretty hard on the video card in the menus, as the sim will easily push 120+ fps there, resulting in unnecessary high gpu temps and fan speeds.

There aren’t really any common framerate divisors between your 90 hz reverb and 144 hz monitor. If you’re running on your monitor you want to cap your fps at the driver level to either 36 or 48 (ie 1/4 or 1/3 of 144 hz), so that there are an even number of monitor refresh cycles per frame. If running on the reverb you want to cap it to 30 or 45 fps (1/3 or 1/2 of 90 hz). Obviously FS is never going to be able to run at native 90 hz (let alone144!) with any complexity, if at all. Maybe see if you can run your monitor at 120 hz refresh? That might simplify things a bit, since both your monitor and reverb could then share a 30 hz/fps update rate nicely. Failing that you might need to make adjustments depending on if you want to fly in 2D or VR before a session.

After locking at 30 fps in VR though, try giving motion reprojection a fair chance, even if you hate it, just to see if it smooths things out? For repro to work properly on the G2 it absolutely needs a stable framerate, 30 or 45 locked, with no dips into lower numbers.

Cheers.

2 Likes

I have the same problem high frames but stutter when panning camera or moving mouse……

1 Like

I will try that and see

1 Like

Delete and turn off rolling cache > apply & save

Decrease off screen terrain pre-caching settings.
Options > general options > graphics

1 Like

Exactly the opposite advice I would give especially the precaching as ultra basically is off and low = maximum culling with minimal (if any) performance gain.

For the rolling cache it depends on your storage, a small rolling cache on NVme or a ram drive eliminates any noticeable popping in.

2 Likes

I saw that happen with another game when I was using Kaspersky (years ago). If you have a 3rd party anti virus software I‘d check that first. It looks suspisciously like that.

1 Like