The whole fleet is grounded in the hangar - structual cracks detected

I have camera creep also since update 5 … basically the minute a Microsoft Xbox controller is switched on in the cockpit view creep in circles starts …moving the hat switch on the joystick allows to look around but letting go again the view creeps… This simulator is a Microsoft product…and now has been customised to Xbox …how could someone at Asobo get it so wrong that when you enable and Xbox controller on PC it is not working perfectly??? Especially that it was perfect for almost 1 year…

I’m not sure why the game looks better on my series x over my computer :unamused:. I uninstalled on my pc and reinstalling right now doubt it’ll make a difference but I figured I’d try something. The buildings and clouds on my series x look like they did pre su5 and on my pc they look horrendous since su5

The program itself is transformed for the new xbox and maybe the controller of old xbox like live or 360 might not be completly compatibel also i asume we are playing it on pc, xbox controllers are not designed for this matter, and there for are not visible to game controller calibration screen in Windows. Maybe some other calibration tool can. Yes the other tool is DiView which i downloaded from the site of Leo Bodnar.
Now, If someone who plays the sim on new xbox, can u try old controllers if you have any, and see if the problem exists there to. Please do respond in this topic if you know.

Sorry for being pedantic but I hate the expression ‘glass half full or half empty’. Half is an absolute, therefore it can not be half full or half empty, it’s just ‘half’


This sound like you had navigraph installed. It needs to uninstalled correctly otherwise you have wiped ALL your navdata, even the stock. By renaming the community folder you have just done that. User error it seems.

1 Like

Sorry, but xbox controllers (and especially newer ones) are 100% compatible with windows and are accessible through the windows game calibration screen:


1 Like

I always have an old Xbox controller connected for the camera to make screenshots. And i also use it when my yoke/joystick/pedals are stowed if i just want fly around non seriously to ha a look at something or test something. It works 100% flawlessly without any software. Plug n play, pre configured.

1 Like

Thanks for your reply, my wrong i didn’t saw it in mine, must have been disconnected then.
But the problem seems best handled in sim settings with deadzone expansion if i mentioned well.

I know, but I was always a nasty Alt+F4 quitter since my childhood. :crazy_face:

The dreamer glass.

Being honest, we are almost a year after release, and no basic issues has been fixed yet. They have only released updates to add things and break other ones. While the fundamental ones are still WIP (which lead me to think why they release such an early product, and I know why, because it was the perfect beta for Xbox product).

In the meantime, a lot of people got tired of this and came back to other sims. And others keep telling the few folks who are here and are tired of broken things in a, supposedly, polished sim, that things will be good someday (I’ve read that here since August 2020, I didn’t believe at that moment, neither do now).

But in the end I don’t blame Asobo or MS. I blame those blind followers (aka fanboys) that aren’t able to be neutral, and all of those who decided to buy a 70/120€ product without even trying on game pass first. Once you give money to a big company, they don’t need anything else from you.


Did not say that.

They should have known the consequences of their actions and prepared a statement and response before they unleashed this hot mess.

I’m the first to put my hand up to user error however, the official line was to offer advise on the need to rename the old community folder or at least remove all mods, which I did. Normally I don’t so the lesson is there I guess. Trying to unpick what you’re suggesting and I do apprecaite your input but what do you think that I need to do to resolve the constant camera creep?

The glass is simply broken! Thats it!

1 Like

I think check that your xbox controller has deadzones (10% maybe) set for the various axes and also reset the mouse profile to default. That’s what I;ve seen elsewhere on the forums

Thanks for your input and suggestions. I don’t use a game controller just mouse, HOTAS and throttle plus rudder peddles. I have created several profiles trying to correct and set the normal freeview modes on both mouse and joystick but with no change; camera view creeps ever downwards and no amount of correction input from my devices will correct the view. The input will restore the set view briefly before jumping back to the downwards creeping before coming to a halt.

Its very curious and must be massively frustrating for you. The input must be coming from somewhere. I mean - I don’t understand why my controller is causing drift when I’ve unbound all of the cockpit inputs from it. And it doesn’t even drift now, just locks hard 90degree left in the cockpit. It must just be one of the many many bugs SU5 introduced in the effort to make the sim xbox compatible. I’m sorry, don’t know what else to suggest other than keep and eye on the forums - some of the tech savvy folk are already finding fixes to the blurry landscape/capped LOD issue and maybe there will be a fix for this. I’m going to log it on Zen desk just to make sure its on the Asobo radar. Hope you get flying again soon.

It sounds like in your psyche you have it all figured out. When you blame others for your own misfortune and despair you have completely lost relevance. Instead, I see someone who is a chronic and persistent blamer, that even has an epithet (aka fanboy) for those he anguishes. It’s amazing how a few setbacks reveal a person’s true colors. It makes me cringe with the amount of negative and depressing energy you waste that could be put to good and constructive use on these forums.

What a complete bag of nails this flightsim has become. Nothing works as expected/should and everytime I run the program over the last few weeks I have failed to get anywhere near completing a flight. So many random issues, so many bugs are making this unplayable, a depressing experince and a huge time waster just trying to get the program to run any like normal. A crying shame!

I posted this comment as a new topic that was closed by a moderator. Fair does as that is the roll and function of a moderator. The reason that it was closed was because it wasn’t considered to be condusive to attract constructive comments and that I hadn’t listed specific issues so here goes; after several long weeks of attempting to use this sim I am still unable to start more than one engine in some of the larger jets, I am unable to save airports that I have just used as departures in the history, I am unable to activeate the autopilot with any degree of reliablity, I still get incorrect flight level reports from ATC when flying IFR flight plans, I still get unexplained CTD, I still get emersion breaking freezes, I still get graphic tearing when set to high-end (this is well within the capabilites of my machine), the graphic display has clearly downgraded over time, I get a strange ghosting of the undercarriage when taxiing, I get aircraft diving uncontrolably to the ground when I change the graphic settings. Other than that, everything is just fine. Come on guys, sort this mess out for the love of Pete and my sanity!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.