Throttle/Mixture Issues with Honeycomb Bravo and C172

I have the Honeycomb Alpha/Bravo and I am a pilot. For whatever reason, it took a number of days for me to get MSFS to bind the throttle to “throttle 2”, and the mixture to “prop 1” for the C172. I had to create a new profile and unbind everything, but as soon as I thought I had the throttle working and went to bind the mixture, the throttle would stop working!

I was only able to get it “to work”, when I declined to save the settings, and imagine my surprise when I went back in to try again, the settings were saved! Not only that, but now it was working!?!?

I’ve seen, from various sources, which joystick/axis to bind these controls to, but all have been slightly different.

When I “thought” I had it figured out, I proceeded to fly from my local airport to another. As soon as I clicked the “Fly” button, the plane engine shut down and I cannot get it to restart. The few times I was able to get it started, it wouldn’t advance past 6xx RPMS, with neither the throttle nor mixture levers affecting anything (although full mixture was also killing the engine).

I then said “EFF IT” and went into the cockpit visually and looked at the controls and discovered that neither were moving when I moved them on the Bravo!

So now with the engine running but with no real throttle/mixture control, I decided to “fly”. Nope, now the parking brakes wouldn’t disengage! I went back to the settings to bind them to an unused switch on the Bravo, only to be told that it was already bound to “Avionics 1”. What’s more is that MSFS would lock-up immediately afterwards, forcing me to shut it down with Task Manager!

I’ve wasted 4 days and valuable training time on this ■■■■!

To summarize, I have no throttle/mixture control and cannot assign a binding for the parking brakes. Oh, and the keyboard is frequently lost because I cannot seem to use the keyboard commands.

I have reset everything to default, reset the app, and finally uninstalled it before reinstalling it. HOWEVER, I don’t believe it’s clearing everything because I had the music set to number 2 and that is what was playing after the reinstall.

I also have XP12 and have ZERO issues, other than its founder being an a-hat.

Windows 10 Pro with all updates.
MSFS Deluxe with all updates.
The PC is a dedicated flight sim PC with no extraneous software:
3060 12GB
16 or 32 GB DDR5
1TB 990 Pro

1 Like

I would start by deleting your cloud saves which are probably affecting a lot of this.

Can you post a screenshot of your assigned bindings on the Bravo?

Also: Are you aware how profiles work per peripheral?

Thank you for that; I will try that out, but it’ll be a few days before I can. I figured it was saving things somewhere nonlocal.

Is it just me, or has MS made things more difficult not making this a straight download?

I will post a couple of screenshots, but it’ll be a few days.

As far as the profiles are concerned, I did learn when I tried to “reverse axis” on the standard throttle-2 profile and MSFS prompted me to save it as a new profile. I saved a new profile as “ASEL: Fixed Prop”, to better represent what category/class the profile was for.

The idea is that you can install the sim on as many devices as you want (but you can only be logged in on one device at a time), unlike older sims which only allow for one installation.
The cloud save enables your settings to be applied to all of the devices you may have installed the sim on, no matter which one you log into.

Which why the transition to my new PC was completely painless. Plugged in peripherals and all was working as before.

1 Like

Hey, apologies for the late reply, but I was able to delete the cluod saves as suggested. While it did seem to reset everything to default, it still did not help.

As soon as everything was done downloading, I went into the Bravo controls and copied the default profile straight-away, naming it “ASEL”. I then confirmed that the axis on which I have my throttle and mixture attached, were working, albeit in the wrong direction.

To recap, Throttle 2 is the axis for the throttle, and Propellor 1 is the axis for the mixture.

As soon as I made ONE change, the input bar (showing the amount of input being used), on EVERYTHING stopped working! Just like before.

I continued to delete/clear all throttle/mixture/propellor inputs and reassigned the mixture,

Again, once in game, the throttle won’t work and the mixture works backwards but not even correct (it acts more like a throttle). I tried Free Flight and pointed my mouse towards the top of the screen to select the controls profile and I cannot even change which profile I want to use!

If this wasn’t enough, none of the light switches on the Alpha, except for the beacon light, even work!

I know my hardware is good since I use XP12 all the time.

I cannot believe I am having these issues!

Are you using this with just a single prop plane?

I am, BUT I also wanted to see if ANY TPM axis was working in game and none were, other than the one mixture axis.

OK, have you tried Throttle 1 rather than Throttle 2

1 Like

None of the controls are operational, other than throttle 2, which I assigned to mixture, acts more like a throttle except it also acts like the mixture because it shuts off the engine.

I am going to uninstall and delete cloud saves…again…and try again.

  1. delete everything and start with a clean profile for your bravo in msfs
  2. assign only the specific axes and buttons you wish to use
  3. if you do find that only one lever produces output, you should contact Honeycomb support and return the unit for replacement (this should not be an issue if your unit works in X-Plane as you say)

Also note that many of the axis inputs in MSFS have variants covering both 0-100% and -100-100% axes. If one doesn’t work as you expect, try the other. (I don’t remember offhand whether the 0-100% or -100-100% variants are correct for the Bravo, as I run my Bravo through and it communicates its axis data via SimConnect internally.)

For the C172 you want to assign your levers to the MSFS Throttle 1 and Mixture 1 axes. The MSFS Throttle 2 axis should have no affect whatsoever on the C172.

You should be able to use any of the 6 levers for either axis. Try them all and make sure they work as expected!

1 Like

As mentioned, I am in the process of deleting/cleaning-up everything (local and in the cloud).

When I am in the Controls option window, and before changing anything, I see that everything works (i.e., the TPMs work, the light switches work, etc.).

Next, I have been making a copy of the Bravo default profile, naming it “ASEL”, since I am setting it up for a C172.

My physical throttle lever is on the throttle 2 position on the Bravo.
The physical mixture lever is on the prop 1 position on the Bravo.
I make sure I am switched to “ASEL” and double check that all controls work…they do.

Now when I move the throttle lever, it shows up on throttle 2, which is correct, but the axis needs to be reversed to be correct, so that’s what I do. However, when I do that, I notice that NOTHING works anymore! All I see is that, as I move the throttle or mixture, the axis button will flash.

Regardless, I hit “apple and save”, exit out the control’s menu, and then go back in, where I find that the controls are working!!

I clear-out all settings for mixture and the prop. I will then click on mixture 1 (-100 +100), and change the input by physically moving the lever, and then validate.

After I am done, I hit “apply and save” and exit. I will go back in a few times to ensure things are working.

I get in game, and they do not.

I cannot even change the Bravo profile being used in the game (it wants to always say default).

And even though I have confirmed that the light switches on the Alpha work while I am in the control’s menu, they don’t in game.

I mean, seriously, what the heck?

As mentioned, XP12 doesn’t have any of these issues, which is why I don’t believe it’s hardware.

Nothing should go to throttle 2; you should bind the physical axis (whichever it is) to throttle 1.

Oh goodness…did the lightbulb just come on?

I think that explains things a bit.

I’ll have to wait for everything to redownload first.

Still won’t explain why I can’t change profiles (from Bravo Default to the ASEL I setup), or why nothing works in game anyhow. I mean, Bravo Default should still work, even if I misassigned the controls in my ASEL profile, but they aren’t.

Ok, so after downloading the sim, I didn’t install anything else. I went to controls and verified that each physical axis moved as expected.

I created a NEW profile (not just copy the default profile) and assigned the throttle and mixture to the correct physical positions. I used reverse axis so that, as I increased either (i.e., pushed them forward), the white bar would increase.

I went to do a discovery flight in NYC. Well, while the throttle and mixture levers were now responsive, they were BACKWARDS! I went back to the controls and unchecked reverse axis and I went back and started a new discovery flight.

Now they work as intended, which is nice.

So I went to world airports or whatever that option is, and setup for a departure from somewhere in Spain (just randomly chosen). The throttle/mixture were working, the light switches on the Alpha were working, so I disengaged the parking brake with the mouse and applied full throttle and…

…nothing. The engine revved up sure, but the plane won’t budge. I went through all of the checklists and made sure everything was checked. Still nothing. So I told MSFS to put me up at altitude. Well, now I was a few thousand feet in the air, but the ■■■■ plane just hung there…no movement at all.

Seriously, F MSFS.

That’s not how you select the controls. Instead pres ESC then select controls and select the control of interest.

Best wishes on getting this fixed.

I too am frustrated with the Bravo mixture control. I had to go into the game settings and make it “automatic” in order to fly. It would work one game, and then it would not change the throttle at all next time. I would push the throttle in with my mouse since the Bravo didnt do anything, and the mouse would push it in, and it would turn blue and pop right back out. Dont know how to fix.

Glad the controls are getting closer to working at least! :slight_smile:

Two things I’d recommend checking here:

  • you may have accidentally engaged “active pause” – everything looks like it’s still working and the engine will rev up if you hit the throttle but indeed nothing will move! i suspect this is what happened to you here. the ‘pause’ button on the toolbar will toggle this
  • sometimes i actually just get the parking brake state backwards. swear to god this still happens to me, it’s worth double-checking. :wink: