Thrustmaster Boeing Throttle Quadrant Calibration

I recently bought the TM Boeing yoke/throttle combo. Impressed with the yoke, the quadrant has been a real pain though. I downloaded the drivers, plugged it in and the rotary switch seemed faulty - it was sending continuous signals for several buttons. I rolled back drivers, tried reboots, different ports, even pulled the cover off and fiddled with the rotary selector. Also tried installing Target from TM. Tried 2 different PC’s, windows 10 and 11. Emailed TM but haven’t got a response. Somewhere, somehow, suddenly it started working. But the central button doesn’t work and the calibration was way off. There’s nothing written in the manual or on the TM website. Eventually found a review on Amazon that suggested:

  • unplug the throttle quadrant
  • close all the levers
  • hold the top left button while plugging the USB cable in
  • raise all three levers to max
  • press and hold the top left and the top right buttons at the same time. It worked!

Why TM don’t make this very clear is beyond me. Just thought I’d post in case it helps someone. Cheers!


Thanks for this, just as a correction, its top right button not bottom right :slight_smile:, so hold top left and top right at same time to exit calibration.

But you are correct, why this is not in the support docs or the manual is beyond me.

Thanks for that - you are absolutely right. I’ve updated my post just in case someone skims by and doesn’t read on. Cheers!

hello, where did you do this? in game or in de calibration app?
because i have a probleme that the throttle quadrant dont have the funtions that it should have

and i use FSX

Pressing a button while plugging in the USB cable sounds like calibration utility programmed into device itself, so it should work provided you have powered on PC in which to plug it.

Help! I’ve tried the recalibration steps in the OP post and axis y and z (2nd and 3rd levers) are still not aligned. I can’t be believe TM has nothing in the user manual about how to calibrate.

It is a non-starter because e.g. the alignment is so bad that if the levers are in the same position then the difference in engine spool is 5% causing all sorts of mayhem with the auto-throttle. This is picture of them at the same position as seen in MSFS.

Anyone know what to do?

And here is the same situation

the TM control panel (firmware is up to date)

Another user posted on similar issue recently (TCA Quadrant still not callibrating fully) with the problem apparently being a broken button on the throttle that prevented correct calibration procedure.

Edit: Er, never mind, different TM throttle. That being said, are your top three buttons working correctly? If they aren’t then the calibration operation would probably not work correctly. You could also try if the Windows calibration utility helps (search for USB game controller, click properties, click settings, click calibrate).

Thanks for your post. I confirm that calibration definitely operates as posted by the OP, it just isn’t calibrating correctly. I justed tested that it operates by following the steps but putting the levers in extremely random positions - this caused the throttle store these extreme positions. So it definitely functions, just not properly when I try to calibrate with the levers all at the exact same position.

So, my workaround for now? I ran the calibration with the middle lever slightly higher (0.5cm) than the right lever. The result after calibration is that they’re now more or less aligned. Oh my.

1 Like

Also try calibrating it in Windows.
Just type joy.cpl into the search box and find the settings tab for the controller you need, run through the calibration routine there.

I am having the same issue as you and when flying the king air today, i realised my left and right throttles are about 2% difference. Going to try and calibrate this. Thanks all!

Please let me know how you get on? I’d already run calibration in joy.cpl when I posted above, so it didn’t solve the offset for me.

My work around was to run the calibration and physically offset the levers slightly, so that when the calibration tool ran it compensated for this. Not a perfect solution at all!

it works perfectly now! the steps i did was:

open the Thrustmaster Flight Control Panel Properties of my quadrant.
Put all 3 throttles to 0%
Hold top left button and connect USB to PC.
Wait for 5 seconds after the USB connection sound and release the top left button.
push all 3 throttles to 100%
press top left and top right button to complete calibration.
reload the Thrustmaster Flight Control Panels to check.

if it does not work, try again. It took me like 15 times to make it work as I tried doing at 5% throttle for left to compensate for the difference in the throttle position which was not necessary.

1 Like

Ok Funziona. Working. Can you confirm that the latest firmware is 1.28?
Thank you

Does this trick works with the Xbox ?

Thank you Enfield55. Throttle stagger on a brand new purchase for £137 was frustrating until I found your post. Amazing. This fixed it for me.