Thrustmaster Boeing Yoke Control Anomaly

Hi,

Strange thing happened today while using my yoke. All of a sudden, when I turn the yoke full left or full right, when I reach about 65-75 degrees, aside from the ailerons moving in the correct direction, my eve viewpoint goes straight to the overhead panel and locks in that position! Some of the time, I’m able to hit the “reset eye view forward” to go back to the forward view, but other times I have to unplug the yoke (turning the yoke back does nothing to fix the eye view position). I have been using this yoke since it first came out and never had this happen. Also, I checked the assignments page to see if something else assigned itself to this function, but nothing. I also tried deleting the assignment and re-assigning it, but no luck either. It’s just happening with my TCA Boeing yoke. Anyone else experienced this or have any unput? Any help would be appreciated. Thanks very much.

Mario

There’s probably something in your control profile that triggers the camera view when the full yoke deflection happens. I don’t have the yoke myself, but sometimes thrustmaster has set a virtual button on some of it’s axis. Like “X-Axis+” and “X-Axis-” which usually engages when you move that axis to it’s full maximum position. If these digital virtual buttons are bound to a camera function, it could trigger the movement that you described.

You also need to note that you might need to look at the assignment on all your other hardware, if there’s a conflicting input, that could have caused it as well. And try to delete the control profile again, and with a blank profile, test the movement, if the problem stopped, then you can slowly re-assign the profile one thing at a time and keep testing as you go along.

1 Like

Another thought; go into windows and check the function of the controller there. This would tell you if there’s something wrong with the controlller axis.

Hi NeoKingRthur,

Thanks for the suggestions. What’s weird though, is the fact that I have not messed with any profiles, assignments, or functions in months, and all of a sudden, this happens out of nowhere.

I will try your suggestion of making a new basic profile to just test the aileron and elevator axis to see if it still does it, and I will report back. Thanks again for your input.

Mario

Hi NonstopQyster0,

I will test in windows and report back to once done. I will also try what NeoKingRthur suggested.
Thanks for your input.

Mario

What aircraft? I have that yoke and usually use the PMDG B737-700 with it. I am about to do a flight and I can test the yoke to see if I can reproduce what you see.

Hi NeokingRthur, NonstopOyster0, and bam12208834,

It seems that Neo’s suggestion to create a new Profile from scratch worked! It appears that in this new profile, the ailerons now work w/o also triggering the “lookup Cockpit View” I have no idea why it started doing this in the first place.
Note; I did try first to duplicate a profile so that I wouldn’t have to re-assign all the buttons again, but that didn’t work. I had to do it the long way and re-assign all the buttons on a fresh profile.
Bam12208834, I was initially using the b-747-8, but it was doing this on all aircraft.
Thank you all for your help & input. Regards

Mario