Thrustmaster TCA Boeing Yoke & Quadrant Invisible Mappings & duplicated buttons numbers

#pc MS Store Version

Yoke & single quadrant (1&2) I’ve now given up trying to understand this.

First example issue: I wanted to change some of the default mappings. For example, button 11 on the quadrant I mapped to “Toggle autopilot approach hold”. It recognises the input and maps it and I save to a custom profile. (I’m not sure the difference between the L&R boxes, I have tried both but it’s the same). However, there is a button 11 on the yoke, which when I “search by input” also brings up the same mapping I created for the quadrant. I don’t understand why, having created a virtual device for the combined Yoke & Quadrant, it (sometimes, see below!) then leaves duplicate button numbers between them, causing this confusion. Whatever I map button 11 on the yoke for will then overwrite that which I set for the quadrant on button 11.

Second issue is a complete inconsistency with the above. I have button 2 on the throttle quadrant set to “Autothrottle to GA”, but the corresponding button 2 on the Yoke, when “search by input” returns nothing mapped, but in game actually works as Toggle Autopilot Master! You can see there is nothing mapped for Toggle Autopilot Master, so it is as if it inherits the default from the default profile but doesn’t display the mapping

Any help much appreciated. Had big hopes for this TCA setup!

I’ve got this setup and I’m not quite understanding your issue.

The yoke will have a button 1 and the throttle will have a button 1, but they are not the same control. If you assign autopilot to button 1 on the yoke, it isn’t also going to be assigned to button 1 on the throttle, unless you also assign it there, too.

The left and right box for each control, just allows you to set up two separate control assignments for the same function on that specific device.

I also want to point you to this, I’m hoping it will help you:

1 Like

I am a fool - it has just clicked that the virtual device 1&2 is JUST the quadrant(s) and not the whole setup. The yoke has its own separate device. Can’t believe I missed this! Thank you for the fast response.

By the way as you gave the sane setup, do you know if it is possible to make the rotator knob context specific eg to use it to control VS rate when you’ve got VS ap/fd node selected?

The VS issue seems to be a problem (along with the knob “push” function of each knob in the actual aircraft — IAS, HDG, Altitude). It looks like Asobo didn’t give us a mappable control for those functions. I’d really like to be able to use the push function on the SEL knob as it is used in the aircraft. Grrr…

If they did(do) give us those controls, the only way I could see it working is via a second quadrant for engines 3&4. You could use the AP knob/selector there to map the VS, etc.

EDIT: I stand corrected on the VS. They have provided control maps for them:
• Set AP Current VS
• Increase Autopilot Reference VS
• Decrease Autopilot Reference VS

My second statement still stands, though. You’d need to have a second quadrant and map its autopilot controls to the VS function. That or give up IAS or HDG on the first quadrant and remap one of those.


I just tried using the throttle sliders on the yoke for the Inc/Dec reference VS, but they are waaaay too coarse - move it a milimeter and I was getting 9000fpm!!

The APFD MCP buttons & knob were the main selling points for me on this, but seems they’re a bit of a half way right now, never mind. BTW I can’t get push to set std working on my baro on any aircraft just from interacting with the knob in cockpit itself.

Hello Everyone,

Why doesn’t the picture reflect the actual image for the peripherals YOKE and Quadrant?