Thrustmaster TCA Quadrant not working - Firmware “0”

My TCA Quadrant Airbus Edition is no longer working at all.

Everything was working fine for the first few weeks. I had it set up for both MSFS and FSX. But it wasn’t recognized sometimes when I was using FSX so I just set it aside for a while, figuring that was an FSX problem.

It shows up in Device Manager as TCA Q-Eng 1&2. In Properties none of the axes or buttons register movement and the Firmware shows as version “0” when it should be 1.61.

I tried reinstalling drivers a few times. It fails with error code 0x0000104B.

Seems like the firmware got corrupted somehow. But I don’t know how to fix it. Any ideas?

Ohh boy… I don’t think anyone of us can help you with a bricked hardware.
You might want to contact thrustmaster support directly.

Thanks for that. I have contacted Thrustmaster. Just working with them now. Thought someone might have experienced this or might experience it in the future.

If it’s faulty I’ll get a replacement. No biggie.

Well they’ve asked for some info to give me an RMA.

It’s interesting because there is a firmware recovery procedure published for some Thrustmaster products, but I guess not for the TCA Quadrant.

Have you tried the Thrustmaster Firmware Updater?

https://support.thrustmaster.com/de/product/tca-officer-pack-airbus-edition-de/

image

After the software installation:
Firmware Update Procedure - for TCA Quadrant Airbus Edition

  • In «start menu» => «Thrustmaster» => «FW Updater»
    image
  • Check that your device is detected then press “OK”
    image

Actually V1.61 for me

1 Like

Yep tried that. Instead of three green check marks, it fails on step two with a red X and the error code 0x0000104B.

But thanks for the suggestion!

Thrustmaster is sending a replacement.

They had me take a video of trying the firmware update one more time. They were careful to check that I had:

  1. Restarted the PC after installing the drivers.
  2. Plugged the Quadrant into a USB 2.0 (not 3.0) port.

USB 2 OR 3 doesn’t matter.
USB 3 is more recommended as it supplies upto 500mA of power… why the hell have a device with a USB-C connector on a USB.2 legacy port… fml!

1 Like

I may be “a bit” late, but for the records if anyone has problems with corrupted firmware:

I bought a defect Throttle Quadrant on purpose on ebay for a few bucks to give a repair a try. The device was not detected at all on USB.

Solution:
before plugging in, push both buttons in front of the engine switches, hold them, and connect the device. As a result, you should hear the normal USB connection beep from windows. The device shows up in device manager and also is recognized in the Thrustmaster firmware update utility marked in [BOOT] Mode. Now flash the firmware - and have fun :wink:

Probably this also works with the sidesticks, but I didn’t try to find out the needed buttons yet.

Best regards
Marcus

3 Likes

I’m now getting firmware 0, with only engine 1 throttle nor working:/ did you resolve?

Thrustmaster replaced it under warranty. I never got the original one working.

Hey, Did you resolve this?, I got it too

Thank you sir. It did it for me, holding both crank and ignition buttons, while plugging in the usb.