Thrustmaster TCA Spoilers not working (tried the other solutions)

Hi all,

Again, now me, with this annoying TCA controller. I have tried the solution that Neo posted about everywhere on the board at least 10 times. Yes, all 5 positions, pushing the red buttons five times, holding the black button to get it into config mode and holding both to get the controller out of config mode. Everything works fine, every button, every lever. Everything except Spoilers.

It’s assigned correctly to the R-Z Axis as it is in the default settings (I checked and re-checked, axis inverted as well). Inside the binding menu, the spoiler lever works. Inside the A320 it’s not working. I have rebooted the computer, restarted the sim at least ten times. Not working. I got firmware 1.61 installed, T.A.R.G.E.T. says everything is working. Inside the system control everything is working (although I noticed the spoiler lever is associated with buttons 27 - 31 inside the system control). Oh and community is of course empty.

I’m actually pretty desperate at this point…maybe someone has another idea to help me out.

Thanks, Z

You need to make sure that the virtual buttons that are engaged by the spoiler lever detents are not affecting the spoilers deployment.

To be honest. I had to remove the spoilers axis from the spoiler lever because it interferes with the Auto-Spoilers arming. I put everything to digital inputs myself.

At the up position, it activates the Retract Spoilers command.
At the first detent, it activates the Set Spoilers Arming
At the second detent in the middle, it also activates the Spoilers Retract Command.
At the third detent, it triggers the RZ Axis- to Extend Spoilers command.
At the final detent, the virtual button is also bound to the Extend Spoilers command.

I do it this way, because while having the Axis seems like a great idea to control the amount of spoilers you want to deploy. The fact is, the position of your spoilers lever in axis mode will override any other spoilers input that you have. For example, if you arm the spoilers. That’s all good. But since your spoiler position is in the retract position, it will not deploy at all because the retract position overrides the auto-spoilers.

By removing the axis altogether, the position of the spoiler axis will no longer override whatever spoilers input that you have. So pulling the lever to the first detent, will arm the spoiler and there’s no axis positions to override it. The spoilers always deploy on landing. When you want to disarm the spoiler, just push it up to the retract position, and the sim will retract the spoilers and disarm it. Same goes for the other way around, if you want to manually deploy the spoilers, just keep pulling it, and it will disarm the spoilers back to the retract position, and if you keep pulling it, it will deploy full spoilers.

The only drawback here is that you can’t apply half spoilers or any level of spoiler that you want. But frankly, I never needed do that for my flights anyway. But even if you do need it, manually moving the lever in the cockpit with your mouse should still work, because again you don’t have any spoilers axis assign to override it.

1 Like

Thanks man! This is a pretty good work around I haven’t thought of yet - helps for the moment!

can u take a screenshot of your settings from the menu?

mhm doesn´t work for me, but thanks!

What do you mean it doesn’t work?

Top position is retract, if you want to arm the auto-spoilers you pull the lever into the first detent. When you’re done after landing, you push it up if you want to retract.

If you want to manually deploy the spoilers, to pull the lever all the way down. When you’re done, you push it up to the retract position again.

your settings doesn´t work for me. maybe its due to that I have the Ground spoiler mod from shapeways / hotbso.

Ahh that’s why… And that’s also because using that mod, requires FSUIPC as well.

My setting works on a default non-modded TCA quadrant without FSUIPC. So only using stock hardware, with stock MSFS.

But why do you ask about my setting. If you have the mod installed and you follow their guide on using FSUIPC, shouldn’t your settings be working already?

If you want to follow my setting, then you’ll have to remove the mod and not use FSUIPC. It’s your choice, really.

i dont have FSUIPC, I thouhgt there is maybe another way…

Hang on… so you’re telling me that you’re using the Ground Spoiler mod from shapeways, but you never read the instructions on how to use it to get it working??

calm down dude, which instructions?? There is only instruction for the FSL A320 with FSUIPC. Once again: I thought there is another way to configure it without FSUIPC.
And finally I found way.

The instruction is given in the Shapeways website on the product page, the one I refer to in my previous post. One would assume that you read everything before buying,

If you don’t want to use FSUIPC, you wouldn’t have bought the product since it literally says “Note: Requires the full version of FSUIPC to work” in bold letters and have a link that points you to the configuration guide.

But that being said, my binding configuration doesn’t require the mod, nor it requires FSUIPC too, and it works practically the same way without spending anything.

■■■■■, I bought this detent mod actually for my a320 from flightsim labs and for the prepare3d and its working for me without FSUIPC. On the shapeways page nothing is written regarding the ms fs 2020. but i have it installed because i am using both sims. but anyway its solved…

Would you have the full config.cfg…file in plain text for the TCA throttle plus Spoiler/gear - Flaps/park brk add-on ?
My throttle work fine, flaps parking brake work fine. Nothing work on the left side i.e. spoiler / gear and braking switch.
P.s. I am using the flybywire mod. Could this have an impact ?

Currently the autobrake switch doesn’t work on the FlyByWire mod, it works on the default A320. So for the FBW mod, just use the mouse button.

As for the spoilers, Just look at that binding in my screenshot.
Basically for each detent, this is what’s going to happen:
Up Position = Retract Spoilers (Joystick Button 27)
1st Detent = Set Auto Spoilers Arming (Joystick Button 28)
2nd Detent = Retract Spoilers (Joystick Button 29)
3rd Detent = Extend Spoilers (As Joystick R-Azix Z+)
Full Position = Extend Spoilers (Joystick Button 31)

Don’t bind the Spoilers Axis to the spoiler lever. Doing so will make your autospoilers not working because the axis will override the spoiler position.

I don’t think I have full config cfg since the keybindings are synced to your Microsoft/XBox account.

Will tried that,
Thank you.

Just the gear that appear to have a double mapping, does not come down while flight. Rest ok.

Now. Before I put your mapping into effect. I notice my quadrant connector under the throttle package was not fully connected…that would help…

So the mapping suggested will provide to arm the spoiler at pre landing. Or pre take off in case of rejected take of . The other option is on this mapping is full spoiler deploy, non 1/2 déployer. I am correct ?

It will apply to both before take off and landing. You arm the spoilers the same way for both scenarios. And yes, the only problem with this mapping is that you can’t apply 1/2 deploy. Only either full retract or full deploy. It’s an acceptable tradeoff I believe.

The gear up and down is meant to be double bound to the same button. That’s just how it is in the default binding. But you can’t just double bind them the same way. It has to use the default TCA Quadrant profile. And you change everything else to match except for the landing gear. As long as you leave it alone to the default double binding. The landing gear should work fine.

That’s a great work-around, thank you so much!