Thrustmaster TCA throttle issues


I have been having some issues with the thrustmaster tca throttle quadrant, when I have both levers at the same power or position the number 2 engine lever seems to be higher or moving faster than the number 1 engine lever. I have tried to reinstall drivers for the thrustmaster and recalibrating but had no luck.

Any suggestions?

You need to do the hardware recalibration again. Note that the official guide to the calibration process has a missing step. You have to press the red buttons 5x instead of 4x that’s written in the guide. So, make sure you’re locking both levers together using the bar, (the one in brackets are for if you have the TCA Addon) then:

  1. Move throttles to TOGA, (Spoilers Up, Flaps Up) Press 2 red buttons.
  2. Move throttles to FLEX, (Spoilers 1, Flaps 1) Press 2 red buttons.
  3. Move throttles to CLB, (Spoilers 2, Flaps 2) Press 2 red buttons.
  4. Move throttles to IDLE, (Spoilers 3, Flaps 3) Press 2 red buttons.
  5. Move throttles to FULL REVERSE, (Spoilers Full, Flaps Full) Press 2 red buttons.

Then continue with the rest of the calibration process. The official guide is missing either step 4 or 5. Which screws up the calibration. Also, make sure you’re on the latest firmware 1.61 before doing the calibration.

where can I get the firmware update? When I get the installer from the thrustmaster website it stays a 1.53, and the check for updates isn’t working in the windows game controller, I get an error message saying it cant access the update file.


I figured out the firmware and now they are moving together again

Thanks for your help

anybody having issues w the thrustmaster and the new Aerosoft CRJ? does not seem to work for me.

Same, can’t seem to find a way to calibrate it.

Yeah I get no input data, I cleared all possible throttle assignments other than the throttle and nothing

I have even tried unplugging every device other than the tca

I have realized it is working but it seems to be desynced from the VC.

See if this helps, I am gonna try it out now.

Edit: I can confirm the throttle now works.

That seemed to have fixed the issue. You just have to search for L-axis x for engine 1 and L-axis y for engine 2

I still have some issues with my TCA addon pack though, still tinkering around.

I don’t know about the add-on as I don’t have it

would that impact anything when returning to fly in the A320?

I’m not sure but here is a link to a forum that setup the throttle perfectly for my A320. Just make sure to download the custom A320 as said in the post.

What’s your issue with the addon. I might be able to help. I’m also going to create a topic about how to properly setup the complete thrustmaster TCA set fairly soon. As I just got my addon delivered today and I need some time to tinker with it.

I am incapable of figuring out how to use to flaps lever correctly, and for whatever reason I have noticed that the parking brake on the addon doesn’t move the parking brake on the VC.

But I would appreciate any suggestion. Thanks.

You need to Delete all your TCA Quadrant control profile to bring it back to the default binding.
It should have the default binding to have the flaps and Spoilers, and the parking brake as well.

I just received mine today, so after reflashing the Firmware to 1.61, and do a full Recalibration of both the throttle and the addons at the same time. I have everything working. From Flaps, Spoilers, I also set the Auto-Spoiler Armed on the first spoiler detent position which works after tweaking the sensitivity curve. Even landing gear works well.

The Autobrake works too, but only in default vanilla A320. It doesn’t work in A32NX mod, since I think there’s a binding issue from the sim controls with the aircraft.

I tried doing just that, and on every plane barring the CRJ it works just fine, I don’t know what it is about the CRJ in particular but the flaps lever and parking brake just don’t seem to play nice.

Then it’s probably an issue with the CRJ aircraft itself and not caused by either the sim nor your hardware.