Thrustmaster TCA Throttle Quadrant USB device not recognised error

Installed drivers from Thrustmaster directly. Plugged in. Installed. Rebooted. Worked fine for a whole day, no updates or anything then suddenly the throttle keep disconnecting throwing up USB device not recognised/malfunctioned.

A reboot sometimes fixes it but then as soon as I launch FS2020 during the intro it disconnects again.

Ideas?

Moin
In German I can tell you what to do. If you want send a PM

I am happy for advice!

Hello/Moin!
I’m having a similar problem with the TCA throttle quadrant, although most of the time it disconnects as soon as I’ve connected it. I would be very grateful for any advice too (in any language) :slightly_smiling_face:

Hey squik2001 - it is highly likely that you have a faulty device based on what i am seeing.

Things i tried - device manager and see all USB Root Hubs on power management to NOT allow the PC to turn off to save power. Ensure your power profile doesn’t put USB ports to sleep. Also in Device Manager, on each USB Hub ensure the power or max power is 500mA for each port that you want to use for Thrustmaster products… let me know what you think…

Hey there, thanks for your tips but unfortunately it didn’t solve the issue for me (I only received my Quadrant less than 2 weeks ago).

Initially the Quadrant was working ok, then I tried to attach the TFRP and that’s when the ‘USB not recognised’ error began to appear. Sometimes I think it’s sheer chance that Win 10 recognises the Quadrant. I’ve uninstalled and reinstalled the firmware multiple times (and even downloaded an older firmware to see if that helped) which on occasion can fix the issue but it only seems to be a matter of time before the USB error reappears!

I have also contacted Thrustmaster Support and have an ongoing ticket at present but I think I’ve exhausted all options and will most likely have to return the unit and hope the replacement is a simple ‘plug and play’.

This is what i got from TM Support:

First, please make sure your drivers and firmware are updated from the tech
support website:

https://support.thrustmaster.com/en/product/tca-officer-pack-airbus-edition-
en/

Make sure you use a 2.0 USB port instead of a 3.0 USB port.

1-Official statement concerning Microsoft Flight Simulator.
To give you more details and be fully transparent about Microsoft Flight
Simulator In-Game integration process. Microsoft Flight Simulator Teams are
still working very hard to provide an intuitive, handy, and polished In-Game
integration at the level that such a product requires and for the best
sensation of our simmers with Airbus. By October 22, we are sad to inform
you that our Quadrant is not integrated in Microsoft Flight Simulator yet.
The final integration should be released shortly.

In the mean time, you may have requests from end users. That?s why we send
you an official statement with 2 levels :
. Level 1 : We explain our quadrant is not integrated in MFS yet and should
be in the next patch coming soon (no precise date for the moment)
. Level 2 : if end users complain, Thrustmaster advises to wait but we have
an ?abnormal procedure? for the ones who cannot wait.

This abnormal procedure file will be published on October 22nd on our TS
website. You can find it attached but don?t send it before October 22nd. In
advance, here is the link you will be able to share on October 22nd :
http://ts.thrustmaster.com/download/accessories/Manuals/TCA_Quadrant/Microso
ft_Flight_Simulator_Thrustmaster_Abnormal_Procedure_-TCA_Quadrant_and_TCA_O
fficer_Pack_Airbus_Edition
-_22_10_2020.pdf
Of course, this official statement and the abnormal procedure will be
useless as soon as MFS2020 patch will be published. We will share this
information with you as soon as possible.
2- Firmware Update
The first TCA Quadrants (Stand alone or in the TCA Officer Pack) will be
delivered with the 1.54 Firmware. It?s very important to advise each
customer to update to 1.56 version in order to have the best gaming
experience. This file will be published on October 22nd on our Tech Support
Website.
Make sure all the team is perfectly aware about these subjects and ready to
answer by October 22.
Reminder : TCA Range is a triple A range.

In order to be more precise in the answers made to consumers and players,
you are now able to indicate the integration update below.
The previous statement sent is still available and correct.

Available mapping by default with preset profiles

X-plane eco system (X-plane 11.5 and younger from Laminar Research) :
. Toliss: Airbus A319 & A321 aircrafts
. JARDesign Group: JD320 & JD330 airliners
. Flightfactor Aero: Airbus A320 Ultimate, A350 XWD Advanced & A350-900

Prepar3D V4 & V5 (Lockheed martin) eco system :
. Flight Sim Labs Ltd (v5.0.1.114): A319-X, A320-X & A321-X aicrafts
. PMDG Simulations: PMDG 737NGX, 747 and other aircrafts.

Aerofly FS (IPACS) including Airbus A320-200 airliner

Please check out page 7 of the manual below for reverse throttle
instructions for the TCA Quadrant:

https://ts.thrustmaster.com/download/accessories/manuals/TCA_Quadrant/TCA_Qu
adrant%20Airbus_Edition_user_manual.pdf

If your Quadrant needs to be calibrated, please check out this youtube video
that shows you how:

Please see attachment for the Quadrant add-on

This information should mainly help to answer detailed questions. If the
problem persists, please contact the reseller for further assistance.
If you purchased this from our eshop, please give us the order number.

You can also try it on another PC to see if the issue happens there also.

And… this is what i sent back to them:

Dear Thrustmaster -

  • Latest Firmware was applied out of the box.

  • USB 2.0 and USB 3.0 ports were used and found to make no difference
    to the device. Both USB2 and USB3 provide 500mA which is the recommended
    power for both the Sidestick & the Quadrant.

  • Since October 22 2020 - there have been many patches - please be
    specific as to which patch you refer to? As far as I can see from the MS
    patch notes most of the issues were fixed in Patch #5
    https://fselite.net/news/microsoft-flight-simulator-patch-5-released-v1-10-7
    -0/ See ‘Input’ Section and clearly they have stated this officially now
    supported.

  • This device was tried on 2x separate machines and failed the same
    way:

  • Intermittent Failure requiring reboot to fix. Launching of FS2020
    also caused malfunction during input detection.

  • Instant Failure - USB device malfunctioned error message on screen.

  • Calibration was done numerous times and had no impact to the failure
    of the device

Thanks for sharing your updates. When my Quadrant was working I did manage to update the firmware to 1.61 but it didn’t resolve the USB error message.

I have done the following (sadly, multiple times)

  • Checked the Quadrant was in USB 2.0 - I also moved this to another USB 2.0 socket and made no difference.

  • Checked the additional power settings > USB selective suspend settings > disabled: made no difference.

  • Device manager > universal serial bus controllers > updated all USB drivers and made sure all USB’s had the ‘allow the computer to turn off this device to save power’ function: disabled: made no difference.

  • Uninstalled and reinstalled the drivers multiple times (including restarting the computer after installation): made no difference - USB still not recognised.

  • The calibration was completed successfully and fully responsive in the sim (when it does connect until the USB error appears, then I really struggle to get Win10 to recognise the device.)

I’m left thinking it has to be a hardware fault. I really struggled to find any information or YouTube videos regarding this issue until I saw your post, so we must be in the unlucky minority that have faced this issue. I have asked Thrustmaster Support if they can exchange the Quadrant as I bought it direct via their EShop. I’ll post an update as soon as I hear back.

Yea - let me know because i am getting a new one sent out tomorrow - should have it Sat and what i am going to do is just plug it in and see what happens… lol USB 2 or 3 should not affect it at all… after all, the throttle is a USB -C connector which is designed for high speed transfer which is USB3.0

Did you have to return your current Quadrant before they sent out the replacement? Fingers crossed, you can simply calibrate, plug in and fly! I even looked at the T.A.R.G.E.T software (no previous experience) thinking I had to map something but no luck lol. I think we should gain an extra achievement for attempting all avenues before throwing it out the window lol.

I got mine through an EBay Store - luckily the seller had the invoice direct from TM so he was able to get me a replacement under warranty.

At this point, I’ve basically been told to return the unit back to France for a refund as they can’t exchange it for a replacement unit at present. I’m waiting to hear if they will accept it without the box as I don’t have that anymore. As a last resort, I checked my chipset drivers & updated them but still had the USB error. I’m in the UK and with Brexit issues and additional courier charges, I may just cut my losses and buy another unit when available.

UK here too and it’s been nothing short of a total flop from Thrust Master since its failed launch - so disappointed in how it has all turned out - thankfully the flight stick is still working fine - touch wood.

I am waiting for my new quadrant today - so i will post how it goes…

I hope it all goes well! I managed to get the USB recognised again - sheer fluke I think! I did jump into the device manager and under Human Interface Devices > selected the ‘now recognised’ Quadrant and disabled the ‘save power’ option and all working fine so far. Maybe this could’ve been why it was disconnecting before. I’ll post back if it disconnects again but fingers crossed - on a flight now.

:slight_smile: woo hopefully… mine was totally busted so… just waiting now - out for delivery :stuck_out_tongue: fingers crossed

They apparently tested it on 2 rigs and confirmed in full working order.

40min flight to Paris completed with no issues, all working fine?! It’s bizarre, once the USB is recognised, the Quadrant works without issue. I’m just hoping now I’ve disabled the ‘save power’ function, it will continue to work but we’ll see!

Keep me informed I am super curious that I’ve found another person experiencing what I was

@snaxx82 So, my new one arrived - first thing i noticed was the throttle levers were much more solid and needed more effort to move - plugged it into a USB 3.0 port loaded FS and worked first time, no calibration needed and firmware was up to date out of box…time will now tell…

1 Like

All sounds good, fingers crossed! PC has been shut down since this morning, just rebooted and USB recognised! Let’s hope it continues lol.