Toolbar Missing and ability to change certain weather settings missing when loading a saved flight

Actually you want developer mode off. Having it on turns the sim into “not a sim”.

1 Like

Oh. I already tried it off, still doesn’t work!

Flying a new flight altogether is ok. The Toolbar is there on the top of the screen.

However after loading a saved flight then launching it, results in the Toolbar missing!

2 Likes

That is why I gave you that search results above. :wink:

In particular, the results in this topic:

There’s others too in the search above.

1 Like

A saved flight is like a “manual” autosave. Weather, ToD, aircraft are locked and cannot be changed. This isn’t a bug. It has been a feature from Day 1.

Oh…Great feature! :+1: :rage: :face_with_symbols_over_mouth:

4 Likes

Hi,

after createing a new flight, I can open NavLog, ATC, Checklist, VRF map and more over the top menu bar. Short cuts are working, too. I can save and reload the flight. Everything is fine.

If I use the checklist to start and stop the turbine, save again, still loadable and playable.

If I do exacte the same, but flying a round, landing, parking, save the flight, restart FS, load the saved flight, the top menu bar don’t appear and i can’t open ATC or VRF map via shotcut. I can use the short cut to call the fule truck, I can hear my request and hear the responce, but no ATC window.

I have 4 of 4 saved flight with exact the same problem. Only the saved flights, that never flown, are working fine.

Detail steps to reproduce the issue encountered:

  • (A) Start FS and create a new flight, starting and ending from and to a parking position
  • (B) after loading, I put NavLog, ATC, Checklist and VRF map in a dedicated window and moved it to my second screen
  • © use checklists to be ready for take of
  • (D) communicate with tower, start, fly a short round, and go back to parking position
  • (E) use checklist for shut down
  • (F) save flight and exit FS
  • (G) Start FS and load flight

If I do all steps, except D, all fine.

if I do all steps, after “E” I get a menu for leaving the game, but I will continue and continue with “F”. It looks like, that this create an autosave of “TEMPORARYFLIGHT.FLT”. But I create an own file. But the problem apears with booth files.

I have the problem with “TBM 930” and “Cessna 152”. I didn’t tested more plans. But I tested different airports in different countrys.

What can I do?

Regards

Pascal

1 Like

Hi @Hester40MT,

thank you!

Ah, “toolbar” is the magic name :wink: Now, I can find many threads… Looks like a know bug without workaround, or? Is it on a known bug list?

Regards

Pascal

I don’t know if it has been addressed, but yes, it’s a bug.

Deleting those auto save flight files seems to fix it for some. I don’t know what causes it, I’ve never had it before but I also rarely save any flights. The auto-save I do get though but haven’t had the problem.

Ironically, this bug also causes some users unable to select a different airport or aircraft. They are always stuck with the same flight. But deleting those 3 files corrects it.

It would be good to submit a zendesk request on it to let them know you also have the problem.

Zendesk:

Whenever a flight is started from the World Map and after Fly Now is selected, MSFS creates several files to be used any time the user restarts a flight from the Pause menu, from the Exit Flight menu, or from any crash menu. The user is taken to the start of the flight bypassing the World Map screen. These files interfere with any saved flight files other than the current flight created by the user. I’ve opened this problem with ZenDesk a few weeks ago.

2 Likes

Is this reproducible for you? A while back, I tried to reproduce this and couldn’t when users started to post about it. However, I don’t have any saved flights. Does it only do this when there’s a user saved flight?

There’s another “bug” related to these auto saved flights that I also can’t reproduce. It’s effecting some users since first install.

https://forums.flightsimulator.com/t/i-cannot-load-any-different-airport-and-plane-always-the-same-airport-and-same-aircraft/302113/61

1 Like

Hi

Ticket is created: 86584

Regards

Pascal

2 Likes

I found a fix. seems the weather is only bugged if you have live players on. switch to all. or group and it works. not a real fix but it works until they patch it

1 Like

Hi @THECAPTAINHOWDY,
Make sure you report this find to zendesk. If something can be reproduced, it’s easier for them to duplicate and correct.

I have this 100% of the times I tried this, but given the low interest in this issue: is nobody loading saved flights OR is it an issue that only affects some?

I try to save when I’ve landed somewhere that’s not an airport, and I just want to continue later in exactly the same state, but as if the aircraft had been sitting there for a day or whatever.

I will try that trick with the auto-save files mentioned here, maybe that solves it.

Already logged this to zendesk.

3 Likes

I tried this with the default C152 and no add-ons in community folder, starting cold and dark and parked. Then saved, then loaded. Also did another try where I started up and taxi’d a bit first.

I could still see the toolbar after loading, the state of the aircraft seemed correct. The weather is disabled though!

So maybe it happens with add-on aircraft, OR maybe it happens when I land in a field somewhere or have flown somewhere. Still need to test that.

1 Like

Did some tests with saving behavior, and indeed if you save a flight AFTER the flight has ended (so the logbook popped up), loading the flight again results in a missing toolbar.

What I haven’t tried yet: do the exact same flight, save it BEFORE the end-flight screen and load that one, to ensure that the toolbar is still there. I did test with incompleted flights on the same airfield and landing somewhere in a field. In no cases was I missing the toolbar.

If this retains the toolbar, hopefully we can compare the saved files and fix it manually before loading?

The weather is still annoying, I need to test by starting with a weather pre-set, changing to live weather and then saving. Or changing to a pre-set before saving …

In all tests, I always completely restart MSFS to avoid the “second flight” issues. I load the flights from the World Map.

Incidentally, in my tests I noticed different behaviours of the saved flight for things like state of flaps, lights, … I didn’t even think to try what happens if you save / load a flight where you are not parked on the ground.

1 Like

Hi @Monkfishman3086!
Although I’m replying to your post, this is for everyone else too.

Can anyone confirm that is is what is happening to you as well or if it’s reproducible? Please reply my post or topic, I’ve put a watch on it.

Thank you!

Hello, this conclusion wasn’t right. I am now missing the toolbar but no end-of-flight pop-up appeared. In fact I never even left the airfield, just taxi’d around a bit.

I did this test before, first on EBOS and now on EBZH. The main difference to my two tests was that in the first test the engine was cold and dark and the second test I started on the runway with a running engine.

I’m keeping logs of my tests, I will post them later. I made a mistake of not storing each saved flight’s files, so I’ll start doing that in further testing.

1 Like

As a follow up: just did two test. One with a flight started cold and dark, taxi around a bit, then save. The toolbar still worked, lights were fine, location fine, …

Did a second test, but started on the runway with the engine running. Taxi around a bit, save. The toolbar did not work.

In all cases, weather is disabled, probably because I use live weather. Hopefully this can be worked around by starting the flight with a pre-set, then switching via the toolbar (if it’s there) to live weather.

For my next test, I’ll do a cold and dark start, but fly somewhere, land, park, let the flight log end the flight, click continue then save the flight …

Note: I’m doing my tests with the C152 and no add-ons installed.

2 Likes

A flight with cold start, to another field, full shut down and popup of the log before save will ALSO have the toolbar missing when loaded.

So from my tests, at the moment, I think it’s possible both starting from the runway and popping up the logbook cause this issue.

Also, I saved the flight with engine stopped, but when I loaded the flight it was running again. Some lights were on again. Fuel, flaps and even trim were correct though. Also the location was correct.

Also, I should’ve picked a place with better weather for my test flight, that was a bit tricky …

1 Like