Trying to start MSFS, says insert disc

I guess this shows that if something happens to the mS servers, you can’t even play the sim offline. Your sim turns into a brick…

2 Likes

+1 it looks like Microsoft thinks I’ve no more License

Money well spent. Guess its DCS time.

2 Likes

Run to the hills
Run for your lives

1 Like

Major Outage https://support.xbox.com/en-US/xbox-live-status
image

1 Like

Be patient :smiley:

Smth is wrong with xbox live
https://forums.flightsimulator.com/t/getting-message-that-i-am-offline-when-i-am-not/515735/5

Thought it might be a bad install. So I uninstalled it. Went back into the store to reinstall and I don’t see Flight Simulator.

Two nights ago, for no apparent reason the entire app reinstalled.

1 Like

Amazing… Everyday you have a new surprise. What´s next Microsoft?

Cheers

1 Like

I think the outage it getting worse instead of better.

https://support.xbox.com/en-US/xbox-live-status

image

Oh well. I guess I will read the C310R manual instead of fly :slight_smile:

2 Likes

1 Like

Ow, hello, are you new to cloud gaming?

I’m not getting the insert disc, but get message saying I have to be online to open this device. And like others, the sim won’t come up.

Hmm, for me I get this message:

But it does load after I hit Ok (it’s stuck a while at checking for updates though).

(20) Xbox Support on Twitter: “We’re aware that some users are unable to purchase games, launch games or start Cloud Gaming sessions. Our teams are investigating. Please keep an eye here and on our status page for updates. https://t.co/kQKp1LYR4o” / Twitter

1 Like

What’s a disc? If it’s one of those things I think it is, I thought it was a beer coaster.

Thank you for the update

1 Like

I think the problem may be MS Store. It was apparenty updated today and the license items do not appear in the library, just the base game. But it´s not only MSFS as many other apps that were there before are missing now, including some bundled with Windows.

Cheers

should´ve read that thread first… just deleted it because i thought the fault´s on my end :rofl:

1 Like

Same here. I restarted my modem and it finally loaded… probably had nothing to do with it.
Looks like a server issue on their end.