[Tutorial] How to Link SkyDemon to FS2020 for free

Hello. I’d just thought I would show anyone who’s interested a little trick on how to connect Skydemon (VFR Flight Planning Software) to the sim. Just as a note, it uses a piece of software I didn’t create - I take no credit for it.

Download this https://onedrive.live.com/?authkey=!AHrS2FtIdbDIlZw&cid=062A857FB93775AA&id=62A857FB93775AA!30579&parId=62A857FB93775AA!9508&action=locate . It’s a FSX software that works like a charm for the new sim.

1 - Install FSX2SkyDemon via the link above.

1.5 - Log into your target device, and grab the IP. If you’re struggling with this, google ‘how to get device IP on [device]’

2 - Open FSX2SkyDemon and place the IP of your target device into the ‘outaddr’ box in settings.

3 - Restart FSX2SkyDemon.

4 - Launch the Simulator and spawn in. Ensure FSX2SkyDemon shows green, indicating connected.

5 - Open SkyDemon, go to third party devices and select X-Plane. Then Select Connect with xplane via go flying and it should work.

Disclaimer: This isn’t my software.

If you have any issues, please leave them below.

Jude

6 Likes

Hey Jude,
works like a charm! Thanks for your very useful topic. Any chance for AirNavPro? Probably not, but Skydemon is also a very good choice indeed! :+1: :love_you_gesture:

1 Like

Hey Ruksak,

Glad I could help. I’ve never used AirNavPro so I’m unsure, sorry. Best bet would be to keep a look out around the forums to see if anything pops up, or maybe give them a contact and see if they have a way to support it?

I will have to check this out, never did use this in any other sim. Thanks for sharinig

1 Like

Didn’t work for me but that’s ok!

Yeah, not working for me either. The iPad is stuck on ‘Waiting for X-Plane’ Side Note: The option on iPad didn’t say X-Plane 11, just X-Plane if that makes a difference.

with xmapsy it works, cost some but not much

Yeah, I´m going to contact AirNavPro staff. Hopefully we will get the plugin soon. :+1:

1 Like

Works for me completely fine. Are you sure you’ve restarted the program afterwards, and ensure it’s the IP of your IPad or tablet, not the network. I’d be happy to post a video or step by step tutorial to help you out, as it definitely works.

1 Like

Yup! Restarted everything. IP addresses are correct. :frowning:

Hm, that’s odd. Load into the sim and spawn in. Does your FSX2SkyDemon show Green under ‘FSX’, and that it’s transmitting data and you have your plane marked on the map? Should look something like this image. Gripping If it doesn’t, the software can’t pick up SimConnect, if it is, you’re not transmitting it to your Device correctly. Just to confirm, I beliece this may only work on External Devices. So the app on your computer won’t work with this method.

I would LOVE a video tutorial. Many thanks…

No problem. Will get one on here as soon as I can highlighting how to do it. May sound very complicated, but I promise it is simple when you get the hang of it and is totally worth it for it being free.

Thank you SO MUCH. Personally I failed using an MS Surface tablet. I did not see the settings you were referring to.

Got it working! Had a typo in the IP Address. Haha. I blame the beer. Cheers man, this is awesome! Might have to spring for a Sky Demon account after this trial is over. Thanks again!

Now if there was only a way to easily import Sky Demon flight plans to MSFS :wink:

No worries! Yeah, that would be nice haha! Also made a little bit of an error on my behalf, it’s your standard network ipv4. Will publish a video tutorial in the next few minutes for anyone still struggling.

https://www.youtube.com/watch?v=KO6-xgfCoKI New video tutorial now uploaded, edited in link above. Apologies for any confusion I may of caused in the original instruction. The first message is also edited. Ensure you restart after you’ve placed the IP

Hmnm, it seems the IPAD app is not working. I did all the IP stuff and the app that I downloaded on Windows works correctly. But the IPAD app just says “Waiting for X-Plane”. I followed your video to the T as well. Not sure what is wrong.

Double check these things.

That FSX2SkyDemon was restarted after you put the IP in, and that it’s outputting data correctly.

You’ve set your Ipad to your networks IPV4

Your Ipad is on the same network as your PC.

Double check this on your Ipad. Go to settings > WiFi click the ‘i’ next to your connected network, and check the IP there is the same as the one on fsx2skydemon. If it’s different, change it to the one you found on your Ipad.