Uk update --- spacebar issues

with last update the spacebar go crazy… presses itself. i reset keyboard profile and with clean community folder. simulator is unusable. :frowning:

Maybe clean your keyboard? Dunno.

1 Like

you’re kidding me? o.O

Just check your bases. Normally software doesn’t press your keyboard.

Also check for double keybinds. Is your spacebar bound to the same thing as a button on a joystick/controller?

Bluetooth keyboard? or wired? Bluetooth can cause issues.

My keyboard is wired, i use an apple keyboard… when i launch msfs2020 spacebar presses itself… i play with a midi controller today but i have unistalled all.

now it works, without having done anything!!! Windows mistery :smiley: :smiley:

I’ve now got this problem since the update.

Everywhere in the sim, it’s as if I am continually pressing the spacebar - on the world map, it immediately takes me to the load dialog. In a search box, it repeatedly enters a space. In flight, the cockpit continually shifts up and down.

This happens with the community folder empty, and the joystick unplugged. Outside of the sim, there is no problem - the spacebar performs as normal.

I hope it clears itself as the OP said, but at the moment the sim is unplayable.


I think I’ve found what is causing it.

I normally use the starter routine by @AmbitiousPilots (to have a start-up screen, and avoid the adverts). Using the standard link, there is no problem.


Yes, this is the problem.

You havent needed that in ages! Just use the fsdevmodelauncher from the SDK.

I’ll release an updated version of FSJumpStarter shortly to fix this :wink:


Cleaning your keyboard worked then? :wink:

To avoid the adverts I use this:

cmd.exe /C start shell:AppsFolder\Microsoft.FlightSimulator_8wekyb3d8bbwe!App "-FastLaunch"

1 Like

lol made me laugh :smiley:

1 Like

It gives me a startup screen, and removes the adverts, so why would I want to change?

Version 2 of FSJumpStarter2020 has been released :+1:


Because it kept pressing your spacebar.

Yes, I know - that’s how I realised it was the source of the problem.

Perfect - downloaded and now back to normal (without having to sit through the ads).


Thank’s … :smiley: Grazieeeeeeee :smiley:

1 Like

Just curious, why do you need a mod for this? Can’t you just add the -FastLaunch modifier? Or doesn’t that work on the MS Store version?