Unable to hear own replies in ATC, anyone else have same?

I had this issue earlier today and as mentioned in the OP, it was slightly different than past ‘missing voices’… the menu system was slow to respond. Examples…the acknowledgment option was greyed out for a few minutes. And in another instance, I could see the option to tune the radio to tower, but pressing the option wouldn’t do anything. Once I changed the frequency manually, the ‘contact tower’ option came up fine.

Edit - I was piloting the payware C414 when this happened.

My experience is a little different, I can hear pilot and atc but all simultaneous. When the co-pilot asks clearance the atc voice also instantlly reply’s giving clearance so all talk at once. Also, when the co-pilot starts repeating the request, I know by now a CTD will follow, had this happen twice. I only tested with the A310.

I had similar issues with radio comms using the latest beta that’s just been released. (1.29.29.0)

Had ATIS, clearance, ground and tower. I heard them and my replies on Azure voice comms as I got clearance, taxied out to the active and then called the tower when ready for takeoff.

Tower cleared me to take off, I hear my reply, lined up and took off, never hear any other comm message from tower.

After a few minutes I saw the text in the ATC window showing tower handing me off to approach. I replied to that and heard my reply. But got only a text response immediately after my call.

Contacted approach, same thing. Immediate text, no sound. I can hear my comms but no ATC comms from the AI controllers, traffic, etc. nothing.

2 Likes

The ATC panel can be completely stuck as well. One time after I asked for pushback, the pushback tug disappeared and the ATC panel was greyed out from that moment. No incoming communication or replies from my copilot was there from that point, I couldn’t even choose any option anymore.

1 Like

Yes there is still issues like this that exist since a long time. Like getting information from ATC but not having any Acknowledge button, only Repeat again.

Since yesterday I can hear myself but I don’t hear ATC and AI pilots. I can read ATC’ and AI pilot’s messages though when the ATC window is open.
Before this issue occured only one and the same voice was used for ATC and all AI pilots. This voice changed from flight to flight though.

1 Like

Yes, same issue here. I can’t hear nor do I see (in the ATC panel) my responses to ATC. I tried all sorts of things, but nothing works. I have only been using the PMDG 737 recently, I am going to try it with the 787-10 or the 747-4 default aircraft to see if the same issue occurs with those aircraft.

It’s really frustrating.

Cheers.

1 Like

Same here. Been dealing with this for a few hours now

Some people are stating this problem is exclusive to the A310. It’s happening to me with all aircraft and usually results in a CTD.

Was happening to me with the Justflight Arrows and the Milviz 310R.
Was going to try with defualt aircraft but it seems to be working ok for me today in everything I’ve tried.

Yes, I tested in FBW and BN-2 Islander and the issue persists, i.e. I can’t hear my own responses.

<Edit> Actually, those tests were after a flight with A310.

Just did another test.

  1. Started sim.
  2. Start flight with C172 - ATC ok - hear my own voice / can hear ATC - back to menu.
  3. Start flight with C208B - ATC ok - hear my own voice / can hear ATC - back to menu.
  4. Start flight with FBW A2NX - ATC ok - hear my own voice / can hear ATC - back to menu.
  5. Start flight with A310 - ATC not ok - hear my own voice on first response, ATC responds too quickly and can no longer hear my voice for subsequent responses / can hear ATC - back to menu.
  6. Start flight with C172 - ATC not ok - can no longer hear my own voice / can hear ATC - back to menu.
  7. Start flight with C208B - ATC not ok - can no longer hear my own voice / can hear ATC.
    End Test

Problems start after loading into A310 and then affect other planes.

Can someone repro?

3 Likes

same here; just after the response from the ATC after the taxi, and have no response from my own contact with it. I’m afacing this since the update SU 11, and had any solution for this till now.

I’ve seen this same behavior. The A310 seems to cause this problem.

Same problems but only tested with a310.

Atc cuts out really quickly and co pilot response are not heard, but text is in atc window.

I am playing in Xbox x Build 1.29.29.0. Unable to hear any ATC call or my pilot’s voice also. Upload a clip

waiting for a solution. the golden answer is when it will be launched
.

I fly the Longitude only, and my problem was the same as the OP’s - I could hear ATC but couldn’t hear my own responses. I was actually able to fix it by setting a different frequency on COM1 (doesn’t seem to matter as long as it’s different) then going to COM2 to set the current correct frequency then just working from COM2.

Happened to me a few times since update asswell. I’m flying right know and stopped hearing pilot’s voice, atc I can hear ok. Im flying blackbirds C310R with PMS GTN 750 and noticed it won’t let me change frequency manually, also I activated the option to let AI take over the radios and I can hear the copilots voice.