Unable to hear own replies in ATC, anyone else have same?

The ATC menu was initially very slow to respond, was nearly 3 minutes after I selected an option from the ATC menu before I got any response.
It now responds OK but I don’t hear any of my replies?

Same here!
I start my flight cold and dark. My initial responses to ATC are instantaneous. Eventually, I notice that from the time I press an option until I hear my pilot’s voice, there is a delay. The delay gets worse until about 5 or 6 responses in, when my pilot’s voice is gone completely. However, ATC INSTANTLY responds to my pilot responses. I just noticed this behavior this morning.

I just tried and Azure servers were down.
But they went back up and ATC worked fin but:

  • I’ve now a male voice when I had a female voice before.
  • ATC is now a young female voice (kid’s voice) when it was a male voice before.

Chances are it’s using offline voices. Some of them sound like children.

Welcome to Doogie Howser, ATC.

1 Like

Yeah if it’s offline you get the 10 year old kids taking over the ATC.

1 Like

I don’t hear the ATC at all anymore. On Xbox, and since this afternoon.

1 Like

LIkely Azure voice issues and the reason @Flobud got switched to offline voices.

Better use PRO-ATC/SR ^^

Wasn’t offline when I was using it a few minutes ago. I was still getting the adult Azure voices, just not able to hear my own replies.

Will try again in a bit, just got some new planes to install/update.

Make sure you data is on and under audio that it didn’t switch ATC to offline mode. It may have switched you due to connection loss.

Hi, is this the bug you are referring to?

1 Like

Not quite the same as that. I can hear ATC talking to me but I can’t hear my replies.
Just started sim again and now ATC options are all greyed out and not responding at all.

1 Like

It is. And same as this thread below. This is an old-long-standing issue that seems to come and go.

If you do a quick search for “HEAR ATC”, you’ll see numerous different threads going back over a year in the bug report section that have fallen off the radar and never having gotten any traction or attention.

For me it’s a bit different though. I really don’t hear ATC at all, nor is my copilot responding. There are no instructions by ATC incoming. Nothing.

@Crunchmeister71

They are different. The thread you linked is an issue where it happens suddenly, and mine (Can’t Hear ATC and Other Aircraft after SU11) is that you can’t hear it at all.

1 Like

When that issue happened back then, you could also start with not hearing anything at all. Sometimes it would work then cut out in flight. Other times, it just didn’t work.

This issue is what got me using Pilot2ATC about a year back. I was tired of dealing with it.

1 Like

On the first flight after today’s update, the ATC did not work either. Now on the second flight everything worked normally…

Seems to be working here.

A310 or all aircraft? I’m having ATC issues but only with A310.

A310 can’t hear my responses. Can hear co-pilot response initially (when set to co-pilot handles ATC), but soon you can’t hear any ATC at all.

Even when you get the usual ATC timeout bug you can still here your response, but in the A310, nothing at all.

I’m experiencing issues with the A310 and not other aircraft, as well.

It is(was) not a radio volume issue, either.