Unprecise Mouse Movement in Flight Simulator 2020 on Xbox Series X

Hello,
I’m experiencing a really annoying iusse when playing Flight Simulator on my Xbox Series X.
Everything is working well in genrall but the mouse movment is way to laggy and thereore unprecise when trying to use some dails or switches in the cockpick view.

I tried several things like changing the cursor senstivity or deleting the user files and starting the game again.

I also connected a wired mouse since I was thinking the wireless connection is to slow for a reason, but same issue.

There ist also a HOTAS fligth stick connected to the Xbox. I noticed in some other discussions that in some cases this caused a problem when using mouse an keybord too, but it feels ike there is no change to the mouse issue wether HOTAS is connected or not.

I do not expect a precision of the mouse suitable for an ego shooter game, but this feels like there is something slowing down the mouse significantly. There are no other downloads running in backround except what FS is downloading during the game to create the world. I believe my connection at home ist fast enough for this.

Anyone with similar problems or maybe even a solution to this?

1 Like

Welcome to what we have been suffering with since release. Asobo have decided to implement a kind of negative mouse acceleration. Sadly this is something PC users see a lot with some of the worst console ports.

If you compare a mouse, and a console controller (analogue stick), the mouse uses absolute positioning, and the joystick relative. You move the mouse, and the pointer “should” move at the same rate that you move the mouse. With the joystick you deflect it a certain amount, and the thing you are controlling continues to move by that amount, increasing in speed if you deflect it more, or stopping if you centre the joystick.

My guess is they have implemented this negative acceleration to make small joystick inputs more precise? The problem is they applied this to the mouse controls as well! It is entirely possible for me to drag my mouse slowly across my desk, and not have my view on screen shift an inch. Until you move the mouse a certain speed your viewpoint won’t change.

I hate this with a passion! :slight_smile:

They really should uncouple the mouse, and controller schemes, and leave the mouse inputs alone, and stop interpreting or otherwise fiddling with them.

These symptoms are one of many that come under one of many umbrella terms, including consolitis. PS I apply this to the controller itself, not the platform.

A good developer is one that understands they have two audiences with two different controls schemes, and implements both of those in an optimal manner.

There was a test we used to do to detect regular mouse acceleration in a title. What you did was position your view at a fixed point on screen that you could identify, and make sure the mouse is butted up against something, like the edge of the keyboard. You then move the mouse away from that point at a different speeds, and back to the keyboard. If your view returns to the exact same spot you have no mouse acceleration. If you vary the speed that you move the mouse between tries, and if your view does not come back to the same spot you have mouse acceleration.

That test would work well here, but is unnecessary as it is so obvious it is in effect.

2 Likes

Thank you for your quick reply and your explanation.

I’m sad to hear that this is an unsolved iusse and I’m almost shocked that a “simple” mouse interface can be a problem theses days. But I’m just an user, not a programmer…
Thank you. Hope they are going to fix it.

1 Like

Me too. I logged a Zendesk ticket on this in late 2020 I think, but it just hasn’t got enough attention yet. Its low priority, but a near constant niggle.

2 Likes

Should have more priority. I consider this almost unplaybale with this issue.
If I had known, I gues I would have chosen the PC version. But a gaming PC capable of the same performance like the Xbox X is way more expensive…

I’m on PC as well, hence my consternation! :slight_smile:

It’s not a PC or XBox issue, its a sim issue, where they are applying console controller settings to the mouse. It’s interesting that its happening for a mouse user on XBox though, but it makes sense.

1 Like

How hard can it be to get the mouse working properly in 2022?
I am really thinking of returning my Xbox to while I still can. I bought it ONLY because of MFS

1 Like

Same here. At beginning of a flight it’s, well let’s call it passable. 20 min into the flight and it is almost impossible to use the mouse. Stuttering and lagging.

#xbox #bugs-and-issues #mouse #lagging #stuttering

I am having similar problems. Have completely updated MSFS, have a brand new Logitech keyboard, which is working fine and have a Logitech G604 mouse. It’s the mouse that is giving me problems. I can see it on the main screen and change Activities to World Map, etc, but cannot click to get into them. What am I missing? I was hoping by now they would have solved most of these issues. Thanks in advance.