Update 1.16.2 : is MSFS now a CTD generator?

hi,
I hadn’t any CTD from my first MSFS Deluxe installation in december.
Since the 1.16.2, MSFS is no more playable for me. Some areas are now forbiden or i face a CTD.
LFBD is one of this (so funny, Asobo studio is located in Bordeaux)
So Asobo please a give us a quick fix or create a CTD radar :rofl:

And yes : i ve tested and updated everything possible (GPU, drivers, …) . i ve probably tried every available CTD trick on internet and my PC is designed for MSFS (I10700, 64 Mo, GTX 3090…).

Maybe Asobo should slow world simupdate and ensure a stable MSFS.

7 Likes

Did you buy your PC that way or did you upgrade an older system with new parts? If you upgraded with new parts your issue could be the power supply being overloaded. Either way it’s worth checking to make sure you have a power supply that can handle all that hardware.

3 Likes

You sum it up correctly!
I Spent most of 27/5/21 getting Laptop updated, MS updates, Anti-virus, etc… then downloaded the 1.16.2.0 updates. Everything went fine (except Free Paderborne took nearly 4 hrs for 3GBs when the 1.16.2.0 only took about 1hr!).
So, looking forward to all the new ‘fixes’, on 28/5/21 began checking out all my problems outstanding on zendesk ticket 105965. Nothing had been fixed, also the Cessna 152 flight behaviour has reverted to before April.
So total let down and cannot even fly Aircraft now.
Most of the ‘Problems’ have been working previously?
Yes I would also like a stable BASIC MSFS

1 Like

I’d had a couple of random CTDs since this last update, but overall not bad. The last couple of days though, I’ve had more in that short time than I’ve had in the last couple of months combined.

1 Like

Not a single CTD yet. Check your hardware, and check your mods.

12 Likes

I had a few crashes as well… my own fault, realized I had a few mods that I did not uninstall prior. This fixed my crash issues.

I have only encountered one CTD and that was last year. I am on an older PC with a 1000 watt PS and absolutely nothing in my community folder.

I keep reading about CTDs… I started to wonder if is a small group of people that may have some hardware-software (lot of issues with AMD) that is conflicting with the sim.

I havent had a CTD since November and I use VR since March. Anyway, maybe is that I am on Intel with Nvidia 2080TI with Reverb G2 that is more common, I really dont know whats the difference.

2 Likes

Are you current on the 152 IRL?
I’m asking because it looks like most current 152 pilots do like the improved 152 flight model a lot.

2 Likes

Glad to here someone else is having the same issue. I had 3 CTD’s in a row after I went through the whole cold and dark process in the A32nx. I almost gave up completely but remembered windows just updated. I rolled back to the previous update and so far no crashes. Maybe a problem others are having? Not sure but it is worth a shot to see if yours recently updated. Every time windows updates I have an issue with this simulator. It either wants me to do a full reinstall of the sim or I have to roll back a windows update.

Since the update to 1.16.2.0 I’ve had two,

The first occurred where nearly all my CTD’s go, that is a crashed flight, then going main menu. Few seconds… bam. To avoid it: Restart and then return to main menu.

I’ve had a CTD when I overstressed C172 while diving in (active) Pause mode. First time I saw that. I’m not sure how to avoid this one, it may depend on the weather presets, I was fiddling with winds (?)

PLEASE, can people stop assuming that people that post these topics are beneath them?

Nowhere did the original poster state that they changed hardware recently.

I too have had a large number of CTD’s following the update recently that didn’t happen before in the base game without any mods.

Did I change out any hardware? NO.
Did mods do this? NO.

In my opinion it’s not helpful and exhibits a complete lack of empathy for the posters. This isn’t about feelings, it’s about someone who’s so upset that they were motivated to post about it.

12 Likes

@BakedSiamang970 I don’t even bother replying to those posts now

After more than 280 hours flying MSFS with TBM930 and Robin DR400
never encountered any CTD

My configuration is a new home build PC only for MSFS
Power Corsair 850 W
Asus X570 F WiFi
Ryzen 7 3700X
32 Gb RAM Corsair 3200Mhz
NVidia RTX2070 Super
2 x LG 27" 1440p and 2 x LG 22" for ATC, Navigraph, VPilot etc…
SSD NVme 512 Gb Windows 10 build 20H1
SSD NVme 10000 Gb MSFS
SSD NVme 512 Gb partitioned for cache and Add On stockage

Sorry, but this is a misleading statement. Mods do most definitely create issues after every update.

There is a reason this appears at the top of every “Release Notes”. When the underlying code changes in the sim, any mod that references that code needs to be updated by it’s developer. Not all mods are affected but some are. Not all developers are on the ball with their updates and so you may find anything from a scenery file, livery or aircraft that suddenly creates a conflict. Sometimes without even actively using the mod, just the fact that it is in your community folder. This is not just self installed mods. This also applies to Marketplace purchases that have not been updated.

This is, unfortunate as it may be, the reason others wade in to remind those with CTD to check the basics first. Not everyone is aware or understands the implications of having ANYTHING other than the base package running after an update has the potential to crash the sim.

Best practices would suggest removing ALL adds that were not part of the original purchase before doing an update and TEST the sim thoroughly before reintroducing the addons. If all goes well, no issue. Otherwise you can narrow down the cause by slowly adding and testing until you find the culprit.

Statements as you made above do not help anyone solve their problem.

5 Likes

99% of the times i had a CTD was a mod that needed update or deletion
Addon Linker is a life saver for these cause you disable the mod you think it’s causing the problem and all good

2 Likes

Hello everyone, what should be said here again is that the FS2020 reacts very sensitively to overclocked components. So if you have CTD’s and have overclocked your system in any way then try the whole thing without overclocking. I’ve already had that myself when I tried to overack the computer even slightly. I’ve read the same thing over and over here. Maybe it will help you further.

1 Like

NEW Ryzen 5 5600x (No Overclocking)
NEW RX6800xt (No Overclocking)
NEW M.2 SSD 1TB
NEW 32Gb (3600Mz) RAM XMP Enabled and disabled (Makes no difference)
NEW Mobo: Gigabyte X570 Aorus Pro
PSU: 850 Watt EVGA 850 GQ, 80+ GOLD

VR HP Reverb G2

All MSFS Setting on low to Med
MSFS Render Scale 80%
OpenXr Custom Render Scale 50%

No Mods loaded

Fresh install of Windows & MSFS
Windows update includes KB5001330 (Patched)

Still CTD doesnt make a difference

2 Likes

1.16.2 gave me the first ever CTD I’ve had in MSFS since release date. I tried completely deleting and reinstalling the sim (I had been wanting to move the packages directory to an external drive for a while now anyway), but that didn’t solve the problem. A little detective work then determined that a mod was responsible for the CTDs. A few hours of investigation and I located the mod that was causing the issue (still not sure why though). Dodger Stadium in LA. Deleted it and voila, working fine now.

1 Like

Interested to know if the latest windows update causes problems for you