Update 7 mayor issues

The sim is nearly unplayable after the last update.
And yes, all updated , all drivers , same high end pc , rtx 3080 .
Our armchair pilots are willing to beta test msfs before next release… (over 2000 members)
Did you tested the release only on 1pc … ??

Toolbar doesn’t work
Stutter fest even with the lowest settings
Vr crashes all the time
FPS drops ( I’ve usually around 70 FPS in VR )
Now less than 15
And downloading the update cranks the GPU up to 100%

That’s not even near of a professional update.
That’s a complete downgrade.
Just saying…


unlucky, working just fine for me.


Did you use package or VR?

Fine for me too in VR and 2D. Only material issue (that needs fixed) is the VR toolbar not clickable. All else excellent and very stable and great performance.


What headset are you using? What OS? I’m on a Quest 2 + windows 11 + 3090 FTW + i9-11900K and crazy stutters in VR. Smooth in 2D.

Exactly same here . RTX3080 card and no problem before SU7 installed . now stuttered so severe that I feel that I have got a vertigo. not just a tool bar non-clickable , unplayable is the word to describe the situation . what they have done?

1 Like

Flying VR in FA18 - everything working nicely, steady frame rates.

HP Reverb G2 with an i9 10900K, RTX 3080 64Gb RAM. I use motion reprojection, 50% scaling in OXR and 100-110 scaling in sim depending on performance. Most settings on high a few ultra and some medium - bit of a mix. I do keep fiddling with it a bit and need to stop!

EDIT: Win 10

Win10 , quest 2

Here’s my anecdotal experience from just now. I do not run in VR.

High altitude is ok.

Zooming around San Diego in the F/A-18 at full speed, skimming the rooftops. Absolute disaster stutter-fest.

Turn down terrain and distance sliders, no change.
Turn off live weather, no change.
Turn off photogrammetry, no change.
Delete rolling cache, recreate rolling cache (10GB), smooth!
Turn photogrammetry back on, still smooth!

I’ll see how long this lasts. Try it.

V-Sync 30fps

1 Like

My VR is working but I can’t click in the tool bar either ! Any one have a suggestion ?


See this post (and the thread):

Not tried it yet though


Same! Had to lie down after fighting through the stutters for a few minutes. Everything was perfectly smooth on SU6.

Same here (with high end pc, RTX 3090).
The toolbar workaround is okay, but the performance problems in VR have to be solved by Asobo as soon as possible. Before SU 7 it was great. Now the fun of flying is gone.
Why not roll back the whole VR part?

I used CapFrameX to test the framerates before and after and I’m not finding any major difference. My flights are stutter-free.

If you want to try my settings for a Reverb G2…
Motion reprojection off
OpenXR at 70% (I actually have this at 85% but I’m running a 6900xt)
In-game resolution 100%
LOD at 100 (if I go above 150 I get severe performance drops)
All other in-game settings 1 notch below max
Most Important Setting: cap your framerate to 30 fps using your graphics card software

It seems that once again MSFS delivers such a diverse spectrum of experience :hushed:. I only managed to get round to the update this afternoon; and as usual it took several hours (that said, without issue).

I’ve now done 4 flights over almost 5 hours … all low level VFR in fairly low impact areas … USA Midwest (default C172 & JF Arrow); and North UK (JF Warrior) also with Bijan’s magnificent seasons reinstalled.

I have to say that (excepting the widely documented stuffed-up menu), it was probably the smoothest VR flight thus far. I didn’t measure FPS, but as measured by my Mk I Human Eyeball, flights were silky and completely stutter free (even on my modest system). Mouse response seems to be a bit worse than SU6 (but still better than SU5). And - although I can’t quite put my finger on it - the graphics seemed better somehow … sharper and with more subtle lighting. Not sure I can explain quite why.

Legacy VR interface (mouse only - don’t use controllers).
Reverb G2
I7 9700
RTX 2080Ti

Seems like G2 users seem to be having better luck than we Quest users?

Not quite. I am also on G2.
But it seems high end systems are more affected.

Are you running Windows 11?

No, still on 10.