Update presumably required but not available

I had to reboot, then the update took

I went back to the store and logged in again using my Microsoft ID and found the Premium Deluxe edition Xbox update option visible again. (It wasn’t there an hour ago and the store had said everything was up to date). Anyway I clicked it and that led to a satisfaction survey which I couldn’t get past so I told them how I felt. When I finished that there was no option to do the update so I rebooted yet again and tried the program again.
It started but now the name seems to have changed to Game of the Year.
I went to Content Manager and there was the same suggestion to update as was there 2 days ago when I did all that…

Honestly if it works I’ll be astounded. Whoever is in charge of this needs to have a serious tune up or better yet, a meeting with Personnel to discuss the assistance they can provide with that person’s search for a new career!

Anyway it seems to be working for the moment, sort of. I just downloaded the Volocity because it was developed by a fellow who really got me into Flight Simulator years ago with a plane I fell in love with the Nardi Riviera. He’s working to update that too and for sure it will become my favorite. Anyway I wanted to try it out in Italy so I’m on the map but it won’t move. I can select an airport from the list but cannot move the map to see other airports,
Is that how it is now? I was sure the map would move last time I tried locating a different airport.

1 Like

And when I zoom out I end up somewhere else and despite the airport name not changing, when I zoom in that airport is nowhere to be seen!
This is just one glitch after another!

I’m done today. I literally can’t take this ■■■■. I may try again tomorrow but if its like this again think I’ll contact Microsoft and demand a refund. There is no way a corporation the size and scope of Microsoft should be allowing this kind of nightmare to be perpetrated on its subscribers.

Launch msfs click Options → Controls options.
Select deafault mouse profile - apply and save.

Tried downloading the latest version of MSFS2020. Initially, opened XBox, the update shows an error 0%, code 0x80070032. In Microsoft store, it tries to download then shows an error message stating "something happened at our end’.

Tired starting MSFS2020, it doesn’t download any update, just goes on and starts the simulator is its old version, but the Market Place is unavailable.

When I do a search on the error code, one of the first suggestions is to uninstall and re-install the sim, which is not something I want to do.

Any help would be appreciated

Thanks for any help


Uninstall, then re-install the Xbox app.
When you get it working, go to and log into the MS Store. You can find the library click spot on the left near the bottom. You updates should be available in there.
Once you have it, start the sim it will get to the update screen and ask you to update.
Once you do that, from the main menu in the sim top right, it will show you have updates pending.
Go to your content manager then and install the updates.
Whew, quite a process, but that you should get it you going.

If you have any problems again, let us know!

I tried this process, didn’t help. Here’s what I’ve done:

  • Installed EVERY option update using the in-game the Content Manager
  • No update pushed in-game.
  • No updates shown in MS Store (“Premium Deluxe Edition” has a button which says “Install from Xbox App”
  • No updates shown in XBOX App
  • All Windows 10 updates installed. All drivers updated. Gaming Services is (I think) up to date.

Thank you for your comments, but I also failed to achieve the update. Did exactly what you said, when I went into MS store, several files became available which wern’t there before, all installed themselves except the MSFS2020which gave me the same error message as before.


A couple quick questions:
Do you remember what the updates were that were in the content manager that you installed?
Did you participate in the beta version of this update?
What version of the sim are you currently showing?

I was not in the Beta.

Currently showing 1.21.13.

Installed all of the scenery packs (Japan, Germany, USA, etc) which apparently hadn’t been installed with previous updates for some reason??

Maybe next time you’ll delete your activity before making up stories.

You should have another title in the Library
See attached pic, if not, did you try the “Get Updates” button.

Yep, I clicked “Get Updates”, and I actually have 3 different instances of MSFS in the Store.

‘Microsoft Flight Simulator’ shows “Modified 11/19/2021”

‘Digital Ownership’ shows “Modified 3/4/21”

'Microsoft Flight Simulator: Premium Deluxe Edition" shows “Purchased 2/25/21” and there’s a “Install from Xbox app” button, which takes me to the XBOX app, where it just says “PLAY” with no option to update.

For me, one was Direct X but the others I can’t remember because they seem to have no connection with the Flight Sim. My current version is 1.21.13 I was also not in the Beta


As you can see, I have all three as well.
It’s the one with the arrow that has the update.
I’m not sure why the other says so, that isn’t the update.

When I click GET UPDATES, though, it says ‘Your apps and games are up to date.’

I have the Microsoft Flight Simulator listed on top, with under the Modified section is ‘Something happened on our end’ I have tried ‘Get Updates’ but it just returns to the error message


Did you try logging out and then back in to the MS Store?

Yes, several times