Update presumably required but not available

My version is 10.1.0.1 but every time I try to start it I get a message saying a mandatory update needs to be installed FROM THE STORE despite being on automatic updates …which is why I have the version I have now, since it updated automatically.
image

Then when I go to the Store, there is absolutely nothing there about updating the program.
Nonetheless I am totally unable to run it due to every start being stopped with that message.

Anyone know what is going on?

Computer: HP Omen 17" Laptop Installed 20210402
System: Windows 10 Home
Processor: Core i7 10750H
Memory: 64 GB DDR 4
Graphics: NVIDIA GeForce RTXT 2070 (8 GB GDDR6 dedicated)

You need to do all of your Windows updates first.

Then how to the Windows Store, go to library, and on the 3 dots in the upper right select the option to check for updates. The problematic one is usually gaming services. Then reboot ant try again.

mines downloading via the xbox app for some reason so try that

I think hi version is so old it’s pre Xbox app

For me, the updates weren’t available on the store this time, I had to manually go to the library on the Xbox app!

I hate the update process for MSFS. Eventually an update appeared in the MS Store app and clicking on that opened an “XBOX” app. I have no idea what the real name of this app is beyond XBOX as that is how it appears in the task manager. From there I clicked on update and it is downloading now.

Is it too much to ask for a bit of consistency in updates? Everytime there seems to be some new exciting method of installing updates.

3 Likes

no MSFS update in the store , i updated the xbox app , then in xbox app there is an update for MSFS

It’s been consistent for the last two, but it’s really clunky.

If you go into the standard version and then into content manager within the app, you can download the delux / premium content.
The problem is actually Microsoft and not Asobo wrt the updates. Honestly if you knew the half of it it would frighten you :grin:

Thanks again. I’ll try that now.

Absolutely UNBELIEVABLE
I did that and here is what I am presented with when I try to run the program:
1st of all there was a popup about the Microsoft Dependency something or other which I clicked OK to and then the program seemingly started to run until it got to this:

Wow do I wish I could reach out and touch those responsible for this!!

So what does one do now? Fly paper airplanes?

I’m not sure tbh. I’d log a call in zendesk. They might be able to help.

They have yet to reply to issues posted months ago

1 Like

Yes, but they’re bug reports and general issues. They need to go to developers. They’re quite helpful at getting people up and running and issues with the i game market place.

If you haven’t already tried, log out of the Xbox app and back in again. Also, try the same with the sim, log out of your Xbox I’d in game, restart the sim and log back in with your Xbox ID.

I have a very basic problem: I can’t download the patch / update because I cannot access anything in microsoft store. The help files say click the three dots at the top of the screen in Store, in order to start searching, but I do not have the three dots. I’ve been struggling all evening to access this update (and get back to flying) but with success. Is anyone else suffering this frustration?
Am in the right forum?
Can anyone help?

Robert

Hi Robert, try going to the Xbox app and looking at the library in there for the update. Microsoft have moved game updates to the Xbox app.

My friend, I am so totally confused I have no idea what you are saying. I run the game from Windows. I’m not even aware of having an “XBOX ID”. I store all my passwords in a spreadsheet and never entered one in for Xbox.
This whole nightmare started when the sim became Xbox compatible. Since then every attempt to use it has ended in disaster and I have struggled for days with each update. I’ve spent thousands on this laptop, upgrading it to max specs and on the Reverb G2 VR Headset.
At this juncture I am completely lost.

You must have an Xbox ID in order to play. It’s basically your Microsoft account, the one that you use to log into the windows store app on the computer. In games it’s called XBox ID but it’s basically the same thing.

Within the windows store there is an Xbox app. You need to download and install that. That will ask you to log in with your Xbox ID (Microsoft account)

Once in there, you should see any games that you have bought from the Microsoft store and / or updates for them.

It’s a shambles to be honest, but it’s Microsoft’s shambles and other games are in the same predicament.

1 Like

Many thanks XR219, you solved my problem! A whole evening wasted because the update was in Xbox. From the recent survey is seems only a minority of simmers use Xbox (or perhaps Xboxers didn’t get or reply to the survey).
As you say - a shambles.
But thanks again
Robert

To be fair, it’s nothing to do with Xbox users. It’s Microsoft band all their games regardless of PC or Xbox devices under the Xbox brand. But having windows updates, store updates, Xbox app updates, anc then updates within the in game content manager is horrible.

1 Like