Update presumably required but not available

Yes. I tried logging out of MS Store and Xbox App. I even uninstalled and re-installed Xbox, and did a Reset/Repair on Gaming Services.

OK, how about an uninstall/reinstall of the MS Store ap.

IDK about other versions of Windows, buy my OS won’t let me Uninstall MS Store (I can repair/reset).

I also am unable to uninstall the MS Store app, but did repair it to no avail.


Here is a link on how to do that.

Completed those steps, still shows all Apps up-to-date.

1 Like

The only thing else I can think of is in regards to permissions, or a firewall issue.
Are you running the sim as an administrator?
The only thing I can recommend after that is that you submit a Zendesk request from the “Support” tab at the top of the page. In there, see “submit a request”
Kind of a laborious process though, but they do seem to get back to you farly quickly if you have these kinds of issues, may be a bit busier after the update though.

Yeah, I’m the only user on the computer, so everything I do is as an Administrator. I’ll try Zendesk, I guess, but I have an outstanding ticket from June 2021, haha. I have no faith in them getting back to me.

1 Like

Happening to me too.

please help us

Thanks TenPatrol. That enables me to spin the globe again. Does that mean the mouse side-button that I assigned to reveal or hide the Toolbar when I’m in VR won’t work now? And if not, and I re-assign it again will that trash being able to spin the globe?
I’m just staying off flying the sim again until I feel confident things will work.

As long as you are using the default mouse profile, you can make changes to that and all should be good.

Just tried a flight along the Italian Riviera. My Thrushmaster joystick keeps cutting out. I touch the VR throttle and that immediately jams at full but then the throttle on the joystick works again for a minute, then I go through that cycle again. I landed and had no breaks and the plane would not slow down and on the ground the throttle stopped working on both the Thrustmaster and in VR so jammed itself at full so I was just careening around the airport avoiding gasoline trucks with wingtips hitting the ground so had to pause then exit the game. For me, this is SNAFU unfortunately. It was nice to get airborne for that short flight though for the few minutes that it did work.
I had lots of stuttering graphics with the general options set to the last time everything worked OK, so I had to reset the general options completely then pause and make an adjustment, then another etc. Not good at all. What was clear before is just smudges now.
I see my frame rate is in the low 20’s most of the time, which seems pretty low too.

Could this be your issue?

OK fellas I found the fix! uninstall
So after uninstalling make SURE you keep your old directory. REINSTALL.
When it asks you to install specify the same install path as the old one.
It should then skip the base file size and remember your old install, installing only the new updates required.

This worked for me completely! Hope this helps

1 Like

Certainly willing to try that, since at this point I really don’t have a Sim.
Would you mind listing the necessary steps? I don’t trust any assumptions I might make with this Pitt bull right now.

  1. Don’t delete your file directory
  2. Uninstall via ms store
  3. Reinstall
  4. Specify old directory path when the sim asks where you would like to install e.g d:/flight simulator
  5. Sim should now detect the old directory skip install and then allow you to update as usual

I tried the last suggestion some time back and still had no controls whatsoever after landing anywhere.
Today I updated to the latest build and according to what I see everything is up to date.
I started flying using the default mouse I made that allows me to press the Logitech M510’s forward left side-key to launch the menu, but that didn’t work at all and I still could not rotate the World Map. I reverted to the generic Mouse Profile so now I can move the map but can’t see the menu when in VR.
Flying an Icon that little GPS with half the screen taken up by a “Select a Waypoint” section is no good so I want to use the GPS from the menu, but since 2 updates ago, I can’t even access it in VR.
My Joystick is a Thrustmaster T16000 and about 3 updates ago it was ok. Everything I assigned worked. Now things that work in flight don’t work after landing. Something seems to be messing up the entire sim now. I have no rudder control after landing and not sure if I did on takeoff as I hadn’t moved it much but noticed no directional change on the runway at all.
My pre-assigned Thrustmaster keys for toggling the parking brake, (Key 7) and for just applying the brakes after landing (Key 8) don’t work at all after touchdown so every landing is a totally uncontrolled disaster after touching down. I’ve rebooted etc but am getting nowhere. This is after leaving it alone due to similar problems 3 weeks ago. Now I’ve also got some new floating airport direction indicator or something floating around in my view that wasn’t there before. The Joystick’s throttle control often just goes dead and doesn’t come back until I click it with the mouse in VR. I think that bug is affecting other things too, but when you are trying to keep the plane from flipping over as you careen all over tarmacs and grass after landing it’s hard to know what or if the mouse somehow locking up other controls.
At this point I think I’d be willing to pay someone to help me get this thing set up and running. All the videos are out of date shortly after being published due to the sim changing constantly so I can’t rely on any instruction from those and I’ve spent a lot of time watching videos only to learn well into them that the person is using an Xbox.
Does anyone know of someone I can contact for interactive assistance? I’m at my wit’s end with it.

suggdozer …thanks for that advice. You mention re installing in order to do update as usua,

The current issue isn’t that I can’t update, in fact the latest update installed just fine, and in the program I installed all the updates. so everything is as up to date as I can make it. I even got new drivers for joystick and graphics card and updated Windows 10.

The problem is my custom mouse profile won’t work at all despite the program seeming to indicate it is fine, and with the Default Mouse Profile, when .flying in VR (which is all I do), various controls go nuts. The throttle opens all the way or just closes completely, the yoke moves uncontrollably etc., and on landing nothing works …no throttle control, no brakes, no rudder etc. Those things work before takeoff but it seems like leaving the mouse pointer anywhere near anything in flight, removes joystick control from that item and others and it all just goes erratic. Sometimes I click on a control with the mouse and I can then use it again for a moment or two via the joystick but a moment later it all goes nuts again.
Impossible to land other than just crash because no controls work after touchdown. I’ve contacted Zendesk but get only a canned response not even related to my question.

I haven’t re-installed as you suggested since ‘updating’ wasn’t the issue. I’m beginning to wonder if I need to uninstall everything …FS2020 Premium Deluxe Edition, HP Reverb G2 Headset, Logitech M510 Mouse, Thrustmaster T.16000 M joystick …and start all over again from scratch??

Under “General Options” “Accessibility” “Cockpit Interaction System” are you in Lock or Legacy mode?
There are some issues with mouse interaction in VR, do a search for
mouse VR
in the search function for more info.