VR - when mouse cursor hovers a panel, no input from rudder, throttle, propeller, etc. Ailerons and Elevator OK

:green_circle: Required

Have you used Developer Mode?
no
PC Specs:
5900x / 3090 / pimax 8kx
Aircraft:
c208
Area of the World / Flight Plan:
PNG
Airport (If applicable):

3rd party addons you were using at the time (Mods/add-ons/community content)
none
Peripherals:
saitek quadrant, joystick combined using vjoy as 1 device, and saitek pedals
Feedback/Bug Description:
in VR upon moving the mouse over a panel like vfr map or weather, nearly all input from the quadrant and rudder pedals is ignored. When the mouse cursor disappears after a few seconds, if its previous position was over panel, still no input from quadrant or pedals. you must move the mouse away from the panel to regain control.

my quadrant & joystick is a combined vjoy device. the joystick still works. the only button on the quadrant that works is the ‘show vr toolbar’.

functions that do not have any input when the mouse hovers a panel:
rudder axis
left/right toe brake axes
throttle axis
propeller axis
mixture axis
flaps & gear up down buttons
brakes toggle button

:yellow_circle: Optional

[ ] Multiplayer session or [x] solo flight

Multiplayer settings: [ ] Live Players [ ] All Players [ ] Group Only

Weather settings:

Server: [ ] East USA [ ] North Europe [ ] West USA [ ] West Europe [ ] SE Asia

(PC) Are you using DX12?: no

Added my vote. This is really annoying.

Hope they fix this quick

Long ago I switched to external tools for mapping my controllers (Axis and Ohs, FSUIPC). Asobo will probably never reach such sophistication level (e.g. automatically linking controller profiles to individual planes).
However, if this is broken as reported here, Asobo should fix it.

2 Likes

Does anyone know if this issue also exist for FSUIPC ?

Got the same bug. Thank god I thought I was going mental

I regularly find that my throttle quadrant and mouse stop working in MSFS2020 but are registering and showing as expected in FSUIPC whilst the sim is running. Are there issues with the simulator reading USB ports and devices?

Flying my first flight in the Beta and also having this issue. In addition to what was reported the autopilot controls on the honeycomb bravo also do not work when hovering the mouse over an open panel. Once you move the mouse away from the panel everything works normally.

Just tested today and and with the mouse or VR controllers on a panel the pedals do not work but yoke does.

1 Like

Just made a flight in the C172 (G!000) from EDDH to EKEB.

Throttle and Mixture levers worked throughout the entire flight.
But elevator Trim got stuck.
I have assigned Elevator Up/Down to the Trim hat of my CH-Products Fighterstick.
If I click on the Trim wheel with the mouse, I can use the Trim hat again on my Joystick again.

I’m not sure we’re talking about the same issue :thinking:

Same problem here, mouse on ATC panel and loose all controls ie steering and throttle until the mouse is moved back onto dash area then all is well.

How about you move the mouse away from the panel? Would that be a too complicated a fix? I have a really hard time understanding the “issues” people are complaining about. How can you people plan any flights or learn to fly any planes, if this is an issue for you?

Just because it’s not an issue for you personally doesn’t mean it shouldn’t be fixed, it’s a Bug and therefore needs to be fixed.

Everyone uses toolbar apps differently, please try to understand this.

It is regression so why is it OK for something to change for the worse?

This is not an answer. It was working, it doesn’t anymore hence it is a bug.

3 Likes

I can Confirm the bug, very annoying

@themadmaker

When you lose rudder and quadrant control, does the CTRL-0 trick keep it from happening? In other words, are the panels broken in just the default view or in all views including instrument views?

It’s important that CTRL-0 continue to work if the alternative is to lose control of the aircraft whenever you forget to move the mouse out of one of the panels. Will make using the GTN750 dangerous.

I have this bug too with the beta. If I open an ingame panel such as navigraph my throttle and pedals stop working, but stick works fine., if I click eg on the throttles in the virtual cockpit, it starts working again.

Why do you people always have to say unkind things about other people? A lot of people have got very used to NOT having to think about where we leave our mouse after using a toolbar window.

It’s just another thing to have to consider in an often very busy cockpit. It needs to be resolved and has currently left me feeling like I don’t want to fly at the moment. One bug too many for me.

4 Likes