Updated today - now can't launch!

Why is the update process always a complete nightmare??? I was downloading the update, was near 100% but when I came back the window was gone and now when I try to launch I get “This app cannot open. Check Microsoft Store”. No amount of Xbox app launching or Store launching is fixing this. Anyone know the solution?


I am so ready to sell off my entire flight sim setup. This is not something that should be a nightmare every single update and being the updates are forced we are forcibly subjected to this stress time and time again. I am so done.


I am experiencing the same thing right now and I don’t know how to solve it. Does anyone know whats happening?


Continuing the discussion from Updated today - now can't launch!:

Same p

same problem it’s does not work but for me after the update and after launching the program Msfs was stucked on " up to date checking" no other possibility that to do alt+ del +suppress to go out
Anyone knows the solution ?

1 Like

Hello @Pantelleria34, have you tried removing any mod or addition from your community folder. Restart your internet router/modem. Restart your your PC, and start MFS. Don’t start any addon yet.

Another option is to use task manager to end MFS or restart your PC. When next you start MFS it would give you the option to start in safe-mode

Have a blessed weekend

I’m not the OP, I’m the guy that posted the thread he linked to. None of that works. I tried everything. I work as an IT Tech for the past 22 years so I always do my due diligence before posting. Nothing has gotten it working for me so far. Hope there’s a solution soon. It’s very very very frustrating to deal with problems every single update.

@Rev20105189 sorry about the situation. Please do not sell off your entire flight sim setup.
Other than suggesting that you try a VPN before starting MFS, and if it successfully loads you disconnect the VPN.

The other advice would be to backup the MFS Official/OneStore folder. Uninstall MFS and XBox app, restart the PC and reinstall them again.

Trying checking the MS Store and getting all possible updates. There was a gaming services update and an MS Store update recently - these need to be up to date

Update all apps via ms store app.

Update OS to the latest version via windows update - also chceck optional updates.

Terminate, repair and reset gaming services.

start > settings > apps > click gaming services > advanced options > terminate > repair > reset

Restart PC.

If doesnt help - repair microsoft flight simulator.

Turn off AV software and launch msfs as administrator.

Did that.

Did that before opening MSFS to update.

Haven’t tried that but will, thanks!

How do you repair MSFS? I’ll give it a try. I did disable Avg anti-virus, no change and it didn’t touch any MSFS files, nothing in quarantine and it’s on the exempt list.

1 Like

start > settings > apps > click msfs > advanced options > repair

Disable all addons on your community folder. I had one that was causing a problem like this.

i dont know what to think of this, i was in IT too, and i quickly solve any issues.
the ms store procedure , well, i agree, its …no word allowed.


Reinstalling the game is a good idea

I’ve said it already, I’ve removed all add-ons from the community folder :wink:

I am NOT reinstalling the game every update!! I had to reinstall last time and the game is over 126gb. That suggestion is simply not a viable answer!! :-1:


Same here, I updated to 7 and worked couple of time’s, last night I started the game and somehow stuck at the window where checks for update and nothing was happening. I was not going to the main menu. I had to ctl-alt-delete to force exit the game.
I also did clear the community folder, and did not help.
Anyone can help on this issue?

Your problem is drive space. It crashed near the end of your update because you don’t have enough space on your drive Free up some space and run the sim again, it will check for updates and start where it left off and complete your update. Good luck.

Wrong!! I have a 1 terabyte drive, plenty of free space available.

Guys… DO NOT try a Reset under Apps-Settings-Microsoft Flight Simulator-Advanced Options!!! I did the repair, didn’t work. Tried reset and it deleted the whole entire program from my hard drive and now I cannot even reinstall it cause I get an error in the XBOX app when trying to redownload it.

Sorry, but this is the end for me. I am done with MSFS. Just gonna cut my losses. I may keep my setup for X-Plane but may sell off my gear. Not sure yet. I am sure though that I am not wasting any more time of my life dealing with this nonsense just to have to go through it all over again within another month or two.