UTC time much slower than the actual time

Hello! So I am currently in middle of a flight from CYVR to KJFK

I was wondering if lagging would change the UTC time on the planes clock?? It’s currently running about 30 mins behind.

It’s currently 1:22am which is 08:22 UTC however the plane clock is saying 07:41… also can someone explained the clock time and elapsed time? Because the clock should be the time since started the battery? And elapsed is supposed to be time up in the air… which I have not been up yet, I am still taxing.

I can’t send pics cause it keeps claiming it to big… and I can’t downsize it.

Ps: anyway I can reset the time? Also this also happens with the weather timeframe… its bright when it suppose to get dark.

It’s now 1:35am or 08:35 UTC and the plane says it is 07:47 almost closing in on an hour behind now…

Have you changed your SimRate? If your simrate is lower than 1.00x the clock time in the cockpit also slows down.

I’ve seen this issue somewhere before where someone was complaining why it took them forever to reach their destination, when I had a look at the video recording, the elapsed time doesn’t flow the same with the video time. So I told them to check the simrate, and restore it back to 1.00x and that solved the time discrepancy.

If you’re not on Live Multiplayer, you can reset the time by opening the Weather menu from the top menu bar. Just click the LIVE button and you should be back to the current live time. But you still need to check your Simrate, if it’s still not 1.00x real time, it will always drift away.

1 Like

I’ll check when I arrive. I had flights that should’ve only take 4 hours and took 16 hours!!! What should the simrate be? 1?

yeah, should be 1x. If it took you 16 hours to do a 4 hour flight, you’re probably on 0.25x sim rate. Which is a quarter of the time. So it took you 4x as long to finish your flight.

UTC on the plane clock is now coming up over 2 hours behind but only been in the air for an hour.

You don’t need to check when you arrive, just look at your keyboard binding for changing sim rate, and just press that keyboard binding to increase it until you get to 1x. Check your chrono clock, and make sure the second flows at the same time as real time.

Yeah that seems like a simrate issue. You can not view the actual simrate but the workaround is to reduce it to the slowest (1/4x) and then hit the acceleration button twice. So you are at 1x simrate.

Buttons for this can be set in control options.

1 Like

I’ll check it. I have the minimum requirements, the PC and all is fine just a RAM issue lol. So I always lag or it crashes. I have my settings on high cause I want the best scenery and realistic.

Great now it just froze… :confused: ugh, I still can’t get in a decent flight for once!

What? Sim rate has nothing to do with graphics settings. Sim rate is the speed that the sim simulates the simulations.

You’re probably confusing with render scaling… Keep your graphics settings the way it is. Just press the keybinding that is used to change the simrate. which changes the speed of the simulation and timing.

You should change your graphics settings according to your hardware capabilities. If you don’t want lags, drop down the graphics settings. But this won’t affect the sim rate.

1 Like

It lags different all the time, sometimes it takes so much and other times it’s only a little bit.

( the time and weather sim is always a prob)

On the keyboard what button is the simrate thing?

One more thing, why is the elapsed time running while still on ground prior to taking off? It should only start when take off.

Depends on the aircraft you use I guess. I’m using the FlyByWire A32NX, and the elapsed time never start on the ground. only when I press the button to start the timer. But on the default A320, the elapsed time starts as soon as you press “Ready to Fly” button at the start of your session. I’m guessing this applies to any other aircraft.

If you want to try, you can go to your BIOS and look for Hardware Virtualization Technology and VT-d setting. Disable them. I disabled mine yesterday, and my stutters and lags disappear. Maybe this could work for you too.

I don’t know, you have to check in your Control settings, I already removed my default keyboard binding. My keyboard only have the ESC button bound, everything else is blank. So you’ll have to check the button on your end. Just press ESC to go to the pause menu, and select Controls, then use the search box to look for “rate” and you should see what key it’s bound to.

1 Like

Thanks so much guys! I will for give all these a try!!

Had a very hard time looking for the hardware virtualization technology and VT-d BIOS anywhere on my laptop

Well, I guess it doesn’t have it… That usually means it’s disabled by default since your laptop probably doesn’t support it to begin with.

It’s a pretty fancy computer, RX Radeon and has Nitrosense with max settings to close to 6000.

AMD Ryzen 5 2500U with Radeon Vega Mobile gfx 2.00GHz

A 64 bit bit operating system x64 based processor

A Nitro AN515-42 laptop

Well, not in-sim at least. SimConnect provides the variable SIMULATION RATE so if you have any software allowing display of the SimConnect variable, you can use that.

Also the Mobile Companion (which I highly recommend) has a display and buttons to modify the rate:

Sorry for off topic :slight_smile: Just wanted to throw this in.

1 Like

Well AMD may use a different term for their Virtualization technology. So even if they don’t use that particular term. They may be using their own name. I think they call it AMD-V

Having a very hard time trying to find how I know what my simrate is… I know how to control it but it doesn’t tell me what it is… like how do I know if it is at 1

How do I reset the time… its now running 4 Mins ahead