Various WASM aircraft not working with 1.37.15

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Which aircraft are you using that experiences this issue?

PMDG 737 600 700 and 800 and the DC-6.

Brief description of the issue:

I get an error that says additional software is needed and I should restart the sim. But after restarting no additional software is downloaded.
I tried reinstalling the aircraft but that didnt fix the error.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Select PMDG aircraft.

PC specs and peripheral set up:

Xbox Series X

Are you using DX11 or DX12?

?

Are you using DLSS?

?


:loudspeaker: For anyone who wants to contribute to this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

Are you using DX11 or DX12?

Are you using DLSS?

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Same issue, different a/c.

Provide extra information to complete the original description of the issue:

Trying to load MilViz 310R and get the same message. Restarted Xbox many times.

Are you using DX11 or DX12?

Are you using DLSS?

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes, multiple WASM aircraft are “missing additional content”

Provide extra information to complete the original description of the issue:

WASM aircraft are “bricked”, key binds inop, switches work with mouse but no function behind the switch/button operations. After updating to latest beta build, WASM add on and also had an Insider program update.

Are you using DX11 or DX12?

No, on Series X

Are you using DLSS?

No, on Series X

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

Same issue described in the Topic

Are you using DX11 or DX12?

No I’m on Xbox X

Are you using DLSS?

NO

If relevant, provide additional screenshots/video:

Go to the Apps and Games menu for X-Box and update the sim, which should solve the issue.

Mathijs Kok
PMDG

1 Like

Hi Mathijs,

Unfortunately this doesn’t resolve it, it seems something went wrong with the Beta update 1.37.15 or the Microsoft Flight Simulator Add-on support for Xbox, which is updated every Monday.

Is unclear what is the cause at this stage but my own products are also affected, raising a ticket with Asobo via devsupport in few minutes so they can investigate.

Best,
Raul

4 Likes

Yep. Just tested with updated add-on-support and updated SIM. Lots of planes are broken with the ‘missing functionality’ message.

Left the beta as soon as I noted those issues yesterday, hope in a quick fix because we can’t fly on Xbox.

2 Likes

So are you able to fly WASM airplanes with SU14? can you give me some airplanes examples?

Best,
Raul

On beta, PA-28 Arrow III steam gauges didn’t work, Cessna 414 Chancellor mixture levers didn’t move at all.

Out of beta: everything works and that warning message did never pop up.

2 Likes

Thank you Sander.

Best,
Raul

1 Like

warningbtext pop off, blackbird c310r lost whole efb functionality: wear and tear, state, obwnership etc. yoke visibility can not be swithed off.

Totally Broke!

JustFlight: No Tablet & no Garmin :see_no_evil:

Carenado: Levers Broke

PMDG: Broke

Additionally, the LOD on the XBOX has been extremely reduced. Muddy textures as far as the eye can see…

Not a particularly good outlook for this last SU… Asobo… What’s going on with you?! Is everything already in the MSFS2024 team?

6 Likes

Hi all,

Thanks for your feedback re WASM issues with 1.37.15.0. We’re aware of these issues and will be investigating. This has now been feedback-logged on our internal system.

The MSFS Team

9 Likes

Don’t know if it’s relevant but reports of in sim release notes showing version number 1.37.14.0 in this post.

Yep, we’re also aware of this and it has been reported! Thanks :slight_smile:

3 Likes

I confirm that the SU15 Beta was ok until versions prior to 1.37.14.0 or 1.37.15.0

Unfortunately, it appears that subsequent updates have adversely affected the WASM module. On a positive note, the game’s performance has improved, running faster than previous versions.

I am hopeful for a prompt resolution, now that this issue has been officially logged.

I don’t know if the IndiaFoxtEcho F-35 uses WASM but I would assume it does as it’s a complex aircraft. It can be loaded but it’s unusable as a few minutes after loading in the simulator just keeps freezing all the time. Again, this is surely not an aircraft issue since it worked flawlessly just yesterday (1.37.13.0). After updating everything today it is like this.

After Dune install:
“Some dependencies are missing or out of date.”
(fs-base-ui-widgets (current 0.1.47, last 0.1.46))

I got this message immediately after installing the Dune Expansion Pack today, which I installed after the mandatory (SU15?) update. I’ve never seen any message like this in all the MP installs I’ve done. I don’t know what it means, or how to fix it.

Do you have the same issue if you follow the OP’s steps to reproduce it?
Yes

Provide extra information to complete the original description of the issue:

All third party aircraft that use WASM display a Warning message about “additonal missing content” and don’t load up in the sim correctly.

Are you using DX11 or DX12?
NA

Are you using DLSS?
NA
If relevant, provide additional screenshots/video:
Screenshots identical to previous